[Con] UI freeze upon joining citizen


#1

Title: Some issues upon joining traveling carpenter

Summary: I was pleasantly surprised when a traveling carpenter wished to join my bustling town (especially since the carpenter I already had wasn’t doing much crafting). However, I found that when I selected him to have a closer look, the information normally showing up in the bottom left was no longer there (Fig. 1). It turns out the same was true for any other citizen or object I subsequently selected (Fig. 2). The guy did not show up in the Citizens and Crafters & Professionals dialogs either. Finally, the sun icon in the top right of my screen froze, day apparently no longer progressing.

I thought the entire day-night cycle had frozen rather than just the icon, as the day seemed to last rather long, but upon reloading, I had two ‘rays’ of sunlight left, so perhaps time had continued and only the updating of the icon was broken. Also, upon reloading I was able to view information on selected citizens/objects again, and Campton (the new carpenter) had shown up in my dialogs (Fig. 3).

In all honesty, I am not even 100% sure these issues really were caused by poor Campton, but it is close, something like 90%. I tend to click things a lot and look at the information, so I likely would notice something like this quickly, and I clicked Campton as soon as he showed up, which is when I first noticed it. The sun icon I noticed later – it may yet be unrelated with a probability higher than this 10%. Perhaps should have made a separate report, but I’m making so many already!

Steps to reproduce: I guess you would just start a game and wait for a traveler to show up who wishes to join your town. Then see if these same problems occur.

Expected results: Campton would join, I would look at his information, the sun would shine ever less brightly, and life would be familiar and good.

Attachments:


Fig. 1: Campton’s name and information do not show up in the bottom left upon selection. Note his name also is missing from the Citizens dialog.

Fig. 2: The same is now true for other citizens, and objects as well (not shown).

Fig. 3: Upon reloading, Campton’s name shows up in the management dialogs. Selection also works again (not shown).

Versions and mods:
No mods, latest release version in Steam at the time of writing, version 0.1.0 (release 99) according to the title screen.

System information:
OS: Windows 8 Pro 64 bits (6.2, build 9200)
Processor: Intel® Core™ i5-3450 CPU @ 3.10GHz (4 CPUs), ~3.5GHz
Memory: 8192MB RAM
DirectX-version: DirectX 11
Graphics card: NVIDIA GeForce GTX 660


Impressions of Alpha 4 Release 114
Crash bug while loading
Video Bug reports for Team Radiant Alpha 4 r122 Part 2 out now
Bugs from Alpha 4
GUI Bug -- "Hint Box" Doesn't Update
Back in Action w/Youtube Series
Alpha 4 - Corrupted save
Alpha General Questions [the common stuff goes here]!
Crash bug while loading
Citizens remain in roster after dead
[Dev Blog] Steam Unstable Updated to Alpha 4 Build 118
[Dup] [R118] [STEAM Client] HUD selection focus
[R114] [STEAM Client] Town view HUD text slightly off
Playability of the game
#2

It definitely sounds like you had a javascript error that froze the UI. But was it Campton’s fault? I would also love to know :slight_smile:


#3

Pitiable Campton… he just wanted companionship.

EDIT: aw, turns out he’s a diligent sweetheart, too.


#4

It does seem to be related to joining citizens. Happened again in the new release. 15:29 in the video: information missing from dialogs. 15:50: selection information missing. Did not check for other signs of UI freezing (forgot at the time that you had pointed that out as a possibility), but there you go.

EDIT: Oh! The debugging tool thing in the bottom right was open, and you can see there that that is, in fact, frozen.


Impressions of Alpha 4 Release 110
#5

Confirming
I have found that when a new citizen of any class joins that pretty much nothing is selectable and they won’t show up in the citizen list. Work around. Save exit game restart game. Presto all is happy now.


#6

Save load is even quicker and works too, just for a little tip :slight_smile:


#7

Confirmation for the new release.

28:19

Also see this report.


[Con] All villagers stuck in the ground
#8

Summary: After some time in the village the weaver workbench became the only option in focus.

Steps to reproduce:
1) Unkown at this time. Working to reproduce.

Expected Results: When selecting another workbench or item expected to see the otpions for the item selected.

Actual Results: Weaver workbench remains the focus.

Notes: Not sure how this happened looking into it. A save and load appears to fix this issue.

Attachments:


#9

Experienced same once in R144. Focus fixed on Carpenter Workbench. Cause unknown, no error message. Save&loading fixed it.

Also sometimes my HUD displays nothing at all. This happened in R118. Cause unknown. Forgot to take screenshot, though… Save&Loading fixes this also.

These bugs just happens after playing a while. Not sure whether it is caused by the long play time or it happens randomly and playing longer increases the chance for it to happen.


#10

nice report @digitalFatteh (the pictures really drive it home)… and thanks for the confirmation @Aron0621


#11

My work around for this is to select the item in focus then select another item then the issue goes away for that item. It may show up again later for another item but then just rinse repeat.


#12

Both reports by @digitalFatteh and @Aron0621 sound like a UI freeze to me, akin to that seen in this issue and this one. The identical colors on the debug bar in the screenshots strengthen this suspicion. A save and load does seem to fix that sort of issue, so that fits as well. What @deakon is talking about would not fit, though, so maybe that’s a different thing. Or maybe I’m just wrong.


#13

I didn’t notice any changes when selecting the weaver table and then another object. Just stayed on the Weaver tooltip as its main focus. SO it might be the UI freeze again.


#14

thanks @Phagocytosis

@digitalFatteh, did you happen to notice if you had had a new settler join your settlement?


#15

I just had a footman join earlier.


#16

I remember now. it was right after a settler joined my settlement when my HUD froze… I realized it when I clicked to see her name.


#17

excellent! then i suppose we can merge with this thread, as @Phagocytosis suggested… :+1:


#18

iv experienced the same issue, and get the same error report every time

each time the settler shows up at least.


#19

Can confirm this issue. Had a foot soldier join my village and my focus locked to the Weaver (which I was using when I accepted the new villager)… Could not set the focus to anything else, and selecting the woodcutter’s bench brought up the weaver’s bench instead.


#20

Yep, still in R122.

13:10


[Con] Carpenter momentarily stuck placing crafted item in general stockpile
Impressions of Alpha 4 Release 122