Alpha General Questions [the common stuff goes here]!

A very good point, that’s something I’d been thinking about as well. At least with the new release, you can unstuck the crafter in this situation by deleting the item they’re stuck on, which wasn’t possible before. Even so, your suggestions would be better. Also, I don’t think a warning like that is in yet.

Another one that I had noticed but not yet reported. Again, seconded.

What I do is just have the bed(s) outside until the houses are done. Although I was presented with an issue surrounding that recently.

This one was suggested here.

Nope, that’s unfamiliar to me as well. It sounds like other gathered foods were not recognized somehow (I have seen it happen that far-away berries that were picked from bushes don’t get retrieved), but then, for the farmer to continue eating every turnip he gathers, something else must be involved too, where eating somehow doesn’t reset hunger levels; probably everyone is hungry, but the farmer gets first pick every time he picks something because he’s right there, or something. Regardless of the reason, I have not encountered anything along these lines. Feel free to make a report about it in a separate topic if you want to help out more :slight_smile:

That’s true, and often times the blueprints for windows and doors just get shown even when they’re not placed. Opening and closing the building dialog removes them, but they return quickly. Not sure why, but it’s something like this issue.

4 Likes

Hmm well I see, the only mention I have is that the allocators_[t] happened with a save game on this release, so it cannot be related to older releases.

Also if something require a save/load to be fixed, it is still a bug right? =p but since I cannot load games, I can’t tell if they were fixed or not.

I will try making larger farms to see if my farmers stop being such hoarders lol.

Yep, definitely! The save/load is just a workaround, but eventually it’s to be hoped that the dev team will fix it so nothing will go wrong in the first place, so you don’t have to do that.

Hi! I’ve just recently downloaded the alpha 4 official release of Stonehearth and I wanted to share some thoughts about the game and point out some bugs. Probably most of them are known… :wink:

  1. There is just 1 saw to promote carpenter and there’s no option to make another one in carpenter’s workshop… What happens if the only one you have dies?
  2. When building house, if some item is on the ground (my case was the flower in pot) next to planned wall, the item will get on top scaffolding. Maybe workers should clear the construction site first? (In my case after the scaffolding was removed, the plant floated in the air for some time and then it dropped on the ground.)
  3. When planning house layout it would be nice to make trees transparent.
  4. When accepting new villager, the game shows some errors. New villager goes by the fire and stands still and you can’t do anything with him. Saving/Loading helps to solve the problem
  5. About saving/loading: I’ve got a bug, when after loading, every villager was “in the ground” with only head sticking out… so I could’t play any more. Strange is that previous save of the same game, which was working, got corrupted too.
  6. It would be nice, if the promote villager screen was updated when a new tool is available. For example: On villagers management screen I’ve selected worker, then I’ve chosen to promote him. The panel with available jobs opened, but the tool was under construction, so I couldn’t promote him yet. Soon after the tool was ready, the panel didn’t update itself, so I needed to exit it and again go through all the screens.
  7. The crafting queue needs some tweaking. Sometimes it works great, but sometimes its stuck for example when weaver starts making something and he has not enough materials. He puts one ingredient on bench then when he has no more he is stuck. I think he should check if he has enough ingredients before he puts anything on bench. Also the “maintain in stock” option heavy relies on its position in queue. I’ve managed to make good chain of production: maintain in stock: 3 spindles; 2 cloth; 2 upgraded worker suits. But when I started to change the position in queue of the items, at some point weaver stopped working. I think that the “maintain in stock” positions should be “parallel” (without priority - just make what you can at the moment) to normal queue and should be done whenever crafter lacks materials.
  8. There’s a problem with fence gate. Apart it cannot be placed, I got a quest to make one for the trader in exchange for some reward. I’ve made one, but the trader didn’t take it saying that I’ve got none (it was in one of the stockpiles)
  9. When holding right mouse button and trying to move the view with ASDW, the screen moves slower than without right mouse button pressed.
  10. I’m aware that the building mechanism is its really early stages and there will be more functions… but please don’t forget to allow us to build interior walls :smile:
  11. There should be possibility to: destroy/deconstruct objects; demote villagers back to workers (in case you need more soldiers and there’s no worker to promote); choose which soldier takes the armor upgrade (maybe some inventory on character stats screen?)
  12. When building roof one of the workers fell down…but nothing bad happened to him :smile:

That’s it for now :slight_smile:

hey there @Peter… welcome aboard! :smile:

just a few responses, as I’m stuck on my phone at the moment …

I believe 1,4,5 and 8 are all known issues… and 2, 3 and 6 seem like excellent suggestions… :+1:

Welcome @Peter!

Some of these were indeed known already, and I’ve linked to their earlier reports so that this post can serve as confirmation for them, and so that you (and others) may find further information about them if interested.

  1. Link
  2. Good suggestion! Seconded.
  3. Link
  4. Link
  5. Link
  6. Another good suggestion :smile:
  7. The crafter getting stuck when not having the proper ingredients is a known issue that is not quite fixed, but has been given a workaround for release 118: you can delete the order and add it again. Before, even when you did that, the crafter would remain stuck. But it certainly could use further tweaking/improvement. As for the maintain in inventory suggestion, that sounds like a good idea to me. Perhaps at some point, we need another way to specify these kinds of orders when there’s a large number of things you want to maintain in inventory. As it is, the queue fills up rather quickly. Yes, you can scroll up and down, but it’s a bit clunky overall.
  8. Interesting. It’s probably related to them not being placeable (devs did that on purpose until they worked out the issue with placing them next to each other without them being pushed up), although I have not heard of this aspect/side effect (if it is indeed that).
  9. A while ago, it seemed to me like moving and turning kind of interfered with each other, so that you couldn’t really do both at the same time, and they alternated when you tried, so that it gets kind of jerky and slow. Link
  10. Fair enough as a reminder :smiley: I’m sure they won’t forget.
  11. Destroy/deconstruct objects. Demote villagers back to workers. Choose which soldier takes armor upgrade: couldn’t find this suggestion anywhere yet. Interesting one!
  12. Link

Thank you for your thoughts!

4 Likes

Ok I have a quick question. I noticed in one of the videos (which I can’t find), that you could name a stockpile. Uhm, is that not a thing anymore? I guess its not as important as many other things on the list, but I was just wondering. I’ve tried to name one, and it just doesn’t work. Thanks for you’re time :smiley:

Rename it & hit enter, that should do it. I don’t think the game saves the new name if you just exit the stockpile etc.

3 Likes

ahhhhh you’re good :blush:

1 Like

I can’t seem to update it to alpha 4

if you’re running via Steam, it should auto update… if you’ve previously used Humble Bundle, you’ll need to download/install the latest client from your applications page …

I didn’t get it from either I got it from the stone hearth page

then you most likely got the client via Humble Bundle… what did your alpha email look like?

don’t include any transaction details… :wink:

You mean my email address?

Cause I bought it a month ago so I don’t remember what i did

You will have received an email regarding the purchase so if you can find that you should just be able to find the links to your game.

For now everything will be located in your humble account: Humble Bundle - Log In

When in your humble account just go to the Stonehearth page within your library, you will be able to download Alpha 4 straight from there or see a box that you can click to receive a steam key. If you do that, and redeem the key in Steam you should then follow these instructions:

http://stonehearth.net/2014/01/02/stonehearth-revision-12-now-available-on-steam/

2 Likes

I didn’t have a humble bundle account then, I never received an email

Ah what you’ll need to do is create a humble account - try and use the same email you purchased the game with.

Hopefully your purchases will automatically be linked to your account, if they are not try using this page once your account is set up and see what happens:

https://www.humblebundle.com/store/keyresender

1 Like

try the link provided here (you’ll likely end up creating a humble bundle account in the process):

1 Like

Okay, can anyone tell me how to change the height of walls in build mode??

I’m currently stuck on like a 2 high wall which doesn’t seem sufficient for my needs. lol