[Dev 2380 (x64)] Empty Citizens Listing / the GUI gets stuck

Not even 5 min into the game, and had a bug from the Alpha 4 days return, where my citizens menu was empty.

AMD Phenom II X4 965 Processor, ~3.4GHz
16 GB PC3-12800
AMD Radeon HD 7770 (x2)
Crucial 256GB M4 SSD

Any hint on how to reproduce this?
Does it happen randomly? Sometimes the list is populated and other times not? Or when it’s empty it remains empty the rest of the game or until reloading?

1 Like

i dunno bout his, but i have read elsewhere that people get this problem when promoting hearthlings or some such thing

Honestly it was random. It had happened after my previous post about the carpenter double workstation. I had crafted 3 swords and 2 hoes, and went to assign them, and found that.

Upon restarting the game, I went into Town Defense do to zombies (it was night when I saved), and tried to reassign her as a carpenter (as it was saved before the error), and she went and picked up the tool and did the promotion spin, but the game didn’t promote her.

From there, I noticed that even when I tried to click on someone else, it stuck with her basic title card.

1 Like

The more I play with the same situation, @Relyss, the more I think it has something to do with the campfire. I noticed that the heartlings will prioritize sitting by the fire over anything else.

Here they are ignoring defense mode:

And here they’re ignoring work:

1 Like

Yes, many people noticed that they’re avoiding to work at night. It could be a cause, or it could be a consequence.

There has been old bugs about the bottom left panel getting bugged and messing up the game, but with all the changes between alphas, I don’t think that they are the same errors.

I can confirm the citizens thing, though I cannot confirm them ignoring defense. I think it actually has to do with promoting someone, as I managed to cause it to replicate the issue twice when promoting someone to trapper and someone to carpenter. The game did not recognize them as having been promoted, consumed the item, had the citizens name stuck in the bottom left, and the citizens screen was empty.

I will check the defense thing tonight.


Completely agreed. Consistently happens after I promote my trapper and carpenter.

Can confirm the empty citizens dialog (in Dev 2387). 10:44 in the attached video.


After promoting a carpenter pieces of the interface stop functioning. Citizens are no longer displayed in their tab, Some buttons stop functioning or dissapear, and while I can hover over and highlight things I can’t select them.

While I can still do everything to design a building the button to begin construction is absent. Throughout this I can still place down zones and hearthlings will interact with them as they should.
I can still save the game, I can’t get rid of the save load screen afterwards and have to alt-tab out to close the game, however upon loading the game back up everything is frozen and the interface doesn’t appear.

I had something very similar happen to my game last night. Somehow, though, when I restarted Stonehearth, my game actually did save. However, I believe there were still issues with starting construction.

1 Like

After messing around a little more I’ve found a way to reproduce most of the bug,

  1. set camp and wait for the tools to be placed
  2. enter the citizens menu
  3. select a citizen
  4. open the citizens stats page
  5. while leaving the stats page open click change jobs at the top of the citizens page
  6. close the stats page and promote to carpenter

Your citizen will pick up the tool and switch uniforms however the lower bar has frozen at this point and will display the citizen prior to upgrade, in addition clicking pause, play, or fast forward will change things as it should but will not highlight what is currently being used. In addition to those the building designer will not have the finalize button. At this point you can save however afterward the save/load menu will become unresponsive and upon load the interface will not appear.


@SteveAdamo, this could probably be combined with mine.

1 Like

roger that… stuck on my phone at the moment…


I’m glad @Mogarl found ways to repro. It’s really helpful for the devs.

1 Like

I got back on stonehearth and started trying to break it on a save where I managed to promote the carpenter and so far I haven’t managed to break it again on purpose without the steps I listed (although those steps don’t make the citizens tab blank) , but I have noticed something. The citizens page force closes any other tabs open upon clicking it, the exceptions being Notifications and Parties. However if you have the Citizens tab open it isn’t force closed by other menus, I don’t know if it means anything but I figured it was worth noting.

1 Like

Not sure if this is a similar issue, but after promoting my carpenter tonight I tried promoting a farmer, she didn’t want to accept her new job. Opened the job tree again and the tree is not in the UI as it should be. Saving and reloading helped (game got stuck in saving mod though xD)

1 Like

Something like this?

1 Like

Want to add to this.

Just had the error happen again in Dev 2395, but with a vender. I left the game running to go get something (very unhealthy) to drink, and when I came back, a vender had been waiting for a while. Opening the window, it was blank.

Closing the window, I noticed the notification bar was still lit up. The notification for him still being here was still there, and wouldn’t let me select it.

So I was starting up a new city, checking my new villagers’ stats(speed ftw) and deciding who to make a trapper and who to make a carpenter.
Anyways, while paused I promoted 1 to a trapper and 1 to a carpenter and then as usual(has happened multiple times in the recent builds) the windows/ui gets all bugged and there’s nothing left to do but restart/reload the game.