BUG: Blackscreen, game not starting

Resolution is 1920x1080. The window that pops up when starting the game has the correct resolution as I can slightly move it and see the borders at the right and bottom.
As to the system specs:
ATI Radeon 4870 HD with 512 vram.
System Memory is 4 GB.
CPU is a Intel Q6600 (quadcore at 2.4, not overclocked)

Like I said, the system specs seem to be in order as it worked right after installation using the installer launch option itself. It just refuses to acknowledge that my system is capable of showing more than just black when using the .exe itself or steam :smile:

The config file strangely sets the resolution to 1916x1054, changing it to 1920x1080 doesn’t change the blackness and gets reverted by the game to the original values. Keeping in mind that the window borders make up for the difference it “should” be fine.

Edit: Just for the sake of being completely sure I changed fullscreen to true and the values stayed at 1920/1080, still it’s only black.

given the completely black screen, starting with your GPU is probably a good start… your card is pretty old, but should still be able to hold its own…

have you tried setting the resolution to something smaller than native? how about disabling some of the more graphically intensive settings (shadows, etc.)

@not_owen_wilson, any advice or suggestions on the black screen-o-doom?

Okay, this is the config I am using right now:
enable_ssao" : false,
enable_shadows" : false,
msaa_samples" : 0,
shadow_resolution" : 256,
enable_vsync" : true,
enable_fullscreen" : true,
screen_width" : 1920,
screen_height" : 1080,
draw_distance" : 1000,
last_window_x" : 0,
last_window_y" : 0,
use_fast_hilite" : true

Not sure what I could possibly change to make it less resource intensive, as it’s pretty much all at the lowest possible option except vsync.
I’ll try to lowering the resolution, but I don’t think that’s the problem here as it worked from the installer without any changes. Does the installer start the game in a different manner than (options or parameters that I could add manually).

Turning the camera was slightly sluggish but that’s something I don’t mind at all and given the age of the card something I expected and used to, maybe once the optimization starts it will probably get a little better.

Edit: Tried 1280x1024, same result, although I have to admit the black is a really dark black, not some cheap washed out version smiles

1 Like

It’s really odd that it worked once, and then stopped. I’m wondering if this is related to this bug: [Con] SGT2/A1 Bug: Application doing nothing . (The short of is that you might need to change the permissions under which you run Stonehearth, until we roll out our next build which fixes the bug on our end).

Can you send me private message-me your stonehearth.log and gfx.log files (located in the directory where you installed stonehearth)?

1 Like

Don’t wanna spam your Inbox @not_owen_wilson and get banned in the process ducks and hides

Sure, I’m glad to help. As for the permissions, the User-Account has Administrator privileges, so that should cover it.

Now it’s getting scary, what kind of voodoo do you guys use in your installer?
I deinstalled the game and reinstalled it. Using the “play now” from the installer starts the game fine. Bells are ringing, I see your logo, the graphics.log still registers the raw shader problem, but I can see… colours.

So what is the difference starting the game from the installer and manually by clicking the .exe from inside FreeCommander (which I used for installing, too, btw.)?

1 Like

That would not happen :smile: (although I’d recommend you wander a bit through the forum so you gain ‘regular user’ status).

They need those files to check for possible causes, as they’re the ones who know what’s behind.

I guess you have your drivers updated to the latest version (from official pages) as you say you can play the game from the installer at least. I hope we can clarify this, I’m sure there are still people with the same problem.

1 Like

The only downside by starting through the installer is the fact that I’d have to deinstall the game everytime beforehand, which makes it a little… useless :wink:

Anyway, I’ll simply wait for an update through Steam and see what happens then. Logs have been supplied and the shader error from the log can’t be the culprit as the log starting from installer produces the same error and works. I’m at my wits end.

At the moment it’s slightly difficult to say something interesting keeping in mind that I’m not able to check the latest build and I don’t want to add comments to other topics just for the sake of posting, so this ‘regular user’ status is maybe not the easiest to achieve or does simply reading count towards it? I usually don’t say a lot if it’s not necessary.

it is a combination of factors… but i believe we can simply adjust your status manually… one moment please! :smile:

edit: ok, you’re a “regular user” now… your t-shirt should arrive in 4-6 weeks… enjoy… :wink:

The latest version of Stonehearth on Steam (unstable channel) contains a fix for the crypto issue (this might be the problem you’re experiencing), so give that a try if you are able to. It should be on stable Steam in a week or so.

3 Likes

@not_owen_wilson pulls off the combo!

I really wanted to toss in a MK “fatality” reference, but couldn’t quite manage it… such is life

I just tested the version that Steam downloaded last night (the one from the [latest] branch). Still the issue is a completely black screen when started through steam.
The only way to get the game starting correctly is by using the ‘Play Now’ option from the installer of the Humble Bundle.
Both Steam and Humble Bundle are under the ame User Account, the same rights and everything. So this Crypto-Thingy you linked to earlier shouldn’t be the problem (at least that’s what I guess from my small knowledge in that matter).

Anyway: it still confuses me why the Humble Bundle starts when launched right from the installer, but not with the shortcut or the .exe itself. So what is the difference IF there is a difference that’s to blame and not simply the voodoo-queen inside my machine.

Ah well, I always knew that I was the perfect beta tester, because I get all the problems other didn’t even think could be possibly happen.

@shamayne - That is indeed weird. What happens if you launch the Humble Bundle stonehearth.exe by right clicking the file and selecting “Run as administrator”?

Also, do you have a stonehearth.log file in the same folder as the executable or in C:/Users/[username]/AppData/Local/stonehearth?

1 Like

I just tried running this on a machine with Free Commander, and it still works (launching via the exe located in the Stonehearth directory, launching from the desktop link). That’s probably not the problem.

Anything else running on your machine (any performance ‘optimizers’ or such? I’ve seen some odd things with ‘razr’ utilities.)

1 Like

what about antivirus apps quarantining, perhaps? have we had any incidents of that yet?

1 Like

@Albert and @not_owen_wilson I’ve moved everything over into this thread, saves you having to jump between the two.

Sorry for just replying now. To answer the questions: I don’t use any optimizing tools running in the background. The only thing is an antivirus but I doubt that it’s the culprit either, because if it were it shouldn’t allow any version of Stonehearth (neither Steam NOR Humble) besides the only time I can get it to start up once is after the installation of the Humble Bundle download and using the start option from the installer itself.
It doesn’t matter if I run it using “Run as Administrator”, changing the settings under Properties to “Administrator”. I’d say I tried nearly everything with those options.

The latest updates through Steam didn’t change anyting at all. This is pretty strange as I usually don’t have any trouble running even games with the weirdest copy protections. Steam and UPlay-protected games for example can act up pretty weird when using an uncommon installation setup.

I am close to just rip out my harddrives and get a fresh one just to test this again with a complete “clean” installation of Windows and Stonehearth, just to see if it’s my actual setup, causing this behaviour, but this will take some time as I am frankly not bored enough to do this atm :smiley:

Guess it’s about time for a second test system.

edit: Quarantining or anything the like doesn’t seem to be in effect, as my AV clearly states when this is the case.

No, don’t blow away your hard-drive! Not until we’ve figured out what’s going on here :smile:

Okay, next theory: you’re getting a black screen (but visible mouse cursor) because somehow our embedded version of Chromium (that’s how we do Stonehearth’s UI) isn’t starting up correctly/at all. No real idea how or why, but let’s run with this.

If you are feeling adventuresome, try adding this to your user_settings.json file:

"logging": {
  "browser" : "spam"
},

This should be as child of the top-level entry in your settings files, so your whole settings files should now look something like this:

{
	"user_id" : "blah-blah-blah-blah",
	"collect_analytics" : true,
	"logging" : {
		"browser" : "spam"
	},
	"renderer" : {
		"enable_shadows" : true,
		"msaa_samples" : 16,
		"shadow_resolution" : 8192,
		"enable_vsync" : false,
		"enable_fullscreen" : false,
		"screen_width" : 1920,
		"screen_height" : 1017,
		"draw_distance" : 1000,
		"enable_gl_logging" : true,
		"last_window_x" : 1912,
		"last_window_y" : -8,
		"use_fast_hilite" : true,
		"enable_ssao" : true,
		"last_screen_x" : 1928,
		"last_screen_y" : 54
	}
}

With that in place, try running the game again, and forwarding me your log file. Maybe the browser is trying to tell us something…

2 Likes

Here are the log.files after including the browser logging. I hope it is helpful:

http://pastebin.com/uGQVR42i

I am having trouble with this game… Anyone??? I am not to good with a pc, but know hoe to but and download and install a game…So. I bought and downloaded and installed stonehearth. after the install and th 30.00 purchase of coarse. I click on start game and nothing happens. I then uninstalled and reinstalled using windows and steam. same result every single time… please help me… jsnhll02@gmail.com

Thank you,
J

I hear you are the guy to talk to in time of need!! I downloaded stonehearth, after purchasing of coarse. I then installed it… I then clicked start game…Nothing happened., I uninstalled…reinstalled…uninstalled…reinstalled using a different method…uninstalled…reinstalled using steam…uninstalled…reinstalled…Each time resulted in the same thing… NO LAUNCH… I even disabled anti virus during install… NOTHING…please help...jsnhll02@gmail.com

Thank you,
Jason