Steam Version black screen

no_longer_applicable

#1

Title: Steam version only (my humble bundle install works fine) gets black screen and nothing else.

Summary: Starting the steam install of the game opens up a black window. After editing the stonehearth.json file to use fullscreen the game opens to a full black screen and nothing else happens. No music or UI of any type. There is a Stonehearth mouse cursor however, both on the windowed and fullscreen. While windowed the mouse cursor changes to a Stonehearth one when over the Stonehearth window. I installed the humble bundle first, then Steam version.

Steps to reproduce:

  1. Install Humble Bundle install
  2. Install Steam version
    3)Start steam version

Expected Results: The game starts with music, a UI, and background.

Actual Results: Black screen

Notes: Stonehearth.log has several lines repeated:
2014-Jan-03 13:19:28.430369 | 2 | client | updating selection…
2014-Jan-03 13:19:28.430369 | 3 | client | no entities!

Attachments: stonehearth.log
stonehearth.log (1.8 KB)

Versions and Mods: Latest version as of Jan 3, 2014

System Information:
OS Name Microsoft Windows 7 Home Premium
Version 6.1.7601 Service Pack 1 Build 7601
Processor AMD Phenom™ II X6 1090T Processor, 3210 Mhz, 6 Core(s), 6 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 3503, 13/04/2011
SMBIOS Version 2.5
Video NVIDIA GeForce GTX 570
Locale Canada
Hardware Abstraction Layer Version = “6.1.7601.17514”
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 16.0 GB
Available Physical Memory 11.5 GB
Total Virtual Memory 16.0 GB
Available Virtual Memory 10.2 GB
Page File Space 0 bytes


#2

@Warstories, did you have a problem similar to this? Any suggestions for resolution?


#3

I think there is a similar report on curse, but at first read didn’t make much sense… might have been what @2_Zons is experiencing…

will try and dig it up when I’m back online…


#4

Additional info:

Alt F4 will close, as well as closing via the taskbar. Steam overlay pops up in the lower right corner properly when game starts.


#5

Yep, I fixed it! :smile:
Follow these steps and see if it works for you @2_Zons

Right click Stonehearth, go to properties > betas, switch the beta back to “None”. Wait for it to download, then switch back to the latest beta build (wait for that to download). Once that is all downloaded, launch up Stonehearth and it should work!


#6

nice… we should definitely toss this one in the “workarounds” thread… :+1:


#7

it’s just the first time you’ve used it.

It needs to setup files but instead of create then work it looks for the files can’t find them so displays nothing then runs.

2nd run and more thereafter will work, the GFX tests did this as well and this release does the same.


#8

I have started it several times. Restarted steam several times. I’m going to try checking integrity of local files right now. It shows all files verified. Still same problem.


#9

I tried switching back and forth from beta downloading over and over. Still same.


#10

well you can try changing the settings, disabling things in the settings to see what happens? Try uninstalling stonehearth, then installing the beta version


#11

Installed, changed beta status, re-installed. Vise Versa. every which whay. Same black screen.

I do have a workaround, use the humble bundle install.


#12

Pretty sure the humble install isn’t the latest release version tho


#13

correct, the steam client is the latest “bleeding edge” version…


#14

The humble install has changed since release date, so I assumed it was updated as well. If not than I really need to find a workaround. I would really like to be using the latest and greatest.


#15

OK, I tried it tonight and it’s working. Was there an update? I didn’t do anything, I just started hoping that there had been an update that fixed the problem. Either there was an update, or it fixed itself (doubtful).


#16

nothing that was publicly announced (or, at least not that -i- noticed)… and i’m assuming you are referring to the HB version suddenly working? either way, excellent news! :smile:


#17

My HB version was always working, my steam version works now. I didn’ t do anything to make it work from the last time so I can’t help in diagnosing the problem.


#18

i can only assume the auto-update either didnt trigger before, or some of the 1’s and 0’s got confused, and were repaired/installed on subsequent launches of the steam client…


#19

And now it doesn’t work again. :frowning:

I didn’t change anything this time either.