BUG: Blackscreen, game not starting

Title: When launching game only shows a black screen.

I have had this problem in previous versions, but it went away. I’m not sure if it was in one of the patches or something that changed on my computer. This latest patch (r41) has caused it to come back. Really unfortunate, I was dying to get a look at the new features. The game window opens, actually I had mine set to fullscreen so it opens a new screen, and all that is there is a black screen. The mouse pointer is there and it is the Stonehearth mousepointer. When I press space, I get the green quad arrow pointer, so game code is obviously running to some extent. As well, the steam “acceess the Steam community” window pops up in the bottom right. I’ve tried closing as many processes as I can to see if there is a conflict and I haven’t found a way to get it to work. I tried changing from beta to regular in steam and both don’t work.

Steps to reproduce:

  1. Start r41 steam version.

Expected Results: Game should show splash screen then start menu.

Actual Results: Game starts, but only as a black screen. Doesn’t crash or cause excessive CPU usage.

Versions and Mods: Stonehearth 0.1.0 Release 41, No mods.

System Information:

OS Name Microsoft Windows 7 Home Premium
Version 6.1.7601 Service Pack 1 Build 7601
Processor AMD Phenom™ II X6 1090T Processor, 3210 Mhz, 6 Core(s), 6 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 3503, 13/04/2011
SMBIOS Version 2.5
Video NVIDIA GeForce GTX 570
Hardware Abstraction Layer Version = “6.1.7601.17514”
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 16.0 GB
Available Physical Memory 11.5 GB
Total Virtual Memory 16.0 GB
Available Virtual Memory 10.2 GB
Page File Space 0 bytes

I’m really hoping there is something I can do to fix this. The fact that this problem happened before and fixed itself gives me hope. Like I said, I’m really dying to see these new features.

I just read that they updated humble bundle as well. The humble bundle install works fine, steam version still does not.

Even for the stable build (which I’m assuming there should be a new one of if they’ve updated HB)?

This is all very unfortunate, however at least you have now found a way you can play. :frowning:

As silly as it may sound, perhaps an uninstall and reinstall will solve the issue? Have you tried?

I was silly too, when I tried r41 and didn’t work. I adjusted some screen resolutions on the config files, and removed my incomplete mod file, which of course the game wasn’t able to read because the manifest was empty, and then it worked. I don’t think this is the case since my game didn’t even start, and I couldn’t get what was causing it since I looked into the game’s folder… u_u
But still, perhaps some configurations changed with the update?

Tried re-installing, verifying, no luck.

Alpha 2 steam version is still doing the same thing. Humble version works no problem.

i just quickly scanned the thread… had you already checked your system logs, in the event something was registered?

In gfx.log there are a bunch of loading resource XXXX but the last few lines are:

[00003.093 INF] ---- C O M P I L I N G . S H A D E R . shaders/overlay.shader@OVERLAY ----
[00003.093 INF] ----- INSTANCE_SUPPORT ----
[00003.141 DBG] Invalid node handle in h3dRadiantDecodeDebugShapes
[00003.141 INF] Adding Debug Shape node ‘renderer debug shapes’

This is the complete stonehearth.log file:

2014-Mar-02 02:08:22.780787logger initialized
2014-Mar-02 02:08:22.903794 | 1 | app | Running Stonehearth server on port 59805
2014-Mar-02 02:08:42.987943 | 0 | renderer.renderer | window closed. exiting process

1 Like

thanks for the follow up … @not_owen_wilson, anything peculiar stand out in the logs?

Edited title to show that it is a bug has persisted.

Weird. The steam and humble bundle bits are exactly the same. Whereabouts on your harddrive did you install them? (Default steam install directory, or did you move it somewhere else?)

I have a folder where all my steam games are installed, it’s a sub folder of the folder where all my other games are installed, including the humble version).

Might it be something Steam is preventing?

I finally figured it out. I am running Razor’s game booster, I tried turning that off and it works fine. Strange because some of the previous versions worked fine with it. It’s too bad, Game booster can really increase the performance of games.

So I guess the bug is that it doesn’t work with Razor’s Game Booster.



wow, good catch, and good to know! :+1:

I hate to have to bump this thread up again but this annoying bug is back. I do not know why. It’s not this new Alpha 3. It happens if I opt in or opt out. It happens if I have game booster running, or not. I’ve tried closing any extra running service and same thing. Game starts up to a black screen. A few seconds later the steam community notifications pops up in the bottom right, then goes away. Screen stays black, and nothing. The mouse pointer is working and using Stonehearth sprite. Game responds to an Alt F4 keystroke and closes. Man I wish I could figure this one out.

I hope so. Sometimes the game takes more time to load, and the first screen is black (that’s not a bug), I got once the Radiant logo not even showing before going to menu.

If it’s any consolation, there’s still a lot of people on the Curse forum that can’t still play the game. I usually don’t even use Steam. I launch the game from the Steam folder without Steam running.

I really hope you finally figure this out, I’m sure it would be of help to other people.

I recently bought this game including Alpha access. Now I have the little problem that whenever I start the game, I end up at a black screen.
It doesn’t matter which verion I use (steam, steam latest, humble). After I read about someone having luck with the humble install I tried it and I got it to work – once. After the installer finished I used the Play Now option from the installer and I could see the main menu. When I later tried to play a little more and used the .exe from the install I only got the black screen again.

The other guy with the similar problem had some razor optimizer running, but I don’t use such things. Any idea what might be causing this?

It seems like I should be capable of running this game without bigger problems as it worked from the installer itself. Just later it shows the problem of not showing me anything like the steam version.

Oh, I play in window mode btw. No messing around in the config either by editing or ingame.

Welcome, sorry to hear that you’re having some problems!

This is something that’s popped up a few times and you’ve tried the humble bundle and Steam version so that’s ruled out.

Let’s try this, see if there’s any luck…

Follow the steps in this thread, and make sure that the resolution width and height are the same as your screen, what is your resolution?



hi @shamayne, welcome aboard! :smile:

can you provide your system details, specifically your video card, memory and CPU?