[A16/A17] The buildings my hearthlings will not build (round 2!)

Hey Everyone,

Thanks so much for all the templates you uploaded in the last giant thread. I think I can speak for the devs when I say how helpful they were in diagnosing many issues back in A15. A17 will again focus on improving building, so we’re creating a new topic to collect all your templates. If you previously uploaded a templated to the A14/A15 topic, and it still does not build, please upload it again here. As you upload your templated (full instructions below), please be sure to include the specific build you are encountering the issue (i.e. A16 develop-2969), as well as the issue you are encountering (not starting, not completing, needed manually placed ladder, scaffolding not removed, etc.).

Thanks!
–Josh


In order to upload a building template:

  1. Save your build as a template in game.
  2. Open your game directory.
    Default location for a Steam install is:
    C:\Program Files (x86)\Steam\steamapps\common\Stonehearth
    Default location for a Humble install is:
    C:\Program Files (x86)\Stonehearth\
  3. Navigate to the building templates stored in \saved_objects\stonehearth\building_templates
  4. Locate the .json file for your template. For example, if you wanted to upload the “Clay Dining Room” template, find clay dining room.json.
  5. If you created this template in a recent version, you will also have a .png, for bug fixing purposes this is not important and does not need to be included in the .zip.
  6. Compress the .json file to a .zip file.
  7. Right-click the file you wish to zip.
  8. Left click Send to.
  9. Left click Compressed (zipped) folder
  10. Hit Enter on your keyboard.
  11. Upload the file to this thread in the Discourse by clicking the upload button in the editor and navigating to the file, or drag the file into the editor with your mouse.
  12. Important! Please be sure to list the specific build the template fails in. Also, please shared what the specific issue is. For example:

I am having issues with this template in Alpha 16, develop build 2969. The Hearthlings cannot complete the balcony on the second floor. I can build a ladder on the left side of the balcony, and then they are able to complete it. However, once complete, they do not remove all the scaffolding from beneath the balcony. [Link to template.zip]

If you encounter any difficulties with uploading (or are a new user), please post in this thread and mention the moderators (@moderators) and we will do our best to assist you.

This topic is a continuation of [A14/A15] The buildings my hearthling will not build Thread

5 Likes

Placed all my old builds in 1 brand new a16 552 release. Some buildings did get build wich previously did not. No adding stairs as far as i can tell, but there are some left over scaffoltings om some of the builds. Most could possibly be removed when placing ladders but that would not change the point. All builds are a14 and a15 scematics as far as i can tell. To bad the save file is to big :frowning: would be much easier.

tower not build.zip (8.6 KB)
json files scaffolting issue.zip (23.8 KB)


Uploading…
Uploading…
Uploading…

2 Likes

Mine is a problem with template placement causing 1 of 2 things to happen:
1.) the furniture is placed, floating in the world, but none of the actual building plan is visible.
2.) completely refusing to be placed into the game world, causing an error and subsequently disabling placement of ANY building templates whatsoever until game is restarted.

So the problem: It seems like each time I switch between the erase tool and slab tool, it creates an entirely new ‘entity’ or section of the building which leads to an overly complex template that refuses to be placed into the world. I can see this when mousing over certain blocks will highlight the rest of the blocks from that ‘batch’. The building is also entirely slabs(can’t place windows on slab walls :frowning: )

You can see how I’ve erased individual slabs on the roof in a random pattern and replaced them with different shades to create a tiled appearance. I first created the roof one color and then went over it and erased 10-20 blocks at a time and filled them in with a new color, then i repeated the process a dozen or so times to cover the whole roof. I suspect that I could circumvent the problem by erasing and filling all in one pass instead of a dozen+, thus greatly reducing the number of new building sections created, but I haven’t had a chance to test that(it’s very time consuming.) I will try this soon and post an update. I believe this is true because the main difference between the versions here is the roof tile patterning and also some shading on the white walls, while placing the simple version works 90% of the time and placing the complex version doesn’t work at all.

Hearthlings have been unsuccessful in their attempts to build the simple version and the complex(obviously)

I’ve included 2 versions of this building. The ‘final’ complex version, and an older simpler version, for comparison purposes. It would be cool to hear about other peoples’ experiences with the same problem, or if someone wants to play around with my earlier idea.

1.0 is the complex version, v1 is the simple version
alliance inn 1.0.zip (36.5 KB)
inn v1.zip (21.3 KB)


I originally planned on creating the entire set of these buildings from the game(should be easy to recognize) and release them all at once. I’ve spent hours passionately translating every detail into Stonehearth and I’m proud of the result, so I didn’t want to have someone reupping and stealing credit but it’s worth posting early if the data can help the engine grow. I feel that building is the most important aspect of the game since it’s like 99% of the creativity involved. It would cripple the game immensely if we didn’t have a robust and stable system to support that creativity freely and to make an epic city just the way a player wants it.

Thanks, I hope this helps in some way

3 Likes

Have building optimizations been included in any dev versions after A15 R537? I haven’t seen many building-related bug references in the release notes. I only ask because some buildings take a long time to re-test, and scaffolding tear-down problems haven’t ever gone away for the templates I submitted in the previous A15 building thread.

So if I don’t have to retest them to include them for consideration in A17, great. If I do, I’ll get on that this week.

I have time to spare, if you wish some help testing out the builds

1 Like

I have more lags, optimise games please :smiley: <3
and there is a bug in the menu selection of difficulty with writing
i am french man, (Note: I translated my game french If you are interested contact me.!)

1 Like

Thanks for the assist! :slight_smile:

Stone Watchtower:
http://discourse.stonehearth.net/t/a14-a15-the-buildings-my-hearthling-will-not-build-thread/14704/173?u=megashub

L-Shaped Wooden Inn:
https://drive.google.com/file/d/0B8jLpTsfTtT_eUw2RHFyTGJEMmM/view?usp=sharing

Known issues:
Watchtower - scaffoldocolypse; inside and out. The building builds, but the forest’s worth of scaffolding is never torn down, and in some cases isn’t even reachable to be removed (embedded in walls, stuck under 1-high stairs, etc).

Wooden Inn - unreachable scaffolding (also under stairs) and a weird issue where a single layer of scaffolding in line with the roof overhang on one side of the building that never gets torn down.

the stone bridge and bridge segment build with out trouble but i guess you already know that seeing they are small simpel build. The watchtower gave me a massive error and would not be placed at all.

release-553 (x64)stonehearth/lib/build_util.lua:546: assertion failed!stack traceback:
[C]: ?
[C]: in function 'assert’
stonehearth/lib/build_util.lua:546: in function 'unpack_entity_table’
stonehearth/components/wall/wall_component.lua:548: in function 'load_from_template’
stonehearth/lib/build_util.lua:112: in function 'load_structure_from_template’
stonehearth/lib/build_util.lua:120: in function 'load_all_structures_from_template’
stonehearth/lib/build_util.lua:124: in function 'load_all_structures_from_template’
stonehearth/lib/build_util.lua:419: in function ‘restore_template’
…rth/services/client/build_editor/template_editor.lua:25: in function ‘restore_template’
…rth/services/client/build_editor/template_editor.lua:76: in function ‘go’
…ervices/client/build_editor/build_editor_service.lua:274: in function <…ervices/client/build_editor/build_editor_service.lua:272>
release-553 (x64)c++ exception: lua runtime errorstack traceback:

I am able to continue playing and building other templates with out having to restart

Weird. Let me make sure I didn’t accidentally give you an older version.

1 Like

did you use a mod for furniture?

Nope. Re: mods - all vanilla

Try this version of the watchtower instead:
https://drive.google.com/file/d/0B8jLpTsfTtT_OU51ZENYcHUtV3c/view?usp=drivesdk

your wooden inn is completely constructed in a timely fasion with the exeption of 2 little spots of scaffolting beneath the stairs :slight_smile:

The stone watchtower is finally being build. They will take there sweet time seeing they want to place a massive amount of scaffolting. Still when build early on it won’t take that long. they did get stuck on a small part, which was fixed by placing a stair manually. For just that reason i would say it is still bugged. However after they placed the last part on the top, my game closed it self with out any error message :frowning: so don’t know about the scaffolting :smile:

Edit:

Second try after restarting i had to manually place 2 ladders in order for it to finish. After the last block is placed again my game closes it self

1 Like

The most annoying issue I run into lately is that often when trying to place mosaics (i.e., patterns made with the “foundation” block in various colors), the mosaic won’t place in the spot I want it to – I’ll click it to place in one spot and it will “jump” up or down several z-levels, sometimes offscreen into midair or down inside solid rock.

It seems to be very very location specific. I posted with more details about this problem in the prior thread ( [A14/A15] The buildings my hearthling will not build Thread ) but the problem persists in the current alpha (even in new copies of the same seed/map).

Summary:

Steps to reproduce:

  1. Use the json file I provide, put into your saved objects
  2. Create the building in a world
  3. Once finished, observe that the scaffoldings on the front walls are not fully removed.

Expected Results:
Scaffolding should be removed
Actual Results:
Most is removed, except two walls worth of it.
Notes:
The json file is here (pastebinning it): [JSON] { "header" : { "preview_image" : "\/r\/saved_objects\/stonehearth\/building - Pastebin.com
Attachments:

Version Number and Mods in use: A552

System Information: Windows 10 Dx12

http://discourse.stonehearth.net/t/a16-the-buildings-my-hearthlings-will-not-build-round-2/22200

1 Like

two-story bldg.zip (2.5 KB)

png below
a16 release 553 / develop-2972

I designed a building with a hole in the second floor, that I planned to have hearthlings access with ladders. When I clicked “build”, I got the popup error quoted below.

I loaded the building in a new game and got no error, but now it has the second floor simply floating. (I didn’t try building it since I was far short of materials.)

I’ve had several errors like this with building; figured I might as well try posting one. I’m really enjoying the game so far!

Popup engine error:

release-553 (x64)
…onehearth/components/building/building_component.lua:154: attempt to index local ‘entry’ (a nil value)
stack traceback:
[C]: ?
…onehearth/components/building/building_component.lua:154: in function ‘get_dependencies’
…/fixture_fabricator/fixture_fabricator_component.lua:163: in function ‘_are_dependencies_satisfied’
…/fixture_fabricator/fixture_fabricator_component.lua:202: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:41: in function <…/fixture_fabricator/fixture_fabricator_component.lua:39>

release-553 (x64)
c++ exception: lua runtime error
stack traceback:

Replica of Ancient Monument.
rabbit monument.zip (2.8 KB)
Randomly building stops while building rabbit’s ear part. Hearthlings eventually don’t go to build scaffolding or ladders to build ear part. I found this situation is frequently occurred under following conditions.

  1. Save/reload while building is incomplete
  2. Due to speed of placing slabs much more faster than placing scaffolding and ladders, workers stuck at the top of monument. After rescuing workers by building manual ladders, building does not continue.

release-553 (x64)

got me a bridge design which got build and left allot of scaffolting


bridge.zip (2.0 KB)

2 Likes

Here’s a modular stone keep. My hearthlings have had no problem building the inner and outer wall templates, but the main keep tower has stalled. I think it doesn’t like walls up against existing walls of other buildings. It built about half of the design before stalling, and I’ve tried several attempts to unstall it with manual ladders, but with very limited success (a few new blocks placed here and there after placing ladders and then it stalls again, etc).

Saves:
Stone keep (8.5 MB) before hitting “build” on the main hall component.
Stone keep (10.2 MB) after stalling mid-build.

Screenshots:
Ghosted Design

Stalled Build

@not_owen_wilson, for visibility

1 Like

hi
i have made a 1 floor house but my guys dont build it and the error box poped up and now pop up each time i launch my game.

release-559 (x64)…onehearth/components/building/building_component.lua:154: attempt to index local ‘entry’ (a nil value)stack traceback:
[C]: ?
…onehearth/components/building/building_component.lua:154: in function ‘get_dependencies’
…/fixture_fabricator/fixture_fabricator_component.lua:163: in function ‘_are_dependencies_satisfied’
…/fixture_fabricator/fixture_fabricator_component.lua:202: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:41: in function <…/fixture_fabricator/fixture_fabricator_component.lua:39>

i have the ressources and components are built. I precise it is my first one floor house. all the other houses have no floor.

i have dig the dirt and i want to build that house to hide the hole in the dirt, until we can place dirt back. maybe it is the fact the 0 floor of the house is beyond a hole wich creates the error.