[A18/A19] The buildings my hearthlings will not build (round 3!)

Update 10/29: Please also use this topic for Alpha 19 building issues.

Hey Everyone,

Thanks so much for all the templates you uploaded in the last giant thread. I know I can speak for the devs when I say how all the templates uploaded have been in improving building. A18 brings along more building changes (like destruction), so we’re creating another new topic to collect all your templates. If you previously uploaded a templated to the A16/A17 topic, and it still does not build in A18 releases, please upload it again here. As you upload your templates (full instructions below), please be sure to include the specific build you are encountering the issue (i.e. A18 develop-3109), as well as the issue you are encountering (not starting, not completing, needed manually placed ladder, scaffolding not removed, etc.).


In order to upload a building template:

  1. Save your build as a template in game.
  2. Open your game directory.
    Default location for a Steam install is:
    C:\Program Files (x86)\Steam\steamapps\common\Stonehearth
    Default location for a Humble install is:
    C:\Program Files (x86)\Stonehearth\
  3. Navigate to the building templates stored in \saved_objects\stonehearth\building_templates
  4. Locate the .json file for your template. For example, if you wanted to upload the “Clay Dining Room” template, find clay dining room.json.
  5. If you created this template in a recent version, you will also have a .png, for bug fixing purposes this is not important and does not need to be included in the .zip.
  6. Compress the .json file to a .zip file.
  7. Right-click the file you wish to zip.
  8. Left click Send to.
  9. Left click Compressed (zipped) folder
  10. Hit Enter on your keyboard.
  11. Upload the file to this thread in the Discourse by clicking the upload button in the editor and navigating to the file, or drag the file into the editor with your mouse.
  12. Important! Please be sure to list the specific build the template fails in. Also, please shared what the specific issue is. For example:

I am having issues with this template in Alpha 18, develop build 3109. The Hearthlings cannot complete the balcony on the second floor. I can build a ladder on the left side of the balcony, and then they are able to complete it. However, once complete, they do not remove all the scaffolding from beneath the balcony. Further, if I try and destroy the building, I get an engine error. [Contents of error] [Link to template.zip]

If you encounter any difficulties with uploading (or are a new user), please post in this thread and mention the moderators (@moderators) and we will do our best to assist you.

This topic is a continuation of [A16/A17] The buildings my hearthlings will not build (round 2!):


this still doesn’t work

now also getting this error:

develop-3109 (x64)No matching overload found, candidates: luabind::object load_json(lua_State*,std::string const&,bool)stack traceback:
[C]: ?
[C]: in function 'load_json'
radiant/modules/resources.lua:33: in function 'load_json'
.../fixture_fabricator/fixture_fabricator_component.lua:361: in function '_get_rotation_tweak_xz'
.../fixture_fabricator/fixture_fabricator_component.lua:429: in function 'rotate_structure'
stonehearth/lib/build_util.lua:447: in function 'rotate_entity'
stonehearth/lib/build_util.lua:451: in function 'fn'
stonehearth/lib/build_util.lua:61: in function 'for_each_child'
stonehearth/lib/build_util.lua:450: in function 'rotate_entity'
stonehearth/lib/build_util.lua:451: in function 'fn'
stonehearth/lib/build_util.lua:61: in function 'for_each_child'
stonehearth/lib/build_util.lua:450: in function 'rotate_entity'
stonehearth/lib/build_util.lua:465: in function 'restore_template'
stonehearth/services/server/build/build_service.lua:1603: in function 'build_template'
stonehearth/services/server/build/build_service.lua:1594: in function 'cb'
stonehearth/services/server/build/build_service.lua:1569: in function 'do_command'
stonehearth/services/server/build/build_service.lua:1593: in function <stonehearth/services/server/build/build_service.lua:1591>
develop-3109 (x64)c++ exception: lua runtime errorstack traceback:

I’m attempting to build all the default tier 2 buildings as they are and the hearthlings won’t finish the Blacksmith’s building, they did in A17 but not now, tried 3 times they stop at same spot, just before getting to the roof, image shows everything fine up to that point, but then stop.

@Unatan2, I think you might not have enough space for the scaffolding for the roof. Have you tried building it a bit more far from the house next to it?

there is 4 clear spaces between the two, plenty of room, the roof of the other building doesn’t interfere.

Hmm I wonder what could it be, then. I could build it without problems in latest A18.

Could you upload the save so we can take a better look?

can confirm, I also had this problem in the latest dev3109

Different game, same problem, lots of room all around.

Side note, Removing the building doesn’t seem to remove it all, leaves some parts.

1 Like

I’m having the same issue; my hearthlings failed to complete this building three times at the same spot as those above me before I gave up on it.


I managed to reproduce this by rotating a couple times the template before placing it.

It seems there’s some blocks in the lower roof that are left, and the construction of the main roof is halted:

See the positioning of the scaffolding ladders. Your pictures also show missing blocks in the smaller roof.

Destroy in console command still leaves ladders and scaffolding that doesn’t have a remove button, you must destroy them all one by one. Quite tedious, and rather annoying, when combined with the fact that the ground you put a template on that has been removed is no longer useable because the top layer of soil is gone and you cannot build something that does not have 2 blocks cleared around the entire template that is the same elevation as the template.
This is why I will continue to post my silly 4 story design. The way buildings are currently built is not good enough for the long term of the life of this game, the sooner it is reworked properly the better. The current requirements for template placement that I mentioned above are too strict.
Rather than focusing on where to and where to not place scaffolding I would rather have the devs think about-
"What if I wanted to build my house around an object or structure within the world?"
Like a tree in my living room or hanging off the side of a cliff or as a bridge over a river etc. all things that go way beyond the scope of "do I have 2 spaces around this elevation so I can place this template and have room for scaffolding?"
I should be able to put a design anywhere, with all kinds of challenges and restrictions and still have it built, though it may take longer than usual because of the logistical problems those issues present.






I only bother with this if the rest of the building had successfully built and there was just scaffolding remaining. When a good portion of the roof/walls/etc become permanently forgotten, I just pause the building process and remove it entirely. This at least gets rid of all the ladders and scaffolding.

Until they implement a tool to properly replace soil/grass, I found you can actually work around this particular problem by simply filling in or covering holes with slabs.

And I agree; the building algorithms seem like they could use some updating. That’s not to say that it’s terrible at the moment, but it at least needs to get to the point where opening the console is unnecessary.

Got me a nice one. They almost completely build it but then stalled. Could ib it without any errors. They then only removed half of the scaffolting even though the could reach it with out any issues. Weird part is dat half of it is build perfectly and the scaffolting removed correctly. other half build exactly like the other half they would not finish. Am ordering them to rebuild it free from the wall to exclude that as an iddue even though it did not bug the first half of it. also have it on vid so you can see the exact moment they stopped.

row of house.zip (31.6 KB)

did a rebuilt free off walls same problem

1 Like

i have a new building that is a lot less complex then most things i have tried building but despite trying it in many renditions it will not build!

—Also it will not let me uplode the filee for the template it is a .json should i convert it to something else?—
thank you here is the file
farm house.zip (8.8 KB)


You have to compress it, then upload the zip folder here.

here is a another one. I only seem to have trouble with 2 story buildings.
barn.zip (25.9 KB)

1 Like

Summary: There seems to be an issue with the blacksmith house not completing itself.

Steps to reproduce:

  1. I have a world.
  2. I create a blacksmith house.
  3. It doesn’t finish up as shown in picture. Gets stuck here.

Version Number and Mods in use: Latest version of alpha unstable branch on Steam. Vanilla Stonehearth

I would appreciate some help as the unfinished structure looks rather ugly…

Re: the Blacksmith House - FIXED - I have been having the same issue where the building will not continue after a certain point. I have tried building multiple times under different circumstances - area, rotation, removal of scaffolding, added ladders, etc. Nothing worked. However, after seeing the image that Relyss posted regarding the three blocks on the side of the small/lower roof section, I thought I would try editing the template before building. Upon removing the three blocks from each side of the lower roof, the build completed without issue! There is a conflict with the scaffolding and those three diagonal blocks on each side.

Also, something to note - inside the second flood of this building, there are 10 blocks in the corner (on the floor) that are not necessary and seem to be a bug or overlooked during development? I’ve always removed them when I’ve built this building.

I hope this helps!



:persevere: Same here, I would build it and it would stop, then I instant build to fix it, and it only completes some of it and the hearthlings removes some of the scaffolding and leave the rest there. I then manually fix the scaffolding and ladders.
I noticed those blocks as well, not sure if it was a bug or intentional? :confused: