Hearthlings won't complete premade buildings

Summary: I like using the premade buildings - the fact that Rajja’s Children has workshop templates for all or nearly all of the crafters is a primary reason I end up playing them most of the time. Since last night’s update, however, my Hearthlings won’t actually complete the building; they’ll dig out the space for the floor, build most but not all of it, and some arbitrarily selected portions of wall, including any fixtures attached to those walls.

I’ve tried with the Rajja’s Children Clay Dormitory and the Herbalist’s Workshop with the same general result.

Steps to reproduce:

  1. Place a predesigned building
  2. Hit “Build”

Expected Results: Workers come and construct the building as ordered

Actual Results: Workers start construction, but give up shortly thereafter and far as I can tell just ignore the unfinished building from then on.

Where they stopped the second time I tried; first time looked similar:

Destroyed the building and tried again, giving the building an even simpler name in case the apostrophe and/or space in the original name was a problem:

Where they stopped after that attempt:

Version Number and Mods in use:
Alpha 24.10 Unstable + workshop mods:
Better Storage
Stonehearth Cafe
Easy Mode Difficult
Brewery Mod
Functional Workshop Signs
Archipelago Biome (on an Archipelago map, if that matters)
Autoharvest Mod
Box Command Tool
Dense Fields
Stonehearth Doorways

System Information:
NB: I’m not hardware savvy, so I’m just hoping I’m pulling the right data from my control panel here >.>
Windows 10 Pro | Intel Core i5 | 16 GB RAM | NVIDIA GeForce GTX 1050

Interesting :thinking:

We’re going to remove the old builder soon from the UI (we haven’t imported the default templates to the new builder yet, that’s in progress). So hopefully soon you’ll be able to place them from the new builder’s template list and they shouldn’t have this issue.

If you have other custom templates that were made with the old builder, you can now place them from the new builder’s template list and they should be built fine (there’s some wonkiness with the fixtures, but you can adjust them if needed before starting to build).

Actually, they aren’t completing any buildings for me, not preset templates nor constructions i make. Not even simple roads, they start it and give up and do something else (or idle if there are no orders other than building) after 2% completion.

Same here. Even u use old builder or new one, or intern templates. Nothing will get finished after a few minutes, after they began building.

Please !don’t delete old builder! off the game, till all bugs with the new one will become history.

Greetz from a constantly forum reader ^^

We’re just going to hide it from the UI, since players can still have savefiles from A23 that had buildings in-progress, and those should finish building after loading (using the old system).

It’s strange that they stop building new designs made with the new builder. That shouldn’t happen at all. Are you using savefiles from the previous release? Any tips to reproduce?

Are you using any mods?

see above


when u start new building, even in mp/sp, nothing will get finished after short time.
Only single walls work, but without floor.

Steps to reproduce:

  1. try to build a template building - > stop after half floor, maybe with one wall on it.
  2. try to build a Building with new/old Builder - > same as above (even when your carpenter or potter has the knowledge about)
  3. try to build a single wall (maybe for defense) - > works fine, from begining till end!
  4. try to build with console code “ib” - > building will get finished, but nothing could be changed/added in

Expected Results:
before last update to 0.24.10., they always build till finish… with less or more bugs :slight_smile:

Actual Results:
see title ^^


Short description of each attachment if necessary.

Versions and Mods:
actual 0.24.10 latest build on steam (minimaly tested) (tested in sp/mp)
Mods: smart_crafter

System Information:
CPU: AMD-FX 6100six-Core RAM: 32gb Graphic: Nvidia Geforce GTX 960 OS: Windows10 Pro 64Bit

Edit: every new/old savegame , this happens… and i’m using also premade stonehearth intern templates.

Exactly, I only see this happening with the default templates that come with the game. Once Chris finishes importing them for use in the new builder, this won’t happen (so many changes affecting the old builder…). Sorry for the inconveniences!! :forlorn:

So you´ll crop the building menu only to one button?

With the option to choose the new builder, where all templates are integrated…
so u have your choice, if u use templates from a lis,t or start building urself?

so let’s wait and see :thinking:

1 Like

I have the same issues too. They do around 10-30% of the building and start idling.

Furthermore, It doesn’t seem to check if furniture is in stock. So if I pre-craft 10 beds, build a Shared Sleeping Quarter, it will craft 4 more beds.

Just curious - are the pre-crafted beds in a stockpile? I was having something like this issue in the previous Unstable version (ended up demolishing and rebuilding buildings a number of times because of minor glitches that were bugging me - they were probably my fault so not blaming the glitching on the game, but end result was I ended up having ridiculous numbers of e.g. windows in stock), and they seemed to largely end when I finally clued in and built a furniture stockpile. Oops.

Also having this problem as of tonight. I was playing last night and had no problems, so this bug has been introduced in the last 24 hours. Same as everyone else, my hearthlings start building and only complete about 20% of the building before giving up.

For anyone else experiencing this issue, a handy workaround is to open the console (ctrl+c), select the building and then type “ib” (without quotes) into the command line. Hit enter and the building will complete. For crafter buildings (like blacksmith, etc) you will need to save and reload your game, otherwise your hearthlings can’t use the craft stations for some bugish reason.

Devs, loving the progress you’re making. Fixing this bug would also make the game infinitely more enjoyable for me! (I currently can’t place furniture or wall fixtures in or on existing buildings, meaning hearthlings can’t have nice things!)

Every building beginns with ³/4 floor and one wall finished, nothing more. Even if you use templates, new or old builder.
Seems they forgot the sequence, which part is to do for next. Before update, they first build the floor (finished), then the walls (finshed), then the roof… and at least inventory/decoration. For now, they’re trying to build everything at same time.
And for “ib”-command, -

  1. u have to choose all deco and interior before you finish building
  1. your crafters will nevertheless craft all components, even if you allready finished building

The only solution i have for this problem is to use the new builder, but i don’t like the new builder. Being forced to use the new builder combined with the nerfed mining/tunneling now, has made the game very much unenjoyable for me. I’ll just wait it out i guess.

Doesn’t work also. Tried yesterday, the whole evening ^^
For me, the game is now unplayable, coz u cannot reach towngoals, or see the hearthlings do their work. They’re standing around and talking, eating and yawning. Expect it’s not farmer, miner, trapper or any other non-crafter ^^

Are you sure the problem doesn’t also exist with the new builder? I’m fairly certain the building I just tested with didn’t actually build… :thinking:

The developers fairly warned everyone the new builder is work-in-progress and it will take time to get working as they envision. You haven’t been “forced” to play the unstable branch and nothing has been nerfed. Go and play the stable branch instead if you’re not happy playing the work-in-progress branch.

I haven’t tried building templates with the new builder (as has been discussed, templates with the old builder fail partway through), but I haven’t had any problems building new buildings with the new builder. That is to say, I frequently have a builder get stuck on a partially completed wall since they hardly build any scaffolding and ladders anymore, but once I get them down they get back to building and eventually complete it.

long time owner of the game, first time complainer on this forums, I am having the exact same issues with the old builder, my hearthlings will dig out the area, start building, and than stop about 5-10% of the way through, i can get it to work after about 5 reattempts (6 tries altogether) but this severly hinders my ability to progress in the game when i’m doing a decently sized build like my bunkhouse build (medium sized building, 1 room, 8 beds, and aside from doors and windows, nothing else) and i have to remove it and restart it every few minutes until they get it right, and this process can take anywhere from 2-4 days to complete, and my bunkhouse is a simple building, no fancy add-ons, no mods, just 4 walls, foundations and roads, and a fistful of beds. i don’t like using the new builder due to the fact my hearthlings get stuck and they never remove the ladders they place down, i’ve also had an issue with the new builder where the hearthlings will try and finish the second floor way before the first floor finished, it’s only happened once but since then i’ve stayed away from making 2 floor or more high buildings. no screenshot of the this issue though, i forgot to take one before promptly starting a new game

i have two hearthlings only set to build and mine, no hauling, and here is one of them idling ontop of the build they were attempting to build, a road to my mines

Since they’re planning on getting rid of the old builder completely (and soon), I doubt they’re going to spend any effort trying to fix bugs in it, even ones as big as this, since the new builder is largely more functional than the old one ever was.

I just hope they finish converting the templates into the new builder soon (and/or make new ones, especially with all the “missing” crafter building templates for Ascendancy). When I’m just building my town at lower levels, trying to increase my net worth to get more citizens and progress, quickly plopping down building templates is way more desirable to me than having to manually design a building, especially in multiplayer where I’m not going to pause just to design a building. And that’s what the default templates are for! Once I have the resources and time to make larger/fancier buildings, actually using the building designer becomes a more desirable option, though personally I’m happy to use templates for the vast majority of buildings and just make custom walls and such to fit the terrain.

1 Like

They were in a mixed stockpile.