The Mac version


#62

One more picture (I can only upload 1 at a time so yeah)


#63

Can you try to verify your game files for stonehearth in steam?


#64

Oh i got my version on Humble Bundle (The zip File)


I dont have this game on steam


#65

Did you try to run it as an administrator? Some folders on mac don’t allow for programs to run out of. Try placing the wrapper on the desktop.

If that doesn’t work: are you sure you installed gecko and mono? If not please create a wrapper and make sure you install them, they will popup in the installation process of the wrapper.


#66

Yes i ran the program as an admin, i have also installed all the stuff (gecko,mono) on my wineskin. But it somehow magically does not work :confused:


#67

You might want to retry all the steps including downloading a new stonehearth zipfile


#68

Ummmm if I want to use YOUR wineskin file it says something different like this.


#69

Sorry, I don’t have a clue about what is wrong then. And I won’t be able to access a mac for a couple of weeks to check for you


#70

Hi, I’m as well unable to run the game with Wineskin. I followed your steps multiple times and downloaded the game twice, but I get always an error like @5iM (same report). I’m using wine engine 2.1.


#71

Hmm if more people have this problem around now, the newest engine probably can’t run stonehearth. Have you tried an older engine? Can you try this as well @5iM?


#72

I just tried with the 1.7.55 and 1.8.5 Wine engines and I always get the same error message
I also tried with PlayonMac (which uses Wine as well) and it fails in a similar way (but couldn’t get a log). Could it be the last version of SH? I tried with A20 from HumbleBundle.


#73

Yeah, have the same problem, dont work with A21 at all


#74

Never mind, the macOS version is coming … sometime.


#75

Okay, I’ve spent a little while trying to get Alpha 21 working under Wine, to no avail. It seems related to the libcef upgrade we did in Alpha 20. So far I’ve tried a fair number of things to get it working (Including patches of Wine and Stonehearth…) For those interested I ended up here looking at Steam’s libcef issues under Wine. There are also a ton of other games surfacing similar issues and I tried fixes for those games from various forums but I haven’t hit on the solution.

I can’t promise I’ll find the solution for Alpha 20 and above, but you can still play Alpha 19. An easy way to get Alpha 19 for steam users is to switch to the legacy_vista branch under the betas tab for Stonehearth on Steam.

Please let me know if you are able to run Alpha 20 or above, I think the information would be valuable to a lot of other players.


#76

Thanks for looking into it! I’ll try to free up some time and also look into it further. Does the new libcef file maybe need extra libraries?


#77

How much space does Wineskin take up on the computer?


#78

It may be, I’ve been trying to figure out which new dependencies it might need. It could also be relying on unimplemented behavior.


#79

The file that works on my computer with Steam & Stonehearth Alpha 19 is 4.56gb


#80

Hi I have been getting the same error message and log as other people and have tried The steam version of Alpha 21 and Alpha 19 but still always get the same error. Anyone know how to fix it?


#81

Hey, can you share some more details about what you tried? Also maybe the version of wine/wineskin and the version of OSX?