For us who love Mac and Stonehearth

Hi folks, I am a mac lover, but not a computer genius. I was wondering if someone can help me with playing this game on a mac. Yes guys, I have tried wineskin, but it just crash. It can be the wineskin itself, but i dont know how to fix it

hey there @garddun, welcome to the discourse :smile:

have you taken a look at this thread?

i believe that still works (though not owning a mac i can’t say for certain)

1 Like

Hi! Thanks! Yes, i tried it, but I just got the same error as if I just used the Wineskin, or winerapper…

hmm… sadly i don’t know much about mac, but maybe @Gorkiork could help out?

also, did you try this part,

1 Like

Hi @garddun,

Could you post your error/crash?

This is the error… Do you want the code bit also?

1 Like

I deleted everything, and dowloaded it again, and now i cant even select the Stonehearth.exe aften I hit the “install software” in the wineskin…

Looks like your stonehearth files are corrupt/not complete. Go back into steam>library>right click on stonehearth>properties>local files tab> and then press verify integrity of game cache.

If this doesn’t work, try and rebuild the wrapper following my steps.

Hope this helps!

1 Like

I have still the problem over, I cant select, og choose the Stonehearth.exe file from wineskin…. how can i fix that?

From the picture you send it looks like the wrapper is looking for a map instead of a file, maybe you can just select the stonehearth map? If that doesn’t work, have you tried rebuilding the wrapper from scratch?

I tried selecting the whole map, but it didnt work. I i going to try it when i get home, on the mac i am using, but i tried building it from scratch in Wine bottler, but not with your guidelines, so i would try it when i get home

IT WORKED!:heart_eyes: Thanks man!


Good to hear, have fun!

I am having problems loading.
I followed step 7-10.
I am not sure about step 9 on selecting the executable. When I click Copy a Folder Inside. It does the copying inside then just shows install screen.

I clicked advanced and choose both X64 and 32. But both did not work. Here are the logs generated.

I have also verified the integrity like @Gorkiork suggested.

Buy a PC just for this game is Worth it .

Very sorry for the late reply, I somehow missed this. This looks like something is wrong with the wrapper, not so much with the stonehearth files, you might want to try and rebuild it from scratch

Hi I got the same error as @garddun how did you fix it?