macOS unstable branch live now


#1

Hey all!

As I mentioned on the stream, the macOS unstable branch available with the password perseverance. The issue about it not downloading has been resolved (Thanks @morgan10e)

To get the beta:

  1. open your games library
  2. show all games
  3. right click on stonehearth and select ‘properties’ from the drop down
  4. select the ‘betas’ tab and enter the password
  5. select ‘macos’ from the drop down

Right now the biggest issue is that the only the fallback renderer is currently working. We’ll be attempting to fix support for the deferred renderer for 1.1

Please report any crashes or macOS related errors and issues here on this thread. If you see Apple’s crash reporting dialog, please click ‘report…’ and copy the crash dump. Thanks!


#2

#3

Yay!!! Thanks! And here I thought something I did “messing” around made the download/install finally work (wasn’t able to get it to work earlier today, so was trying several things).

One thing worth reporting:
While trying to get the game to work, I filled in the:

Stonehearth -> Properties -> Set Launch Options

With a value in that field, launching Stonehearth from Steam will briefly show:

Stonehearth - Running

but it stops within a few seconds with no error popup nor anything I could see logged to any console log file. Will be playing around with the game now a bit and report back if I hit any errors.

FWIW, running 10.13.6 on mid-2017 15inch MacBook Pro.


#4

I opted for the automatic crash reporting option.

Hope you got something from the first crash to desktop.


#5

Yay! Now I can work on ACE using the Mac version. Much joy!


Edit: Wow, this is working very very well for a brand new beta! I was half expecting I was going to open the game and all everything was going to be rendering backwards or something. Still needs some work, clearly, but so far it’s very playable :smiley:


#6

We automatically report in game runtime errors, but not the crash dumps. If it happens again it would be super useful to get a paste of the report and if there is no crash report dialog at least a copy of the log. Thank you!


#7

Hi there,

I’m running into an issue where everything runs smoothly up until the part in creation where you choose a map/place your location, etc. Only the frames show up and nothing else.

Just an issue I ran into. Great job by the way Radiant team!


#8

Nevermind, I solved the issue. The issue was with a mod I had installed. I forgot to turn them off before trying Stonehearth on MacOs. Sorry about that :grimacing::grimacing:


#9

macOS stonehearth crash 010818.pdf (58.2 KB)

Another crash to desktop, had console running this time. Hope the attached log makes some sense.


#10

Hello, thank you for mac version :slight_smile:
I have a bug game crash after 10min, but i cant put on post the report but i’m new user cant put file on discourse…


#11

Ah I forgot the scroll of the mouse in the craft menu and other is very very slow


#12

Hey @kikimou, welcome to the forum :slightly_smiling_face:

I’ve bumped your user level, you should be able to upload files now.


#13

Perfect thanks a lot :slight_smile: bug_mac.pdf (84.3 KB)


#14

Thank you both, these reports are helpful :slight_smile:


#15

Nice to be able to be helpful :grinning:


#16

Hi guys, having trouble with the roof, I have restarted the game twice but every time I click on the roof tool I can’t click on any ‘Slope’ of ‘Drop walls’ options.


#17

I was wondering if there is cross compatibility between the Mac and PC versions? My friend and I want to play multiplayer together but she cannot join with the Mac beta and if I try to download it on my PC, it sets the game to Alpha 24. Is there something I can do to make it work?


#18

I’m having a weird highlight issue, everything is highlighted very brightly. It’s making it difficult to see through mining zone… see attached screenshot.

I’ve tested this with and without mods and it’s always occurs on the current mac OS version

Hardware Overview:

Model Name: iMac
Model Identifier: iMac14,2
Processor Name: Intel Core i7
Processor Speed: 3.5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 24 GB
Boot ROM Version: IM142.0130.B00
SMC Version (system): 2.15f7

Chipset Model: NVIDIA GeForce GTX 780M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Dynamic, Max): 4096 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x119e
Revision ID: 0x00a2
ROM Revision: 3782
Metal: Supported, feature set macOS GPUFamily1 v3

#19

And a crash report from this morning as well - unrelated to the above - also a zip of the game save (autosave)

CrashReport 201808040803.txt (118.8 KB)

Archive.zip (5.2 MB)


#20

@EggySOK, the highlight issue is because of the fallback renderer, which is mentioned in the OP.
If we manage to fix it, everything will look better. Thanks for the crash report and the savefile!

@YoYoYasper, if you first draw the roof, then click on it, can you then change the roof options?

@EdisonGG, it should be possible to play multiplayer between Mac and PC, but the game version and mods should match. There’s also been reports about people being able to join their friends but their friends can’t join them, which we’re still investigating.

In your PC it shouldn’t set the game to A24. If you right click on Stonehearth in your Steam Library, and select ‘properties’ from the drop down, click on the ‘betas’ tab, which branch does it say it’s in when this happens?