The Mac version


#1

Wow calm down!
I’m not going to ask for a mac version, I build one with wineskin!

Here it is:
https://drive.google.com/open?id=0B7EVB9VHg0hUUTNUWm15Z2ZaaVk&authuser=0

Just download the file and start on point 7. If it gives an error, right click the wrapper and pres Show Package Content, then double click the wineskin app

I just tested it and it works smoothly on my imac from 2005 with only 2gig of ram.

If you don’t trust me for any dark reasons you can build your own wrapper!

1: Download Wineskin Winery: Wineskin: play your favorite Windows games on Mac OS X without needing Microsoft Windows | Downloads

2: Download the ZIP file from humblebundle, .exe won’t work. And unpack it.

3: Open Wineskin Winery and press update, then press the little + so you can install the latest engine.

4: Click on Create New Blank Wrapper

5: Name it Stonehearth or whatever you like.

6: Let it build and yes install gecko and mono.

7: Open your completed wrapper and press Install Software

8: Press Copy a Folder Inside and choose the stonehearth folder you unpacked.

9: Then choose the right executable: Stonehearth.exe or x64/Stonehearth.exe(not tested)

10: Double click the wrapper and you’re off!


[Tut] Mac/Linux users, how to get Stonehearth from Steam (on your platform)
Mac/Linux version
Map saving syntax
Run the file with Wine on a Mac?
Can't Launch StoneHearth! (Mac with Parallels Desktop)
Mac/Linux version
[Tut] Mac/Linux users, how to get Stonehearth from Steam (on your platform)
For us who love Mac and Stonehearth
Mac port for Stonehearth
For us who love Mac and Stonehearth
A little help with Assertion Failed Error
#2

hey there @Gorkiork … nice work! thanks for putting together this guide! :+1:


#3

No problem, now on day 4 and still no difference with the windows version!


#4

How does this compare to say, using Parallels?


#5

You don’t need to install windows, it is just the wrapper and you place the game folder in there. So you don’t have to double boot or anything.

The wrapper just translates the windows code too code that mac OS understands.


#6

I know what wineskin is, I’m just asking about performance. Sorry I didn’t make that clear.


#7

Oh sorry, well because you don’t have to run windows and mac OS side by side, it uses a lot less resources. It behaves as just a normal program. And as I stated my 10 year old Imac can run it smoothly, so it is pretty easy on the system.


#8

Can we use this method of we have the steam version?


#9

I did try installing steam in a wrapper and then downloading Stonehearth with steam, but that didn’t work.(Steam worked fine, but Stonehearth didn’t) You can try it if you want, this is a good tutorial:

But I will try moving the folder, that steam creates, into the wrapper and see if that works.

But shouldn’t everyone have a file on humblebundle? I got my steam key from there.

EDIT: Alright I did the test with the Steam files and it works. This is what you have to do:

1: on Parallels find the folder where Steam installed Stonehearth(Program Files/Steam/steamapps/common/)

2: Move or copy the Stonehearth folder over to the Mac side, and then just go from step 7.

For the people who don’t have parallels and want to use the steam version, use the youtube link above to install steam and with steam install Stonehearth, then find the Stonehearth folder create by steam in the wrapper: Right click steamwrapper, pres Show package contents, then go drive_c/program files/Steam/steamapps/common and move the Stonehearth folder to your desktop. Then just go from step 1 in the first post(Or step 7 if you already have a fresh wrapper with gecko and mono).

Hope this helps and have fun!


#10

thanks for your helpful guide… again!

your new title seems perfectly appropriate, to me… :smile:


#11

Not a problem at all, just doing my part in this great community!

I’ll wear my title with pride!


#12

i second that :smile:


#13

@Gorkiork How would I move my stone hearth folder from parallels to mac?


#14

Never mind. It worked!


#15

There is a problem, however. Whenever I try to build anything, a crash report thing comes up. So for now I am living in a cave.


#16

I do get a scafffoldig assertion bug, but it is not gamebreaking in such a way that I can’t build anything


#17

Something happened when I was playing. I built a couple of houses. They finished four of them but not one. They only du up the dirt to put the floor down. I tried pressing build and then I got an error message saying something about how they couldn’t build scaffolding. I tried to tear down the building. When I did that, four of my hearthlings went over to the building and started hammering the air. They never stopped. So, I tried to save the gam and reload it. When I tried reloading it, It didn’t reload. I exited out and tried to go back in. Then, the wrapper thing said that it couldn’t read the file “C:/Program Files\Stonehearth\user_settings.json”. So, I went into the file, and there was nothing there! So now I can’t play Stonehearth because, whenever I try to start it, that same message comes up. Any suggestions on how to fix it without getting rid of my world? Thank you!


#18

Hmm haven’t had this occur. The building is a bit weird in the sense you can press the build buttom and they will start building but the build button won’t go away so you may have pressed that so they did’t finish the building.

User settings file being gone is probably a normal stonehearth bug and has nothing to do with the wrapper, but don’t know for sure.

What was the scaffolding error?


#19

I’m not sure. Something about it not existing or something like that. The strange thing is, it worked for the other four buildings. I’m sorry. I didn’t really pay too much attention to it. Sorry. It had something with the file and that’s all I really noticed.


#20

You probably have placed the building at a weird spot then.

You could open the wrapper by right clicking on it and Show Package Contants, then find the Stonehearth folder in drive_c/Program Files/. Delete the stonehearth folder and go back to step 7!