The Mac version


#21

FYI for those who want the latest game release form Steam instead of waiting for HumbleBundle updates.


#22

This saves you using a seperate wrapper for windows steam! Try it!


#23

I’m having trouble with step 8. I can’t find the folder you’ve mentioned.


#24

One one hand you should have the Stonehearth PC folder somewhere. On the other hand you should have the wrapper.
Show the content of the wrapper, double click on “Wineskin”, click on “Install software”, select your Stonehearth PC folder, press “Choose”.

You should end with this:


#25

thanks! got it to work :slight_smile: soo stoked :slight_smile:


#26

Hey, thanks a bunch for this, and I figured out a way to make it just a tiny bit better. It always annoyed me that when you made a wrapper with winery, it put that ugly icon instead of the one you want. Here is a way to make the icon the Stonehearth logo (I couldn’t find the actual pc .ico to convert):

6.15: Open the completed wrapper and press advanced.

6.3: Download this .icns file - https://drive.google.com/file/d/0B4_hZum8nT7ZNGJmR3BKc0RPT1k/view?usp=sharing

6.45: Go back to winery and find the Icon Browse button (should be near the bottom right)

6.6: Find the .icns file, wherever you put it, and double click it

6.75: Click install software

6.9: Keep following the rest of @Gorkiork’s awesome guide!

I know its just an aesthetic thing, but I think it’s a nice addition for myself, so I figured I would share it. Thanks again for the awesome guide Gorkiork

EDIT: It might not work immediately. If after you close winery and are looking at the application, and it is still the winery icon, then drag it onto your desktop and both copies should fix themselves.


#27

Glad I could be of service! And thanks for the great addition!


#28

Christ dude this is great work!


#29

Alpha 12 seems to break something in the wrapper, it won’t load anymore on my side. As I don’t have much time to find out if it’s a “real” problem or a simple bad manipulation, could someone confirm or not the malfunction before all?


#30

Did you try to fully clean the wrapper and then download alpha 12 and verifying local data? I somehow screwed up trying to update, when I just moved the updated files to a clean wrapper. So redownloading and and then checking before putting the files in the wrapper might work.

Sadly I am not in the vicinty of mac at the moment so I’m not able to test alpha 12 for you.

I hope it works!


#31

Got the fully clean wrapper and tried installing but got this error:

You either do not have permission to copy, or there is already a folder with that name in the wrapper’s Program Files folder


#32

@Gorkiork: sorry for putting you on the spot, but any ideas?


#33

What gave the error? The Stonhearth installer or Wineskin?


#34

Hmm, seems like you put the wrapper in a folder where changes aren’t allowed or you’re trying to put the files in the wrong folder in the wrapper.

Also you said installing, you don’t put the installer inside the wrapper, you need to copy/move the already installed game over into your wrapper. If you need a way to install steam and download/install stonehearth so you can copy those files in your folder there are a couple of ways discribed above.

If you did try to moves the installed game try this:

Do you have administrator rights on the account you’re using? If so try moving the wrapper to your desktop, check the folder where you need to put the files in again and try again.


#35

Okay I sort of got it to work but now when I launch the game the screen is simply black. I can hear the music but cannot see the game. :confused:


#37

Hmm, looks like files are missing. Go to steam and the verify the game cache of stonehearth in your library. Clear stonehearth from your wrapper and move the verified content over.

Hope this helps!

If it doesn’t it also looks like an old driver problem so you could check your drivers.


#38

Also… Should it give me an option to choose the executable? I got the option once but messed up and it hasn’t given me the option since.


#39

If you rightclick the wrapper, and then choose “show package content” there should be a program inside called wineskin, open that and there should be an option to change the executable


#40

I was making an error the whole time. I downloaded your wrapper but didnt make my own. For some reason… making my own worked.


#41

Good to know it works!