The Mac version


#42

Just wondering if you are experiencing the same bug. When my hearthlings dig up terrain, the game lags… a lot.


#43

Sorry but I’m not able to check that at the moment, but with the older version it was fine.


#44

okay. It isn’t too bad of a bug unless I play as the new race. :slight_smile:


#45

I wonder if this is available for Mac, if it is, as I install it?


#46

Hey there @borkajolic, welcome to the Discourse! Moved your post over here, check out the first post for a potential (temporary) solution. As of right now, there are no plans to release a Mac version of the game until it reaches beta, and is feature complete. It would be too complicated to attempt development on 3 versions (Windows, Mac, & Linux) simultaneously, so the focus is on Windows for now. Give the suggestions in the first post a try, if you need any help, just let me know!


#47

Thanks for this quick guide! I have the game running great using Wineskin, but every few minutes the wrapper minimizes to my Dock. Can’t figure out why! Grr! Working great otherwise (though the game does take a major performance hit when there is any mining or building taking place).


#48

Nice to hear! The preformance hit is probably happening because the game is not fully optimized. As for the minimizing, that sounds like a pop up for another program or the OS, have you tried running it on an administrator account?


#49

I got the same issue with the window minimizing. It seems to be caused by notifications and putting my Mac in Do Not Disturb mode fixed it for me :slight_smile:

I got a performance hit around 16-17 hearthlings (oh and when doing large mining projects)


#50

Someone please help me.
I’m new to mac and this is just killing me.
I downloaded the file above but then an installer comes up and I need to choose a setup.exe or some other installer.
I have no idea what I’m looking for, where to find an installer or if I even need to do this.
I’ve downloaded wineskin winery and both an engine and wrapper version for it.
Please please please can some good soul help me out before I go mad.


#51

Did you follow all the steps from the first post? The exe file should be the stonehearth.exe from the stonehearth folder you moved into the wrapper.


#52

Well I tried doing the first method using your wrapper. Downloaded it but when I open the file a small wine window pops up saying saying I need to download software. It tells me to a setup.exe or something else but I have no idea what I can use. There are some “advanced options” below which are to copy the file into something else- do I use them?


#53

Did you already move the stonehearth folder to the wrapper? If not then you need to press copy a folder and choose the stonehearth folder. If you already did that, then you need to choose stonehearth.exe in your wrapper. If this doesn’t help you, could you say at which step, of the steps in the first post, you are stuck? And send a screenshot?


#54

I made a little Wrapper kinda thing, you could try that out and see if it works for you :slight_smile:

Mac Launcher for StoneHearth


#55

Thanks so much for the help. Really nice of you to help me people out for no personal gain.
I’m having problems with this site though. All symbols e.g. “X to close” and “attach an image” are squares and also my screenshots won’t upload…
What I did:

  1. opened your google drive file and downloaded it
  2. double clicked/opened the file from my downloads file.
  3. A small Wineskin window popped up with option “install software,” “set screen options” and “advanced.”
  4. I clicked “install software” which led to another window with options “choose setup executable”, “copy folder inside” and “move folder inside.”
  5. Tried the former but couldn’t find what to use (also didn’t know what I’m looking for)
  6. Decided I probably needed winery so downloaded that and downloaded engine and wrapper version.

So I’m lost and don’t know what to do. Keep in mind I’m new to mac and have never used wine before :slight_smile:


#56

No problem! The folder you need to copy inside is the stonehearth folder, you can download the folder from humble bundle(It’s the zip file). After that you need to choose an exe and that exe will be the stonehearth.exe in the wrapper. Hope this solves it!


#57

Can I just say, @Gorkiork, that I’ve sent this guide to dozens of people this summer? You are saving our bacon. Thank you so much.


#58

Not a problem at all! I’m currently low on time and mac access, but when I have some I’ll see if I can update the wrapper.:slight_smile:

It was awesome to get this message in my mailbox, I have been away from the community for a while(Still following the dev blogs offcourse). But it is really nice to see this is still used very much and is being appreciated! This is one of the reasons Radiant and Stonehearth are so great! There is so much interaction with the community, you just want to help. I’m cenrtain Stonehearth will be a great game and you guys deserve it!


#59

Btw, I’ve heard from a coworker that Stonehearth also works pretty well with this program:
https://www.playonmac.com/en/

Haven’t tried it myself yet, so if anyone does, let me know how it goes :slight_smile:


#60

I’ve Played it on my Mac using Free Trial Download, Run Windows on Mac with CrossOver | CodeWeavers
It plays pretty smoothly but eventually stutters my gameplay on my big saves with 25 hearthlings.

I’m going to try it out on PlayOnMac as a comparison and report back :slight_smile:
Thanks for sharing, Sdee


#61

Help! Im stuck. I did follow the steps correctly but ended up with this ;-;. Anybody know how to fix? :stuck_out_tongue: