Can't Launch StoneHearth! (Mac with Parallels Desktop)

So, it seemed like a normal day. I came home and I went to play Stonehearth. But then, the problem arose. I clicked the play button in Steam. It said “preparing to launch Stonehearth”. Then, that message disappeared and on steam where it said last played, it said tomorrow. Am I destined to play Stonehearth tomorrow?

Now, onto the real details. I play on a Mac and I use Parallels Desktop. I have played the other alphas before. This has happened for the last two alphas that I tried to play. I do not remember how I fixed it, but I have tried many methods. I have tried to delete the local content many times and I have tried deleting the local content, then restarting Parallels Desktop, and then reinstalling it, but that did not work either. If you are good with Macs and Parallels Desktop please help. I love Stonehearth and I really want to try playing the new alpha. Thank you!

1 Like

So… I have been trying to play Stonehearth since alpha 8. Btw, I play on a mac with parallels desktop 8.1 on steam. It has been really slow. It takes almost five minutes to open one of the crafter’s menus. Also, after I updated to a new alpha, it won’t launch. It has a thing that says “preparing to launch stonehearth” but only if I click the start button a bunch of times. It never launches after that. I am now playing alpha 10- although not really playing- and it still doesn’t work. If anybody has any suggestions please help me out. And, for the record, I do not know much about computers/files, especially not on windows/parallels desktop. I really want to play the game and I could use some help. Thank you! I hope this isn’t a big repeat of another topic.

i dont know much about this, but i have read that others have had problems trying to play on mac as it isnt fully supported yet…


@Bberger789 unfortunately, Stonehearth does not natively support Mac or Linux as of yet. however Radiant has stated that they wish to create a port for it later on. I’m not sure if I have seen anyone else try what you are trying. have you thought about bootcamp? I’m not a Mac expert by far, and I’m assuming that might be a bit pricey.


I know. I use parallels desktop which is basically like windows on mac. I’m not sure if this has to do with the problem

It might. I honestly don’t know anything about Mac and such but I do know that windows programs require certain executables and libraries that Macs do not have. Parallels might have them, but they might not. Bootcamp might not either. I know that stonehearth uses direct3d which I am unsure if Mac/Parallels can use. just my two cents. I might be and probably am wrong.

@not_owen_wilson seems like the person we need here I think, as I think he does a fair bit of work on the engine side of things.

Parallels isn’t the best way to mimic windows on mac, the problem probably has to do with specific resources(.NET and stuff) not being installed or used by parallels the right way.

You can try my method of playing Stonehearth on mac:

1 Like