[Mod] Settlement Decor Mod [Download available]


#242

and when i do it and send it to you? :wink:


#243

Hello there!
First of all thank you for this great mod.
Secondly i’d like to know if there is a fix for the issue i have: i am struggling to get all items related to this mod picked and stocked by my hearthlings (they just totally ignore them and all items remain spread on the floor)?
I am using “Better stockpiles” mod, could this be related? If yes, is there a compatibility mod released yet?


#244

disable better stockpile until its fixed xD there is a known bug since a20


#245

Will sure try this and wait for a fix.
Thank you for the suggestion!


#246

Hello here, there’s issues in Settlement Decor Mod with stockpiles, your doors and windows use the old filters “stockpile_door” and “stockpile_window”, but Stonehearth uses the “stockpile_portal” filter since Alpha 18. Also some plants and decorations have wrong tags. This is why Better Stockpiles don’t work with Settlement Decor.


#247

As Wiese2007 suggested i disabled Better Stockpiles and now my earthlings are doing their job correctly.
But i’d really love to use both mods together, just make it happen guys!
Thank you for your work.


#248

In my tests without BS, the storing works with stockpiles set to “All”, but it don’t with detailed filters.


#249

@Shinsaka @TheMournful I will work on a fix for this over the weekend and hopefully have it solved and a new version out Sunday.


#250

You rock! Thank you. :slight_smile:


#251

I’ve fixed the issue with some of stockpile tags so everything should go into the correct stockpile category. I’m still not to sure how it will behave with the Better Stockpiles mod and full compatibility may need some more work.


#252

I’m receiving this error when I start/load a game.

[details=Summary]release-696 (x64)[M]
c++ exception: Error reading file settlementdecor/entities/construction/mine_entrance_scaffold/mine_entrance_scaffold_ghost.json: Unterminated quote Source: {
“mixins”: “stonehearth:mixins:placed_object”,
“components”: {
“model_variants”: {
“default”: {
“models”: [
“file(mine_entrance_scaffold.qb)”
]
}
},
“mob”: {
“model_origin”: { “x”: 0, “y”: 0, “z”: 0 },
“region_origin”: { “x”: 0, “y”: 0, “z”: 0.0 }
}
},
“entity_data”: {
“stonehearth:catalog”: {
“display_name”: “i18n(settlementdecor:entities.construction.mine_entrance_scaffold.display_name)”,
“description”: “i18n(settlementdecor:entities.construction.mine_entrance_scaffold.description)”,
“icon”: “file(mine_entrance_scaffold.png)”,
“category”: “decoration”,
“material_tags”: “wooden decoration crafted stockpile_decoration”
}
}
}
}
stack traceback:
[C]: in function 'load_json’
radiant/modules/resources.lua:33: in function ‘load_json’
…nehearth/services/server/catalog/catalog_service.lua:162: in function ‘_add_catalog_description’
…nehearth/services/server/catalog/catalog_service.lua:132: in function ‘_update_catalog_data’
…nehearth/services/server/catalog/catalog_service.lua:120: in function ‘_init_catalog’
…nehearth/services/server/catalog/catalog_service.lua:51: in function ‘start’
…vices/server/game_creation/game_creation_service.lua:193: in function ‘on_world_generation_complete’
…server/world_generation/world_generation_service.lua:274: in function 'f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>[/details]


#253

This was an unusual bug, when I edit the json file outside the .smod archive the brackets are balanced then as soon as I zip it up, a new bracket is added at the end. :grin: Had to edit within the archive to fix it, should be fine now.


#254

Hey @The_M , first, nice mod :slight_smile:
BUT the current version will not be shown in the mod menu.
:frowning:


#255

I have the same issue


#256

looks like an issue while packing ^^ after repacking it recognize it again but gives again the invalid file issue for the ghosts ^^


#257

Hopefully its resolved now, no more sneaky brackets or archiving issues.


#258

I am not sure why. but I am not seeing half the stuff that is shown in the images of this thread.
What all professions does these mods use?


#259

Gardener a new Profession which Comes with this mod.
Carpenter, Mason and Potter are all professions. (you Need the blacksmith to craft the gardeners trowel)


#260

ahhhh ok, I didnt see the gardener profession! xD my bad LOL


#261

Garderner Proffesion do not react with Rally in the Correct way.
Gets an ! over head but never goes to the flag for me like all other none fighters