Hearthlings don't like building churches

Give them a toy rabbit and a top hat that would make them “cutesy”


That’s based on my parenting style…geez. lol. Sure, my minion is only 11 months old but when I crack that whip she gets right to work*.

*Note: “work” is here in defined as “giggling and flailing excitedly” with sporadic drooling and babbling

right back to the issue at hand, I have now removed the plinth bit as well and still they will not build

1 Like

This won’t be causing your errors but I think the staircase position is problematic. I can’t see for sure due to the angle of the screenshots, but it looks like any hearthling using the stairs would get stuck on the roof before they reached the upper level. And if they reached the upper level, there would be a wall there that they couldn’t walk through.

As far as getting the hearthlings to build your structure goes, try using only floors, walls, doors, windows and roofs. Leave out all furniture, decorations, blocks from the block tool and free-standing walls. It should work that way. If it does, try adding things in one at a time (and attempting to build each time) to find out what is making the hearthlings get stuck. Obviously you’ll need to save before-hand and reload each time, but at least you’ll know what works then.

My tip, remove the clock tower, just for testing purpose.
(I can not build multi store buildings)
Oh and upload your orginal file.

1 Like

I do notice you have slabs on top of the floor (that platform). I believe there may be an issue with slabs on floors, although I have seen building with slabs on the floor as well.

Also maybe for testing purposes, you should remove the decoration, to eliminate variables.

I think I know what it is.

you see, your hearthlings are actually MUSLIM-shot

no, but seriously, I believe it’s because of 2 things - 1: your elevated platform on the floor (where the altar is). 2: your roof. as your second floor is not flush with the first floor, the issue here is caused by the roof you’re trying to build. you have 1 roof on the first floor and 1 roof on the second floor. what you should do is build the first and second floor as you did and AVOID BUILDING THE ROOF (the roof on the 2nd floor should be fine, it’s your 1st floor roof that’s causing the issue here). then, after they’ve built it, build the altar and the stairs. after they’ve built that, build the roof manually using slabs. this will take you a long time, but it’ll work. and, honestly, it’ll look better as you can make the roof go all the way up against the wall and place the door inside the building under the roof instead of outside next to the roof.

and if it still doesn’t work, try promoting a hearthling to jehovah’s witn-shot repeatedly

thanks, will try this when i attempt it again, unfortunately ended up restarting the game as i had an incident with a totem, which caused the game to crash

I don’t think it’s the roof. I had little problem building a similar thing. Only thing that went wrong was the usual problem with some internal scaffolding not being removed.


I’ve had some issues with the roof before due to roof blocks overlapping with other blocks. better safe than sorry, right?

also, if you look at his stairs, his door would be located inside of the roof blocks themselves.

I think those issues with roofs are mostly resolved now. The AI had no problems with the roof in the image above. There were overlaps with the 2nd floor wall and the roof above, but it was built correctly anyway. Have you tried the kind of roof that previously gave you problems in the latest version of the game?

1 Like

the kind of building gave me a lot of problems (it was a 2-story with part of it being a 3-story tower, much like the church’s 1-2 story building), so I’ve resolved to simply not touching the editor anymore unless I’m making roads lol

1 Like