Hearthlings don't like building churches

So I attempted to build a church ,as I sadly lost a hearthling in battle, and experiment with the building editing but I can’t seem to get the hearthlings to build it.

it’s the first time i’ve figgured out how to work the second flooring system (I think anyway) and also a raised plinth which is also a new commodity I attempted to deploy.

I’ve checked my supplies and have everything required to build it but my workers just stand there idle and won’t even start.

If anyone has any ideas of if this is just me and how to fix it, or if this is the game and a known problem could you let me know :grinning:

Could be a few things here

1st, Could be the Idle bug, However I don’t see that often any more.

The second thing that comes to mind is, Can your hearthlings reach all the area’s? If they can’t get to one bit cause the building is to complicated they just won’t fix it until you figure it out :stuck_out_tongue:

Are your hearthlings doing other things? like eating, sleeping, or building other structures?

Hope that helped :smile:

are the materials in crates? for some reason the hearthlings hate crates sometimes. just a thought.

they won’t even build the foundations and I managed to build a ladder to reach the second level even though they haven’t started yet (so i now have a ladder in the middle of nowhere now)

They do other task still and seem to have no problem eating or sleeping

and I have just noticed that now when ever i click on the building it will automatically send me back into the editing mode rather than ask if i would like to pause it

All of my items are in crates might try taking them out and see if that changes it

1 Like

and when that happens do you click “start building”?

yes and it says it started but then nothing happens

1 Like

hmm… what happens if you click “remove” and then replace the building template?

note: you might want to save before this, as it could cause errors.

1 Like

ok so removing the items from crates didn’t work

and the template “saved” but when i went to place it, the template was blank so i am going to build it again from scratch and see if it will work then

1 Like

before you do that, try saving and reloading.

also did you get any error windows when you first went to build the church?

Also to add more to this thread, would you be able to upload a picture of the Church for us?
New users usually can’t upload so if you put it onto something like imgur, A mod will upload it (Unless times have changed without me)

1 Like

nope, still the same, though i believe @littlestick is at a high enough “trust level” to be able to upload images directly to the discourse, if not i can always embed it for them.

1 Like

ok so i saved and reloaded and the template was still blank however when i clicked on it it gave me the following errors

release-453 (x64)…nehearth/components/building/building_component.luac:246: assertion failed!stack traceback:
[C]: ?
[C]: in function ‘assert’
…nehearth/components/building/building_component.luac:246: in function 'load_from_template’
stonehearth/lib/build_util.luac:44: in function 'load_structure_from_template’
stonehearth/lib/build_util.luac:48: in function 'load_all_structures_from_template’
stonehearth/lib/build_util.luac:170: in function ‘restore_template’
…th/services/client/build_editor/template_editor.luac:11: in function ‘_restore_template’
…th/services/client/build_editor/template_editor.luac:20: in function ‘go’
…rvices/client/build_editor/build_editor_service.luac:39: in function <…rvices/client/build_editor/build_editor_service.luac:39>


release-453 (x64)c++ exception: lua runtime errorstack traceback:

Plus when I first built it, it did come up with a message but I presumed that was either because i built the floor into itself which I then fixed or because at the time I had managed to get some hearthlings stuck in a hole

1 Like

I can upload a picture once i have attempted to rebuild it however because i deleted it to replace it there currently isn’t a church…

well then there’s the “root” of your problem, sometimes (for whatever reason) buildings generate errors, and then cant be built, along with that you cant build anything unless you reload.

so i guess you’ll just have to rebuild it then :confused:

ok so i have rebuilt the church!!

they still won’t build it but the template worked this time and I have had no errors

Also Pictures!!!




hmmm… it could be due to the stairs, try removing those and then adding them after they finish building the church (assuming thats they finish it without the stairs.)

I have run into problems with decorations in building designs as well. I tend to try to build a plain building and then add decorations after construction. Not sure if that will help at all but worth a shot

1 Like

stairs removed and they still are having none of it

This inspired an idea for a new class of hearthling. The “Motivator”; a large, burly, hairy hearthling dressed in dirty leather overalls carrying a whip. Activating him sends a sharp whipcrack echoing through the village and the hearthlings drop what they are doing and run screaming to the job site :smiley:


yes, because that entire idea is “cutesy” and family friendly… :wink: