Hearthlings Not Placing Furniture/Items

Ignore the buildings with x’s as those are buildings I’ve placed but haven’t “finished editing” or started to build yet. The circles are areas where a building is “finished” but hearthlings refuse to place certain items even though I have them, craft more, and whatever else I try.

I wait and wait just to see if it’s lag but it’s not. :confused: They literally just refuse to place them. It’s small things like doors and windows, and occassionally lights, but I can handle other bugs. Visual bugs with ghost furniture annoy me to no end, though, hence why I’ll probably be restarting the game. :confused: There’s obviously no error message, but it’s annoying that they don’t place the stuff, even tho it’s all in crates.

1 Like

perhaps its a problem with the stuff being in the crates, that was the case awhile back, though i think it was fixed, try removing the stuff from the crates and see if it gets placed.


Actually, I don’t think it has to do with crates:

I’ve had the fences to the back placed for quite a long time I’ve even attempted shuffling them around, the hearthlings at this point just don’t feel like placing them (or doing anything for that matter). This goes for some lamps I’d attempted to put up as well.

I read something about crates causing issues with furniture, so I started using stockpiles just to be safe, but I’m not sure it actually helped…

I’ve had the same problem with windows. I’ve fixed it by deleting the window in inventory. But it happen really often and it’s not a really viable solution. Sometimes it work, sometimes not :confused:

im going to page @yshan @sdee @Albert so they can take a look at this… because im stumped :laughing:


I responded to a forum post asking us to send in large saves to look at CPU use - the save I emailed in last night has this issue with placing stone fences in it. I think I also have some windows and doors that are not getting placed. If you check your email you should have a good example of the problem.

When looking specifically at the stone walls, the inventory screen shows that I have more objects than I can place. While it says I have 5 walls, I can only place 2 right now. I can only guess that something happened when I was saying where to put the items - perhaps a wall was moved into storage while I was trying to build a pasture, but it leaves the item in inventory but unusable.

I’ve been tempted to IB it away, but it may be helping to cause some of the the other AI issues in town right now.


Sometimes, when I try to place an item from the place menu, it stays as a “ghost”, hearthlings won’t place it, I can’t sell it, and it propably has something to do with crates.

Hi @bbarteqq, welcome to the forum :smile:
Can the hearthlings reach the item? Or do you suspect that it’s not being placed because it’s inside a crate?

They can reach it, about 10-20 % of the furniture I want them to place is never placed and stays as a “ghost” in the world, I can move the “ghost”, but they won’t place it :confused:

is this the same as this one here,

Yes, But I have this problem with crates, beds, chairs, everything…

1 Like

Ummm this thread reads as resolved, but I’m running the latest version of Stonehearth and its still refusing to place certain items from the pre-designed buildings.

Three chairs are available in my stockpile but the hearthlings are refusing to place them where they are Ghosted to be placed at. I tried placing them else where but they are not even trying to pick them up from the stockpile.

I do not believe this issue is resolved.

The funniest thing though.

I sold the three chairs to a traveller and their ghosts vanished from the house but the ghosts remained on the ground when I tried to move them. Ended up with error msgs. So I build 3 new chairs and the hearthlings placed them in the dinning hall all by themselves.

Its as if pre built furniture does not keep track of what has been placed and what is in stock.

I’ve also been experiencing the fence/wall and building furniture placement issues.

Building placement:
I didn’t take any screenshots, but was having trouble with both known scaffolding issues and furniture placement. I was able to get around this by simply reloading a save and reattempting the build. After numerous tries (maybe around 8-10?), finally got a finished result.

Wall placement:

These orders have been around for a while, but the wall sections have never been placed.

  • Building new stone walls has not helped.
  • Other wall sections have been placed successfully.
  • Wall sections are located in stockpile, not in crates/pots.

At this point, it would be nice to have a way to just cancel the order.

I am still getting this bug. Hearthlings will not place any items

@Kins, can you provide a few more details please? Are you saying that you cannot place any items at all? Does this happen in a particular save, or any game?

Hi, sorry.

During the game all the sudden the hearthlings will not place any items anymore from storage. When I save and load the items are being placed.

1 Like

Interesting…does this occur frequently, or was this the first occurrence?

It has actually happened in quite a few games so far.

1 Like

You mentioned that if you save and reload the items start being placed. Will the Hearthlings stop placing items again, or does one save/reload fix it?