Building Structure Complete! but furniture not in place

So i was building a pre dising two person cattage, the building was finished but the hearthlings didn’t place the furnitures. no windows no door no bed. And everything was on inventory. Also i place other decorations in the area, they never place them.

Welcome to the forum, @Jose_Rivera :smile:

Which Stonehearth version were you playing?

Did you have enough resources (for example, wood to make the ladders for placing the windows)?

Was the furniture on stockpiles or inside crates?

@Relyss i was playing alpha 17 in steam.

The hearthling finished the structure i was just a matter of putting the bed windos and door and lantern. i had like 250 wood and the ladders where already place. the hearthling even took donw the scaffoldings and all. they just left the window ladders in place but after days no hearthling came to put them down.

The furniture was already build because of autoqueue and they where store in a stone chest. i was already in day 27 tier 2 city and all.

But for example this happen before the start of this building. I place a few stone tall lanters in the surrounding but none where place. there is the transparent void in there, just waiting for some lovely hearthling to come and give it life.

Also happen with the last funtain i got, because i got the three.

but after the building was finished i could place othere intems for example the scout gong was place but those before the gong weren’t (stone tall lanterns and third fountain).

And i start building other building just like the one before (two person cottage -pre disign) and out of nowhere the hearthling put only the windows for the old one… thats it then start the second building again, but left the door beds and lantern in the chest for the first one. like nothing happen.

1 Like

I’ve heard some similar behavior from other users…
Could you upload the save where this is happening?
The saves are located in C:\Steam\steamapps\common\Stonehearth\saved_games
find the affected one, zip its folder and upload it here so the devs can take a look.

If the save is too big for the forum, upload it to some free hosting (like Google Drive, Dropbox, etc) and share the download link here.

Here it is! I hope you can fix it! i really like this save file!

1 Like

Thanks for the save
I am posting here to remind myself to look at it

1 Like

@yshan @Relyss hello I fixed it…
I sold every single furniture then craft then again. The hearthlings start the building process again.
And everything went smooth from there. But after a while I move some beds and wanted to place a fine comfy bed. Same bug. But is only that one this time.


I’ve tried to build some of these ready "blueprint"houses the game has. This one is cozy townhouse and citizens build the house, but do not place furniture, even though carpenter made them just for the building.
Steps to reproduce:

  1. Make citizens build something with furniture in/on it.

Expected Results:
Building finished INCLUDING the furniture being placed to their rightful spots.
Actual Results:
Building remains empty and no furniture is placed.
Is this the “famous” crate bug again? The bug that didn’t allow stuff from storage items to be placed?
Screenshot shows two cozy townhouses built. One on the right is finished, though I finally used ib command to finish it, because furniture was missing. Then I destroyed some of the ghost furniture that overlapped with finished products.

Version Number and Mods in use:
0.17.0 (develop 3023) x64 build

Stonehearth Cafe (Cooking And Farming Expansion)
Stonehearth Doorways
Settlement Decor Mod
Better Stockpiles

EDIT Closing Stonehearth and loading a save causes them to place furniture normally for few minutes, then they stop it again.

1 Like

You know, I’m not sure if I’m seeing things, but villagers seem to have really forgettable memory.

They sometimes put furniture in their places and sometimes don’t. It’s like they have a range or something. That they constantly need to reminded that there’s a building that needs to be furnished.

If I manage to place chairs into an inn, villagers come eat and suddenly they remember that
"Hey, I think our ‘leader’ wanted us to place some stuff here, let’s do it"… at least partly. When they go fetch stuff, some of them forget the building again.
The further the building is from stockpiles or if the building is in the mountains, the more furniture keep missing.