Carpenter Bug - wont craft

I’m new to helping on Alpha games so let me know if I do this wrong or I’m posting in the wrong place. I really like the game and see its potential so I figured I’d try to contribute.

I’ve started the latest version, new games, twice now and each time the carpenter will stop building even though there orders and plenty of supplies. At first I had made a game where everything was put into crates so I thought that might be the issue so the next game I just made stockpiles and the same thing happened.

Also on the second game most of the workers just stopped doing any work at all.

Another issue has been logs being left on top of houses after a build is finished and ladders not being taken down as well.

That’s all I have for now! I look forward to what you have next in store!


I am having the same problem, and in addition when i change a hartlings job to farmer nothing happens.
Btw i am having the problem in the new build [Dev-2594]

Here is my world save!U4Y3xBgC!axz91QK8M9husJrYQbl-s0kDXFs9mjlMbXsCfbfYV4Y

Try saving and loading as a workaround

I have tried that multiple times, did nothing.

Hey - dropping in to say that I’m seeing the exact same issue right now, but not just with the Carpenter. So far it appears that my crafters work correctly for a while, then stop processing any orders. My Mason also stopped making any items, and while trying to fix the Carpenter trying different methods the Blacksmith stopped working. All my initial professions are broken, but new professions seem to work for a few days. I just promoted a cook and she’s happily making food for now.

I’m starting to wonder if there is an issue releasing a queued job or if the collection of harvested items in the game (mined ore/stone, animal parts from trapping, wood, ect.) starts to mess with the AI when too much. I’m trying to only use containers as they look better than stockpiles and I keep falling behind needing to make more items specific containers for a specific item. I know that leaving wood on top of a building can bring all your hearthlings to a standstill (or least it used to.)

I’ve also had some saves crash today upon loading them - so I’m thinking I may have to try to play as long a new game as many days as I can to see if they stop working if you don’t save/reload.

I’ve had this problem with all my Hearthlings as well in this latest build. I’ve found that if you demote the hearthling to worker, then promote them again they do their jobs correctly for another 10 mins or so, but then you have to do the trick again. I think this bug deserves high priority attention since it is very close to game-breaking.


I was about to say the same thing, but I thought it was related to building a structure.

Same thing is happening to me as well. I demoted my carpenter and made a new one but he stopped working also. I agree that this issue deserves the highest priority because it is a very big game breaker.

This is happening a lot for my sessions as well. The carpenter will make a few things for a while. Usually get up to level 2 or 3, then they lose interest in doing their job and starts acting like a worker. He’ll go out and gather or build a structure with the other workers when he has jobs queued up and not being done.

Sometimes saving/reloading works and sometimes not. I’ve changed their jobs back to workers and promoted someone else which works for a while then goes back to acting like a worker again.

I have the same problem with last build (dev-2594).
Crafters work correctly for a while then stop to craft, but accept to work as worker (mining, farming, etc)
Only way I found to “fix” it, swapping crafter to worker, then swapping back to their last profession, seems work for me but its really boring.

They seem to prioritize building buildings over work orders.

I tried loading the save to see if changing jobs would fix production issues. When I do this, the game closes (crashes?) without an error.

I’ll try with a new game to see what happens.

this seems like a dead thread but im getting this problem still. My carpenter refuses to do any sort of work, he just stands idle and not doing anything.

UPDATE: seems demoting and re-promoting does the trick, still took her a little while though.
UPDATE: seems not only to be the carpenter, but my cook and blacksmith also required a re-promotion to kick start their queue.
Dev-2598 (x64)

I can now play it again. Yay! But after a while crafters just stop crafting there items even if they have the items for it. Also what ever I try they will not place the worktable down… :frowning:

It seems I found another snag with the latest patch. After the latest patch for the ladder game crashing bug was put into the game, my crafters won’t build items for me anymore. I tried removing all of my maintain tasks for them, which didn’t work. I’ll leave you my log, just in case you want to see it.

stonehearth.log (990.1 KB)


Was building my town and trying to upgrade my beds when my carpenter broke. He focused only on helping build buildings. Even once the structure was done he would not return to crafting. Everything was in place, new crafting tables, resources, beds in storage. Also noticed when I tried to delete the order and reissue the list would bug out.

So I’ve done this a bunch of times and it seems ok for a minute. But what I do is change the carpenter’s profession back to worker and then select a different person to be a carpenter. It work up to level 3 each time and then they stop and just help building. Now I’m at a point where many of my workers (crafters and not) are just standing around idle even with build orders. Not sure how to proceed from here. Bummed bc my town was getting pretty nice.

The bug still occurs in develop-2603, with carpenters at a minimum. Demotion/promotion does the trick for me. Also saving and reloading will get them to work again.

I found it wasn’t just the carpenters, but any of my crafters when crafting and building a structure at the same time. I did find a small fix for it by making the crafter switch job classes and then switch back, but this causes the loss of all exp, but not level. And it only fixes it for a short time.

Same here, very annoying.