Hearthlings don't resume crafting if they started (green item icon) and then ingredient becomes unavailable

Hearthlings don’t resume crafting if they started (green item icon) and then ingredient becomes unavailable

Steps to reproduce:

  1. Set something to craft
  2. Interrupt crafting (I guess? Such as activating town alert mode perhaps? Or another item being crafted uses same ingredient and not enough available?)
  3. Watch Hearthling doing other stuff (or nothing at all, idling) even though it has things in its crafting queue that have enough ingredients to be crafted.

Expected Results:
If an ingredient for some reason of what is currently being crafted becomes available, suspend that one (temp skip) and craft next item with enough ingredients available.

Actual Results:
I guess I already explained that?



Version Number and Mods in use:
No mods, latest version as to date of this post: release-701 (x64)

System Information:
Wintel 10 i7 32GB GTX Titan X


The only way AFAK this can be fixed is by deleting that queued item and re-queue it.

Iv gotten this bug, very annoying

This other bug is more severe: Deleting stuck orders keep the crafter stuck
Even though the steps are almost the same. Because the crafter will resume working whenever you get the missing ingredient again.

I will remind the devs to fix this if possible when they fix that one.

1 Like

here the steel shield need 2 steel lingot but i dont have it.
so why the guy want to make it ?i have steel lingo to make and i have all the requirement…
on early game this working but now not…
bug ?

Likely is the case that your blacksmith started working on it expecting all the materials to be there but your engineer got the materials first (or whomever else wants steel ingots), blocking your blacksmith.

Quick solution is to trash the request for that item so the blacksmith can reprioritize.

Yes annoying…
need a fix for this :slight_smile:

There is another possibility. As the crafter gathers the ingredients required for the recipe they are taken from the inventory count. You may have those ingredients they simply do not show anymore. If this is the case, the steel ingots are already in the blacksmiths power. Watch him. He may be gathering the other things, gold and leather, and will eventualy return to the workbench to craft the shield.

Have Fun, Kyth.

1 Like

could you rapidly coorect this annoning bug…
for create this bug… it is so simple :

pause the game
weaver : create queue of ;
=6 spool of thread
=2 bool of cloth (need 2x3 spool of tread)
1 unit of small wall-mounted banner

carpenter :
confy bed (need 1 bolt of cloth)

start -->
the carpenter steal the bolt --> weaver blocked on 1 unit of small wall-mounted banner

so reload the game do nothing…
so now… delete the craft in weaver and redemand it…

for me the carfting system is broken now

I have a problem as well, blacksmith not doing anything
please check my save to see what is wrong.
cant add my save file cause im new :frowning:

please help me, i would really like to continue this save

Welcome to the forum, @jclitje :slight_smile:
You should be able to upload files now, but if the zipped savefile is larger than 10MB, you’ll have to upload it to a free hosting site (like Dropbox, Google Drive…) and share the download link here.

ty, its not, its about 5. here you go1492911553286.rar (5.7 MB)

I hope you can find it, I have tried almost everything on this forum, from altering storage to promoting the blacksmith again. Thank you in advance

He is stuck because he run out of wood while he was collecting the ingredients.
You need to chop more trees. Your inventory says that you have 4 logs, but one of them is trapped inside a building, and the others are on top of a roof, so he can’t reach them (you might build a ladder there).

You have a building in progress, so when you get more wood the workers will start to pick them for building (and for lighting the fire), make sure to get enough for your blacksmith too.


Summary: My carpenters/blacksmiths, weavers, ETC, will stop crafting anything if they encounter a lack of a resource, like, if they are missing a mean bed to make a comfy one, they dont either: make a plain one, OR move to the enxt thing, they just idle. Even demoting and re-moting them does not work. It only works IF you move another job into their queue, and then you demote and promote them again

Steps to reproduce:

  1. get a crafter, have them make a few things (whatever you need, just have tyhem make something they can do)
  2. ask them to make something they dont have ingredients for, FOLLOWED by anything they can make (a comfy bed withouth any wool, or without any plain beds)
  3. look at the queue and look at what the hearthling does, (even if the next thing they CAN do is perfectly achievable)

Expected Results:

Hearthl;ing woul;d move on to the next best thing to do, whatever is the next item they can make, skipping the one they cant (this is the behavior as it has always been, they usually just move on to make what the CAN do)

Actual Results:

Hearthlings will idle indefinitely


This has started happeneing since alpha 22, I remeber that back in 21 it still worked just fine.


Version Number and Mods in use:

0.22.5 (release 763) x64 build

anorien biome
onehanded pike
furniture expansion plus
uinitframe activity
unitframe health
better_stockpiles (latest version as of September 24,2017)
brewery mod
spiros_gate mod
Lodewall lights
commemorative items
plant_lore (disabled)
homesweet home

System Information:

i7 6700HQ
12.0 GB ram
Windows 10 64Bit

is there any known fix for this issue? is this just me?

Try to delete everything in his crafting queue and then add what you want to craft.

Coulkd be a queue bug

I’m afraid it’s not a bug that started on A22, @TheRedBaron91 :pensive:

If they run out of ingredients while they are collecting them, they will get idle.

However, we’re reworking the crafting system so hopefully this should not happen in A23. :slightly_smiling_face:

Just a little bump, I am still getting this issue from time to time. Not sure if it is the same cause but the same thing happens where crafters get stuck on a certain item in the cue. This seems to happen when for some reason the required items for them to craft with gets used up elsewhere(?)

Every time they get stuck on a craft that I’ve not got the materials for but instead of giving up on it they just ignore any other work orders until that ingredient becomes abundant again. Which annoyingly enough is a material they need to make in the first place so production comes to a complete halt. I’ve had this happen even with 3 crafters working in the same pool though more crafters does tend to make it less likely as one of them has a chance to make it to the lower tier ingredient without getting stuck.

While the best workaround right now is having multiples of certain important items in queue it is still a pain when my queue’s are nearly capped out. Easily reproducible with one weaver and a full crafting queue of 20 of each item, they are the most likely to get stuck for me as their refined items are the most sought after.

giving the weaver a “maintain” spool of thread “command” gets him/her stuck on that command… forcing the hearth to completly ignore their job until
1: the command is removed

2: the “job” is paused/unpaused with the hearthling menu

this issue happens mainly with “northern alliances” in the “northern biome”… at least those are the only times where i could observe this issue (3 savefiles… 3 times the same issues… played a rayyas children game… the issue didnt happend… dont play “vanilla” race tho so cant say much about them)

Steps to reproduce:

  1. play the game… give weaver a “maintain basic ressources” craft command
  2. weaver starts crafting ressources… however somehow gets stuck at spool of thread
  3. weaver is unable to participate in their job

Expected Results:
maitenance of basic ressources, weaver doing their jobs

Actual Results:
weaver ignoring their jobs and standing idle or reverting to “secondary tasks” (haul, build etc)

savefile 1: savegame_stonehearth.zip (8.4 MB)

savefile 2: Savegame_weaver_bug_2.zip (6.5 MB)

Version Number and Mods in use:
current, no mods “of relevance” (just template mods… most of them not even used… and the ones i used are mines anyways)
System Information:

1 Like