Crafting certain upgrades and crafting furniture

I spent a good bit trying to make certain items and I noticed that the hearthling will have it described as currently crafting in the craft menu. I find the hearthling, and they are doing anything but. For example, I was trying to make a steel black smith hammer, and the box was lit green. It was the current queue project. I had all the required materials. I find the blacksmith and watched them for about five minutes. They wandered about, hauled some items, ate some food, chatted with a friend, and sat by the hearth. I disabled all actions but the job to see if that was the problem and they repeated the process, omitting the hauling items. I did have smartcrafter installed so I disabled it and got the same result. A current list of items I found with the same effect are; some armor pieces, steel blacksmith hammer, steel trapper knife, the last blacksmith workbench. The one used for precious metals. I cannot get those to build.
Steps to reproduce:

  1. go to crafter
  2. try to craft certain items
  3. watch them not do it

Expected Results:
They will craft the item.
Actual Results:
They do not craft the item.
I did do a second test with only ACE installed with the same effect.

Version Number and Mods in use:
Stonehearth (newest)
ACE 0.9.4
System Information:
Windows 10

He probably can’t reach his workstations. They need to stand on a very specific spot near it, maybe it is blocked by a wall or something else. Try moving it to open space and see if it changes anything

That is not the issue. The crafting benches, storage, and structures are all on the same plane. They were walking around the bench but never utilizing it to craft those specific items. If I told them to make tin ingots for example, the blacksmith would walk over and make that no problem. It was those items specifically.

Did canceling the order and re-adding it after disabling Smartcrafter help?

No it didn’t. I actually did full blown redo of the tests and had the same result.

If you post the save file (may have to upload to some other free hosting site and link from here), we can take a look at it.