Blacksmith will do anything but craft

I have experienced and issue where my blacksmith will not craft. She will Haul, eat, speak with other hearthlings anything but her actual job. I have tried pausing all jobs and unpausing, demoting the hearthling and using another hearthling as the blacksmith, and reloading. I have the required resources and the forge is in an accessible location. Please help!

Looks like my carpenter is experiencing the same issue!

could you upload your save game file?
are you using any mods?
which game version are you using?
what are your pc specs?

Have you tried to go into the menu of were your hearthlings are, and check haulingand so on off, so it’s only at crafting there is a x

@revan, if both your blacksmith and carpenter have the same issue, do you have enough wood? Can they reach it? Does it have to be looted?

Yep! Plenty of Wood. This even happens with trying to create another forge. It is accessible to all hearthlings, and no it does not need to be looted.

  • Check if there’s a greened item in the crafter’s queue
  • If so, see if any of the materials is missing for that specific item
  • If a material is missing from that thing, remove then re-add that item to the list

Sometimes it happens that a crafter gets stuck on a specific item in the queue because another crafter steals the last of a material that was previously available. I believe it was reported in the past, but wasn’t fixed yet.

If this is not the issue, you might want to make sure if the requested material isn’t located in a crate that can’t be accessed.

That’s not the issue. I just stated that the resources are accessible, and I already tried emptying the queue and then adding the items back to the queue. :confused:

How do I upload my save game?

You have to upload it to a file hoster like drop box and share the link here.


I have experienced this same exact issue!! BUT WITH SOME SUCESS!
If you play Stonehearth like me, you maybe using the “ib” command quite often in the command console.

If you are playing like this, I have a solution.
From my experience, this is what’s happening;

You are building your “pottery shop” or “Blacksmiths shop”, and you are using the “ib” command to finish the job. GREAT! You now have a instantly finished building. The only problem is, when you created it with the command console, the computer does not register it as a placed item by an Hearthling, since it did not come out of your inventory.

If you command an Hearthling to relocate the object (furnace, anvil, etc.), or put it in your inventory, and place it again, it should then register as an in-game item. Then you can Craft-AWAY!

I hope this helps,


1 Like
  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.