Blacksmith won't craft anything

When I click the “Craft” button in the Blacksmiths UI nothing happens. I have tried to save/load, to demote and promote the Blacksmith, close the game entirely but nothing seems to solve the issue.
Weirdly enough all my other crafters seems to work fine.

Steps to reproduce:
Not sure how to reproduce it but I attached the save file to this post.

Expected Results:
Selected item to craft, showing up in the queue and gets crafted.

Actual Results:
Nothing happens.


Save file

Version Number and Mods in use:
No mods are in use.
Alpha 14 (release 519)

System Information:
Windows 10

8GB Ram
Samsung 850 Evo 500GB

Whoops seems like I forgot to add the save file, and the site is not allowing me to attach a file anyway.

hey there @TillableToast, welcome to the discourse :smile:

[quote=“TillableToast, post:2, topic:19793”]
the site is not allowing me to attach a file anyway.
[/quote] i’ve bumped you up to TL1 so you should be able to upload the save as a .zip now :slightly_smiling:

1 Like

Thank you so much! :smiley: here is the save file (7.8 MB)


Summary: I have many maintain jobs for the smith and and order for an anvil. I have the bar to make anvil and in the orders it says crafting but he never does.

have you tried a save/load? that seems to be the quick fix for most problems. just save the game then reload that same save right away. that might give them a ‘kick’ start :grin:

Yes that does work thx, but doesn’t really explain why it happened in the first place

im not sure myself I have that with my Hearthlings mining or building… or forgetting to finish a building

the only things that seem to work for me for most tasks they go idle with is call to banner. suspending a job for a bit or save/load

Calling @8BitCrab and/or @jomaxro . any other ideas or work arounds/ solutions ?

It looks like your town is underground. Maybe your smith is busy mining, if you’re actually mining. Try unchecking mining on his work tasks, as well as haul, though im not sure if he needs haul to move finished objects to a location.

Nope, he wasn’t doing anything at all. He was idle.

do you have free space for bars?

Yep plenty of space.

do you have wood? i think smelting 1 bar takes 1 wood + 1 ore.

EDIT (since im new): try checking for placement of the foundry?

Yea i cleared out the area right outside of my cave so i had like 3 stone chests full of wood.

Hmm…this is the second report of blacksmith issues in the release-519. Let me do some testing…

…Edit: so far no luck replicating this in my testing. Will load up the save posted and look again tomorrow. Also, welcome to the Discourse @Lord_Draxis!

I noticed similar thing with my weaver, but once I redid his orders and kept the maintan orders in much smaller quantities (12 at max), he started working again.

And is that forge against the wall? Maybe try planting in the middle or room and see if that puts the smith in action.

I have been experiencing the exact same problem.
I’m running windows 10 64bit with GTX 950 ti, with and intel i5-4460 8GB ram. (i have updated to alpha 14 btw).

Hey there @UnnervingS, welcome to the Discourse! Thanks for the confirmation. Would you be able to upload the save where you are experiencing this?

To upload a save, locate the folder in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

Add me to this list now.

I think I might know what is causing it but you might need to do some testing to try and reproduce the issue.

The first person’s problem happened when his original blacksmith died and he promoted another. The new one wouldn’t craft.

In my case, the issue occurred after I promoted my Mason to Blacksmith instead of picking a new worker to become the Blacksmith.

So the problem may exist for ‘reassigned’ hearthlings. The crafting / assignment programming for Blacksmith isn’t clearing out the old data from the previous one. This is also the case of promoting a different profession to it as in my example. My Blacksmith wasn’t advancing. He would smelt bars… and it took me about 20 or so of copper and tin before I realized he was never advancing to Rank 1 at all.

I unassigned him and reassigned him - did not help. Finally just left him a worker and assigned a worker to Blacksmith who hadn’t already been another profession - at first the new one wouldn’t do anything, just idled. Then I restarted the game and it seemed to kick him into action and he’s been working fine ever since. That old Blacksmith, he’s a worker but if I assign him to any other job - he won’t do it.

They need to fix that - whatever in the programming retains their ‘skills’ or flags them a profession isn’t getting cleared out when you unassign or reassign them and if the previous Blacksmith dies, same issue… the data is staying in there somewhere.

Hope this helps. Should be pretty easy to reproduce in internal testing:

  1. Level up a Mason and then promote the Mason to Blacksmith instead of promoting a Worker.
  2. Mason turned Blacksmith will either not craft anything at forge or will craft but not level up Blacksmith.
  3. Unassign non-working Blacksmith and assign a regular worker to Blacksmith.
  4. Newly assigned Worker to Blacksmith should work properly (may need a save/reload of game).

Hi there
Thank you for posting this bug. I loaded up the save and something is definitely going on with the crafting queue in the back end. There are items in the queue but it’s not being sent to the UI, etc etc. I will investigate.