Blacksmith ceases to work -- Solved

I am currently on a save that i’m doing well on, and it’s making me annoyed that my blacksmith won’t do any crafting i have queued up for them. I looked at previous threads and tried their solutions but it didnt work. I don’t know what caused it, the blacksmith just stopped crafting. All they do is sit idle and haul stuff. I tried making more storage for the Ingots and ores, i tried demoting them back to worker then re-promoting them, i tried emptying their crafting queue and re-adding the stuff (that’s what i saw to do in the other thread i viewed), and i reloaded the save, but they still wont do any work. I am using a few mods that i found here: The balista mod, Wizards mod, better stockpiles mod, and the jewellery and leadership mod. It was all fine up until 10 minutes ago (at least from what i saw, who knows how long they haven’t been doing their work.) Can anyone try and help me?

To anyone nice enough to click this, thank you, BUT trying again i now see my error in why it wouldn’t work. It wasn’t working, but clearing the queue thing worked but my stupidity wouldn’t let it continue. Long story short, you don’t need to craft something when maintaining 1 of it when you have 10. But thanks again.