Blacksmith stopped working

My blacksmith just suddenly stopped doing his job.

He used to just do it like he was supposed to and I one day I noticed he stopped after he reached level 3…

I’m on the latest version (04/29/16).

Do you still have ores, wood, etc?

Try clearing out all his tasks and then re-queuing them afresh, sometimes that fixes jammed workers for me.

Thanks for the reply, but that’s not working for me :confused:

clear path to all the ore, wood, the smith, the anvil/forge, etc?

1 Like

I’ve seen it once.
Try depromotion and promoting your blacksmith :slight_smile:
Worked for me, hope it will for you too ^^
(This doesn’t/shouldn’t reset his lvl as blacksmith)


hey there @lanessear, welcome to the discourse :smile:

hmm… not a good thing for crafters to be stopping doing their job…

could you perhaps provide your save file? to find the save go to this file path,

C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games

if you don’t know which save is the newest one, you can check the screenshot inside the save folder, then zip the individual save’s folder (not the entire saved_games folder) and upload it directly to the discourse either by using the upload button , or by dragging and dropping the .zip file.

if the save is larger then 10mb you could upload it to a site like googledrive or dropbox and provide a download link.

1 Like

Thanks to everyone who answered so quickly!! This was sort of the problem here. I tried placing the forge randomly so all the sides would be free, and I noticed the blacksmith works on the opposite side of where the arrow points to… Pretty simple solution but that’s the first item where it happens for me so far.

1 Like

I am currently on Alpha 16 (release-559) running the x64 version on Windows 10. I am experiencing the same issue, although replacing the forge does not help. I’ve tried all the things mentioned in regard to this bug:

  • replacing the forge/anvil
  • removing all items from the queue and adding them again
  • removing all items, saving, closing the game, starting the game, loading the save and adding items again
  • demoting blacksmith and promoting
  • promoting a new hearthling

The blacksmith (new one or old one) just won’t do their work. They do pick up the materials from all the boxes, but then just hang around.

Same goes for the carpenter. I don’t think this bug is related to the blacksmith. I’ve experienced this in one game so far, where I’ve been playing around with the new faster speed.

Sadly I can’t upload attachments. I will wait until I hear back from someone :slight_smile:

1 Like

sorry about that, i’ve bumped you up to TL1 so you should be able to upload attachments now. :slight_smile:

1464645849772.7z (4.3 MB)

And here’s my save :slight_smile:

1 Like

Looks like I’m alone with this problem. I’ve started a new map and I’ll see if it happens again, but I’d like to continue on my old one still :slight_smile:

Did you double-check if there is storage available for the bars/items next in the queue? I had maybe the same and it was because I was storing bars in chests and he ran out of room.

Hi @mdiener,
It looks like the pathfinder is having a tough time getting to the stone chest you have with wood inside it.
I’ll look into the pathfinding issues. In the meantime, try moving a chest with wood logs into your blacksmith’s work area and see if that makes it better.

1 Like

Hah! I moved all the workers into the same building, moved all the storage stuff either into that building or right in front of it and it works! So I guess there WAS a path finding issue … Glad it works now though :slight_smile:

Should I open a new thread with the specific issue of the path finding or are you tracking it?

I think @not_owen_wilson is working on it. No need for a new thread. Thanks!

this issue with the blacksmith is still present. any solution?

What version of the game are you playing? The blacksmith issues should be better in 3032. If they are not, please upload your save and I will diagnose.

hi, the issue got solved by itself, had to relocate the anvil and the forge, also had to destroy previous ones

1 Like