Blacksmith(s) Not Crafting

Blacksmith, when Build, Haul, and Mine turned off, sits Idle, despite having a list of items to craft.

Steps to reproduce:
Last thing he built was the Scout Gong. Not sure what caused the problem.

Expected Results:
Usual crafting behavior

Actual Results:
Alton is visibly doing nothing, Idleness listed in the Citizens, though in his workshop on the Orders screen it says Crafting… and is green on the right bar.

I have read other posts and already tried the following:
Saving and reloading
Moving the chests with the ingredients so they are definitely accessible.
Moving the forge and anvil so they are definitely accessible.
Dumping inaccessible items.
Demoting Alton and promoting a Freya to Blacksmith (same exact results)
Clearing the queue and starting again, with different recipes, in groups and one at a time

Actually…I went back in to double check it was still not working before I posted this and now everyone seems to have given up on two buildings that were coming up, even after I’ve saved and reloaded, paused and unpaused the building, and set the workers to Build only…so maybe the file is just corrupted somehow? Should I revert to a previous save from a few days prior?

I’ve uploaded my save to OneDrive, here is a link:!Ar70yxFAcXvHh2Ipgd9YGcje6tdC

Version Number and Mods in use:
The current Steam? 0.21.0 release 707, it says on the launcher. No mods.

System Information:
Windows 10 - 64 bit.
16 GB Ram
i5 with an integrated graphics card, nothing special

Hello? Anyone out there? =/

@LittleLionFlower, try getting more wood.

Your blacksmith can’t get to it so he can’t progress with his current order. I don’t know yet where are the 5 logs that your inventory claims you have, but apparently they are unreachable for him.

Edit: They seem to be between the stone chests. There’s a single block mined down, and hearthlings dropped items in there. Hearthlings can’t pick them up unless they are in the same level next to them, so you’ll need to mine the block next to those items.

1 Like

Oh my goodness, I can’t believe it turned out that simple! Thank you so much =)