Hearthlings not crafting

People not crafting
Steps to reproduce:

Expected Results:
Create what I want them to create
Actual Results:
sit there doing nothing
plz tell them to work

Version Number and Mods in use:

System Information:

hey there @AGamer_Jason, welcome to the discourse :smile:

could you perhaps provide some more details?

  • what version of the game you’re playing on
  • which crafter it is

I’ve run into this one also, Usually the blacksmith in my case. He’ll pick up the mats he needs, then just stand there doing nothing. He will, of course, return to normal after reloading a save.

1 Like


I am running Stonehearth 0.14.0(release 524) x64 build.

I purchased and play the game via STEAM.

My Blacksmith seem to have problems with crafting.

Specifically, if I set her to craft iron or steel ingots, or items requiring those as components she would remain idle.

If I added things to the queue she would remain idle. I had to empty the queue and then set her to craft copper ingots to get her back to doing anything. If I then tried to have her craft iron or steel ingots 50/50 she would do so successfully.

Quitting and reloading the game seemed to fix the problem for 5-10 minutes of realtime but it would always come back.

I was at population 17 when I noticed this start happening.

Hope this helps.

1 Like

@AGamer_Jason, @djreptile, @Karede: There were definitely issues with “stuck” crafters in A14. We have not had any recent reports in the latest A15 builds. If you want to give A15 a try (it’s pretty stable at this point), check out the instructions to access the Latest branch on Steam on the Stonehearth website Development page.

I was running the a15 unstable when this happened. Just fyi. I seems that one of the recent patches may have fixed it though. I haven’t had the problem in a few days now.