Crafters getting stuck - whats the latest scoop?

Hi all,

I’ve been following the game since the kickstarter, but have only dipped my toes in occasionally, as I don;t want to burn out on the game before the final release. The last time I played was Alpha 9, before that, alpha 2. Anyway, I reinstalled and am playing the fast track Alpha 17.

I’m on day 28 and doing pretty well, but suddenly my carpenter and blacksmith have stopped doing their jobs. They’ll do other jobs, like hauling, restocking etc, but they will ignore anything put into their own queues and just go idle if they have nothing else to do, although I notice that in the queue breakdown page it says they are crafting.

I tried the usual stuff like demoting/re-promoting, moving the workshop equipment, saving/reloading etc. I have checked it’s not that something is stuck in the queue by missing ingredients etc.

I think it started when I designed a big building which was going to be a shared crafter space, and I put one of each of the crafters flags on the wall outside the door. The new A17 loads these into crafters’ queues, but it doesn’t put ingredients in the queues, so obviously all the crafters got a “stuck” flag in their own queues because there weren’t any of the blank flags the carpenter makes. I queue up several of the blank flags, and he made those, and then never made anything else. This could be a coincidence of course, but I’m pretty sure the timing is right.

What’s the current state of crafters/idle bug. I thought that had been fixed several alphas ago? I can upload my save if it would be useful.

Are your crafters only idle when assigned jobs from buildings? Have you tried crafting anything, other the plain wooden signs, that was not auto-queued?

1 Like

Yes, anything I now add to their queue gets ignored, although the highest up thing will say “crafting” on the orders screen. This is through adding it manually, rather than via the autocrafter in A17.

Probably a bug; upload your save :slight_smile:

1 Like

How do I upload a save?

thanks for helping out @jjjshab :smile:

@BrianNZ, to find the save go to this file path,

C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games

if you don’t know which save is the newest one, you can check the screenshot inside the save folder, then zip the individual save’s folder (not the entire saved_games folder) and upload it directly to the discourse either by using the upload button , or by dragging and dropping the .zip file.

if the save is larger then 10mb you could upload it to a site like googledrive or dropbox and provide a download link.

hope that helps :slight_smile:


Thanks 8-Bit. Long time no see!

Save attached for whoever does bug checking :slight_smile: (7.6 MB)


no problemo, and good to see you back around here mate!

i’ll page @yshan for you :slight_smile:

1 Like

For the record, I managed to resolve this. Saving/reloading, even closing Stonehearth didn’t help, but rebooting my PC and then going back in did fix the issue, so maybe there’s a memory leak issue? (perhaps around auto-assigning jobs to crafters?)

1 Like

I had the same issue, and indeed restarting the computer solved it (which is pretty strange). One more addition: on the Citizens dialog, I was turning off all other activities for my mason other than job. It didn’t work, the mason was still going for building, and if not that, it just went idle.

1 Like

Yes, I found the same behaviour exactly!

1 Like

my weaver just got stuck. deleting the item that’s stuck works but thought it might be something you want to look at: (6.7 MB)

I’m finding that exact same thing with my blacksmith. And you say a restart of the computer works? Or just a complete shutdown? Nice to know I’m not crazy.