[Res] Carpenter gets stuck

resolved

#1

**Title: **
Carpenter gets stuck while he is supposed to work

**Summary: **
When giving a carpenter a bunch of work e.g. beds, chairs, you name it, he initialy starts to work but then seems to get in idle mode despite having unfinished business.

After some time in idle mode, while wandering around, the carpenter just freezes while in walking animation.
You could still see when he gets hungry but he wont move anymore.

Steps to reproduce:

  1. Promote a random citizen as carpenter and build a workbench
  2. fill his job-queue with various items (in my case 2 tables, 6 cardinal chairs, 6 mean beds, 1 hoe)
  3. let him do his job, after some items crafted he will stop working but start wandering around till he freezes

Expected Results:
I expect the carpenter to do his job-queue unless he has material and once finished to wander around (if he must :slight_smile: ) but not to freeze

Actual Results:
Carpenter gets stuck in walking animation, doesn’t complete his tasks and even sank into the ground once I re-loaded the savegame

**Notes: **
None further

**Attachments: **
I would have a savegame, but unfortunately do not know where to find it on the pc :frowning: any hint?

**Versions and Mods: **
Alpha 3 Steam release
Mods --> none

**System Information: **
Intel i7-3770
256GB SSD
AMD HD-7950
8GB RAM


Worker getting stuck on scaffolds (and other nonsense)
#2

Oh noes! the carpenter got lazy again. I think it’s normal, you always give him so much work to do at once :angry: This happened in older versions, let me check for similar threads…

The savegame path is this C:\Program Files (x86)\Steam\SteamApps\common\Stonehearth\saved_games

But, I wouldn’t recommend posting save games, to tell the truth (even people already did this)
because loading is really really buggy. But still could be of some use.


#3

This is definitely happening in this build, and it’s definitely new. But we’re still not sure how to reproduce it regularly. If you can, please let us know! We’d really appreciate it.


#4

You know if the carpenter doesn’t help the workers, he need to do his own job, and this means a lot to craft.
Gosh I have a town to build up :smiley:

Thanks for the tip with the location

EDIT: Just tried to upload, but wasn’t allowed to add .bin files. To be honest I couldn’t tell which one to send either (client_state or server_state)


#5

Honestly speaking I got this bug every single time.
Even playing the version before this one it got stuck.

What I did then was:

  1. Getting the carpenter promoted, workbench (all the stuff to start)
  2. Getting the following items in his job queue:
    6x mean bed
    2x table
    6x cardinal chair

The only difference to Alpha 3 is, that previously he got stuck after the tables, so I was never actually able to produce a cardinal chair.

Before he stuck you couldn’t convince him either to get back to his duties by deleting the remaining tasks and adding new once, he just walk till he finally stuck.


#6

Yes, I’m referring to this thread, in which several people report about a carpenter with a job-queue that ends up freezing. It’s similar.


#7

I have definitely seen the carpenter get stuck, but I’m pretty sure it’s not JUST the number of things you give him:

Maybe there’s some intersection with eating, or sleeping or deleting things from his queue?


#8

My carpenter is currently stuck, he has somehow acquired a fabled invisible log, the wooden overlords are yet again angry:


#9

This seems strikingly familiar, but in my case it happened with a regular worker on a house. I would suspect that it may have more to do with the AI task handling.

I also just got the same error with a carpenter on another save of mine. It spammed some errors about the AI failing to return a value in ‘pickup item on a table’ action.


#10

Also happened in my tries when I gave a carpenter more than 1 thing to make.

In my version he was tooking a very long nap. (first nap, then carpenter’s AI crashed at thinking).


#11

Gotcha! Many thanks to @Ponder and @not_owen_wilson. This bug turned out to be in the Task Scheduler and is now dead on my machine.


#12

kudos! :smiley:

so whats the protocol… do we flag this as [Res] and move it to the lovely new sub forum, or wait till this is actually out in the wild (subsequent build)? i’m guessing we mark it as resolved now…