Carpenter not crafting

Summary: My carpenter no longer crafts what is in the queue, he acts like a normal worker, hauling, building mining etc.

Steps to reproduce:

  1. Get a carpenter to level 4
  2. Tell them to craft something
  3. Nothing happens

Expected Results:
Carpenter crafts what is in his queue
Actual Results:
Is either idle or acts like a worker


Version Number and Mods in use:
No mods release 707
System Information:

hey there @DukDuk4,

is this something that stays on save/load? if so, could you upload your save,

To upload a save, locate the folder in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

thanks :slight_smile:

I had the same with my cleric and indeed a reload did the trick

I’m having a similar issue with my Blacksmith. He seems to have just…stopped? I’ve tried saving and reloading, clearing his queue and restarting, different recipes, moving the anvil and forge, moving the crates with the ingredients… I can’t think of anything else to try. He’s just idle, even though the craft menu says “crafting…”

Help please? >.<

I’ve uploaded my save to OneDrive:!Ar70yxFAcXvHh2Ipgd9YGcje6tdC

Different enough at this point to start a new thread, I think.

Saving and reloading did not help, but he started working again after i tried a few different recipes. I don’t how but it got fixed.

@DukDuk4, there are several possible reasons why he was stuck. For example, someone else might have stolen the next ingredient he was going to pick up, or he couldn’t reach some of the ingredients or the workbench. You might have deleted an order that was stuck and he wanted to finish it first (that’s a bug that’s currently prioritized in our list).