Carpenter almost exclusively works on building; plenty of crafting work to be done


#1

Well, not sure if this is a bug, or an intended feature somehow, but either way, I think the carpenter should be weighted more towards crafting items if they are in the list, rather than building, especially if there’s wood in the stockpile and others are already building the house(s) in question.

I had queued up several items for the carpenter to craft, but after the first few (wooden sword & farmer’s hoe), (s)he (can’t remember sex) exclusively worked on the two (rather large) buildings I had planned out. Leaving all my poor citizens to get ever more back-pained and groggy from sleeping on the ground so much.


[Con] No doors/windows are build into building
[Con] UI freeze upon joining citizen
[Con] Carpenter Crafts In Odd Numbers
#2

It definitely is supposed to work as you describe; crafting things is more important to the carpenter than building. It is possible that if they had a half-completed build task in progress, they would finish it before starting their workshop work.

Which is not to say there isn’t a bug! Can you check next time you see it, whether the materials are available (right now if they don’t have the materials there is no way to send an alert about it, TBD) and whether deleting the job/saving/reloading helps?

I just want as much data as possible to find the source. :slight_smile:


#3

Well, like I said, she did craft two items already (the sword and hoe). I made this screenshot later:

You can see Campton asleep on his output stockpile after quite a bit of work making tables and chairs. However, my other (original) carpenter, Norsa, whose workshop is the one in the back, has still not gotten back to work (which is why Campton is still sleeping on the grass). You can see a log resting there all the same. This makes me think the workshop somehow got bugged, causing her to default to other work (namely building the houses).

It doesn’t seem to be that she was just still in the middle of that task either (should the entire house be one task, anyway? Don’t they reevaluate for every new log they get, for example?), because the houses were later done and she just started hauling logs etc.


#4

Yeah, that definitely sounds like her “use workbench” process got interrupted, and couldn’t figure out how to restart itself. What happens on save/load?


#5

Still the same issue. The finishing of the buildings actually took place after a reload.


#6

Noted! If it happens again, let me know if there’s something–anything that consistently causes.


#7

Will do! I just wish I remembered what happened originally.

Oh! I do remember something else. When I was giving the crafting orders, and I clicked the increment by one button, it instead incremented by two at a time. Thankfully, I needed 7 beds and 7 chairs at the time, so it worked out, but still, it was noteworthy. Might be related? Later on, when I had Campton working as a carpenter as well – this was after a reload – the increments were one, again.

EDIT: then again, if that was it, then why would the problem occur just then? The next order was a weaver’s spindle item thing (what’s that called again?), which she just was to make a single one of. Unless I gave the orders for the beds & chairs after the sword and hoe were done, but before the weaver thing was… not sure.


[Con] Carpenter Crafts In Odd Numbers
#8

I have definitely seen this too. I think it happens when the workshop updates for the first time after you’ve queued a bunch of things. I still have no idea why this would be, though. T__T. Javascript, you SO WEIRD!

Workaround: you can actually type in the little box with the number. But the cursor is missing! Still, pretend it’s there, click in the box, hit backspace, and enter a number. You can also just close the window and open it again.


#9

I noticed that, although that was after the reload when it already just incremented by 1 again. At least in this case it didn’t cause me any issues (except if the bugged out carpenter workshop was related, of course).


#10

Happened again in the new game I started today: things queued up, wood block still on the workshop, carpenter not crafting (idling, in this case). Only common factor I can think of is that I again had a Weaver Spindle in the queue. Also, this was the game where I had no wood in my stockpiles (but plenty outside it) and all my builders were also idling. There was wood in the stockpile when I noticed the carpenter idling in the game from this topic, but it’s possible it wasn’t there when the workshop bugged out.


#11

I’m such an idiot, of course it’s the Weaver Spindle! I don’t have any fiber, after all. So I guess the carpenter gets the wood for it, because it’s there, but then finds no fiber and so can’t make the spindle. Seems like the obvious answer. Thanks to @Rayocku for making me realize this with his video.


#12

you are welcome :stuck_out_tongue_winking_eye:
Glad i could help :smile: