[WIP] Final Fantasy Jobs [A20] - Downloads available


#1

The plan for this mod is to incorporate jobs from the Final Fantasy games as new classes, so far I’ve created a few gear sets that are usable by the existing classes from the vanilla game as well as adding the black mage and paladin class.

These have been updated for A20.

paladin.zip (150.2 KB) This is the Paladin Class v4 - it will require more testing and balance, the paladin uses the same base outfit as the gear set I released for the Knight. see post for V4 details.

paladin_af.zip (93.9 KB) This is the lvl 3 gear set for the Paladin

black_mage.zip (146.1 KB) This is the Black Mage Class v8 - upon learning level II of a skill they now wont cast the level I version anymore

black_mage_artifact.zip (56.8 KB) This is the lvl 6 Gear set for the Black Mage

dark_knight.zip (47.2 KB) for lvl 6 Footman

paladin.zip (107.6 KB) for lvl 6 Knight - same set as paladin af, keeping this download available for those that don’t want the paladin

white_mage.zip (39.3 KB) for lvl 6 cleric

This is how they look in game plus another set i’m working on:


Alternative options to the cleric
Qubicle resizing
#2

welcome to the discourse @Reyn :smile:

even though i haven’t played FFXI, i look forward to seeing this mod :slight_smile:


#3

Hey 8Bit! I’ve looked through a lot of your stuff, you’ve got talent my friend!


#4

Dark Knight screen 1


#5

I’ve had some decent progress but unfortunately hit a couple of snags. If anyone can shed some light on this for me that’d be awesome, also if you want the files let me know.

Issue 1 ------- SOLVED

In the equipment tab on character screen for the life of me I can’t get it to display correctly, I’ve looked over and over but I’m missing something.

Also how do you make the armor and weapon attributes display on that screen?


#6

Issue 2

I’ve created new types in the blacksmith recipes screen and the armor turned out fine but for some reason the weapon stays attached to tools… again I’m stumped.


#7

Mod Update:

Added Paladin armor, helm and weapon


#8

your models are really good! have you had “practice” with voxels before this?

glad to hear you got that fixed,

i’m not sure why this would be happening, but maybe @Drotten knows…


#9

Maybe you aren’t mixing into the blacksmith’s “recipes,json” file correctly? That’s the file which determines where items/recipes are grouped.


#10

What’s the category’s name? I’m thinking that its name could be “Tools,” hence why they’re showing up there.


#11

Totally off topic but, welcome to the discourse!


#12

Hey guys, thanks for all the replies :slight_smile:. I’ve never been active on a forum before, its all a bit new to me and I don’t know how to do everything correctly yet haha :smile:.

Thanks mate! really glad you like them :blush:, I dabbled a few years back with models from a game called “Cube World”, But nothing really. Generally I just draw from a few pictures of what I want it to look like.

I think this is the problem, only other option is if I’m not adding it to the en.json file properly. But I just can’t see what I’m doing wrong haha, it worked for the “Artifact Armor” just doesn’t want a bar of “Artifact Weapons”.

It’s meant to be “Artifact Weapons”, I got “Tools” and “Weapons” separated again but I don’t know how that happened lol.

Sorry I would post up the code for the recipes.json and en.json but I don’t know how other than copy/paste from the open file, doing that makes the formatting stuff up though.

Thanks! seems like a really good community :relaxed:.


#13

you can upload them (in a .zip) either by using the upload button , or dragging and dropping the .zip


#14

Ah cheers 8bit :slight_smile:, I was trying to show the code in the post without having to download a file but download is probs best way to do it.

Here’s the recipes.json and en.json for the Dark Knight job if anyone wants to have a squiz, I also changed the category name from Artifact Weapons to Relic Weapons to be more inline with the FFXI lore.

Dark Knight.zip (899 Bytes)


#15

Mod Update:

Changed Paladin relic weapon -


#16

loving the paladin, they are always my favorite :slight_smile:


#17

I found a couple of issues in there.

  1. In recipes.json, for the name within relic_weapons: it’s missing a ‘)’ at the end.

  2. For the same name: it’s referring to relic_weapons_name, but it doesn’t exist in your en.json file. Instead, there’s something called artifact_weapons_name there. Just change one of them to match the other.

Hopefully, after those two are corrected, the category should show up as intended. :slight_smile:


#18

@Drotten

Your a legend! that fixed it all up and now they have a relic weapon category of their own. I would of never found it so again thank you for taking the time to look over it for me :smiley:


#19

Mod Update:

I’ve created the paladin’s shield, in the pic the right side is shorter than the left this has already been corrected.


#20

Mod Update:

Shield has been fixed and is now visible, I just need to work on its position and maybe tweak how it looks.