Windows and doors randomly going on adventures

items
ai
a23r783

#1

Summary:
I’ve been messing about with this building (attached image below), not paying much attention to what was going on. But at one point I took notice of something weird… One of the doors and multiple windows simply vanished from the building.

Note: I attached the save file and the original blueprint of the building below.

I do not really know what has caused this. Perhaps one of couple things:

  • I vaguely remember replacing blue flower pots with pink ones because my carpenter didn’t like the blue ones.
  • I had to rearrange the fences a little bit, because the builders did not faithfully follow the instructions.
  • At one point during the construction I had to manually place a ladder because Hearthlings are just stupid.
  • (I replaced a mean bed with a comfy bed, but at this point the windows were arleady gone.)
    .
    .
  • I clearly remember that every window and door was correctly placed before this incident occured!

Steps to reproduce:

Unknown.

Expected Results:
Windows and doors stay when they are.

Actual Results:
Windows are doors going on an adventure.

Notes:
As seen below in the image, the doors and windows completely vanished:

Attachments:

Version Number and Mods in use:

System Information:

  • Windows 10
  • AMD Ryzen 1500x
  • Radeon RX460
  • 16GB RAM

Placables disappearing while building
[New Builder] Objects sometimes not being placed and ignored
Ghostly Seeds & Uprooted Plants (r826)
Windows not placed
#2

This happened to me, as well, in a game that I started only a few days ago. The house was built correctly. One of the windows at the front of it simply vanished.


#3

Two games in a row now, I’m seeing ghost seeds/uprooted plants. They read as being in the inventory, but they can’t be placed or sold and they do not appear when I go searching through the inventory containers or around on the ground anywhere. I’m seeing it predominantly in the RC side of the game. I have not yet checked Ascendancy side to ascertain if it carries over.

It seems to start with the Acacia seeds, which I’m currently experiencing in my re-embarkment game. I tried to plant 3 trees because it said I had three seeds to do so. I have two trees, one ghostly apparition of a tree where the third one is ready to place, and the inventory says I still have one seed to plant. The most recent vendor can’t buy the seed because it’s not in the inventory.

I’ve scoured through all the backpacks of the Hearthlings and no one’s hiding it.

This is a bit of a frustrating issue.


#4

This is an awful bug we’re trying to track down. It can happen with any placeable item.
As a workaround, you can try save / loading, and then opening the default console with ctrl+C and execute dump_inaccessible_items. This will dump your missing items near the banner.


#5

Oh this issue is present in the savegame i uploaded in the “unable to undeploy thread” There are at least two wooden chairs that only exist in the place an item menu, but nowhere else…


#6

Should we upload saved games? Would that help, @Relyss?


#7

No need, sadly this is a completely random bug. I already have the one from the first post, and some other ones that I made when I managed to reproduce it.


#8

Oddly, I didn’t realize this was associated with the door/window bug. I’d never had consumable items wander off like that until I started playing on the Unstable branch. I thought maybe it was just part of playing unstable.


#9

It’s become more frequent ever since seeds and undeployable plants were introduced, but it’s an older bug.

In fact, the “dump_inaccessible_items” command exists because this bug happened in the past, and we needed some way to verify it. I’m trying to find if it was ever fixed completely and has regressed, or it simply got dormant for some alphas and has resurfaced now :confused:

Definitely want to fix this before stable. But it’s difficult to find the exact moment where the item disappears (in the code), since it normally works just fine.


#10

I’ve had whole stair cases disappear. Appears to be only the textures though as the Hearthlings are happily walking on air.


#11

I do not know if it happens with other versions as well.
When I place objects, sometimes it happens that one is not placed.
The spirit is there but the object is never set because it does not exist.
I have a chair I can place it out of the objects but I can not sell the chair and it is not in stock.
Only the spirit is there
and can be broken off then it is there again as a placeable object but is never placed because it does not exist.


NEW BUILDER VERY UNSTABLE BRANCH O.o
#12

Do you have a save where this has occurred?

Thanks!


#13

I think i have found the Problem!

I use Autosave.

If I place an object and automatically save the game at the same time, the object is placed but not subtracted from the storage.
It is then no longer in stock but is still displayed with one.


#14

That could be one instance of the problem, I will try to repro with those steps.
But I’ve seen this “teleporting” / “disappearance” happen even with no saving involved.

It’s so spooky looking at a hearthling placing an item and at that moment another item a few blocks away disappears :slightly_frowning_face:


#15

Well I must confess that this was an existing save in which the the builder was updated. But in the chance that it may be helpful I will go into more detail on what I found. First this only happened to stairs inside of building. Also, I found that when using the slice tool the stairs were visible, but when using the vision mode to look into the buildings they appeared to not be there. If it happens again in my current new game I will send the file.


#16

Okay then, same thing happening on new game. To add to this, I have roads that Hearthlings ignore and when they are on them do not give speed bonuses. There is also an Issue of items saying they are in use and can’t be undeployed this includes thing like berry bushes and plants in the world.

Will send save file after work and list of mods.


#17

I’m building a wall with a bunch of garden lanterns inside of it. The lights keep disappearing when new ones have been placed! I’ve already built this template in the previous alpha and nothing like that has happened.

Steps to reproduce:

  1. Have a simple building with I guess at least 60 placable items (mine are stone garden lamps and there is 100 of those)
  2. Save as template
  3. Place down
  4. Build and watch

Expected results:
Everything builds and stays put.

Actual Results:
Every new lamp deletes one that has been placed prior to it. I have a little over a 100 in the template and only 59 stay at once.
Update: Ok, there are, like, moments when every new one disappeared and moments when they stayed.

Version Number and Mods in use: r-838

Notes:
I’m providing a save with the building in progress. Watch those lamps closely as they poof.

Save: Lamps.rar (3.3 MB)


#18

Summary:
I wanted to build a big fence surrounding the poyo coop with the new builder in order to protect them from attacks, but I noticed that my hearthlings left a few openings, thus leaving my poor poyos and the chicks to die

Steps to reproduce:

  1. In my case, make a big fence area
  2. Watch the hearthlings build
  3. Look at the finished structure for missing objects

Notes:
According to the new builder, the structure was deemed done. I also was unable to place fences on the missing spots because in the blueprint view they are present, thus blocking my way to place it. If I place it a block further away, the placement gets registered, but my hearthlings ignore it.

During the construction of the fence, my hearthlings got attacked before, which may have interfered with the construction.

Attachments:
20180510172405_1
This is truly heartbreaking :frowning:


#19

I wonder if this is related to this legendary crafting materials gone missing bug that’s already resolved for the next build.


#20

I didn’t get an engine error, though, plus the objects were already crafted, but still not placed