Bug List Alpha 4, Release 0.1.0, Build 127


#1

Please post bugs below and I will add them to the list :slight_smile: I use Serious and Not Serious to determine whether it will crash the game or break the game or not.

  • The floor eraser is a bit buggy (Not serious)
    Clicking on the eraser wasn’t giving me the eraser straight away, was giving me the regular hand tool (one time after selecting eraser and going back to drawing, it didn’t draw the new tiles, had to select the draw tool again)

  • Modifying buildings can cause considerable lag (Not serious)
    I’m not so sure about this one, because I think it will need to be tested, but whenever I was changing the roof direction/height it was causing quite large lag spikes. Confirm?

  • Doodads slightly buggy on mouse over (Not serious)
    This will also need confirming, but I found while mousing over a building holding a window, it would kind of spazm a bit on it’s location, moving quickly between one spot and the spot next to it. Confirm?

  • Carpenter table (Not serious)
    I got the Carpenter to build a door, and as he placed the wood on the table, he fell asleep. After waking up, the wood is still on the table, but the door has been made. Not easy to replicate unfortunately. :frowning:
    EDIT: This remaining wood block is acting as infinite wood, my carpenter picked up 1 wood block to make a sword and started making it, after it was done, the wood block remains.

  • Black Items in Carpenter table (Not serious)
    After an item is made at the Carpenters table, it caused the items to go black for a second, the go back to normal, nothing major, but maybe want to look at it? :slight_smile:

  • Fences still inactive (Not serious)
    Unfortunately, fences still can’t be placed :frowning: I’ve tried using the item itself and the “Place furniture” button, but still nothing shows up at all.

  • Weaver is hyper (Not serious)
    While getting the weaver to make some leather, I found she was running up and down her workstation, and even teleporting a few times, it wasn’t recurring but it happened none the less.

  • Stacking bugs (The return)
    Seemingly items are getting stacked on top of one another again, I’ve got some wood clipping through other wood, and some corn sticking out of a block of wood, recurring bug I guess, it just doesn’t want to go away! :stuck_out_tongue:

  • 2nd building crash (Serious)
    After attempting to build a second building in my world, I clicked on the “Place floor” icon, and my game instantly closed. Not sure if this is for everyone, needs confirming.

  • Adding windows bug (Not Serious) UPDATE
    Seemingly, when you add windows to the building, the ladders that are placed will bug out and be either incomplete or not removed after the window is placed. : Completing ladders sometimes causes item placement menu to bug out, causing game to crash.

  • Hunter Traps / loot on trees (Serious)
    Hunter traps and loot seemingly appear to teleport above the tree it is under.

  • Unable to promote (Serious)
    For some unknown reason, after using a quick-start, I was unable to promote any of my workers to Carpenter, they would continue to stay idle. Not sure how to replicate.

  • Furniture placement (Serious)
    Unable to place down furniture, getting an error that the game returned a value of “e” which is nil.

  • Berry Bush carry items (Not Serious)
    Wasn’t sure how to describe this one, but items that appear on top of berry bushes will be un-usable. Workers can sometimes place items on bushes when they are tasked to do something else while near a bush.

  • Peaceful mode game creation (Serious)
    Starting a peaceful game can cause the game to crash, after embarking, the loading screen will freeze. Seems rare at the moment, only one confirmed case.

  • Workers not using beds (Not Serious)
    Sometimes workers may not go to available beds while tasked to do something, will “Stop and Drop”.

  • Building grid remaining (Not Serious)
    Planning a building, scrapping the building plans and then building over the original spot will leave behind the original grid from the first building.

  • Multi-room house walls (Not Serious)
    Using the auto-wall tool on a building with multiple rooms (single block space between floor) will cause errors.

  • Defend command (Serious) UPDATE
    If you attempt to use the defend command while in build mode, you can’t access defend again. Causing workers and footmen to ignore all enemies. : Same happened after one footman killed a goblin. New footman took up the role but the original one continued to ignore everything, even after upgrading armor during his strike.

  • Day 8 Crash (Serious)
    Getting to day 8 will supposedly cause an unknown error, that will make the game crash.

  • Wall Building (Not Serious)
    Walls cannot be built by themselves.

  • Crafters Idling (Serious)
    Crafters would occasionally idle when it stated they were crafting, while they had the materials ready.

  • Workers Idling (Serious)
    In the same world as the promotion bug (Unable to promote) I attempted to get workers building a house, after building a single column, the workers stopped, dropped their resources and went idle. (Unique)

  • Quick Start - no options (Not Serious)
    Quick Start games don’t seem to give the option of selecting a normal game or a peaceful game.

  • Quit to Main Menu (Not Serious)
    This has been on-going, but the “Quit to Main Menu” button does not work in-game.

  • Steam shows game as “Nothing” (Not Serious)
    Not sure if intentional or not, but a friend says my game comes up as “Nothing” when I play Stonehearth.

NEW:

  • Loading saved game (Not Serious)
    Loading a saved game caused the “calender” to bug out. So far unique.

  • Footmen eat swords (Not Serious)
    Footmen when eating will eat with their sword in hand. Probably not wise, they might get splinters in their mouth :open_mouth:

  • Fog of War bug (Not Serious)
    Fog of War was not disappearing, stayed even when explored.

  • Score bug (Not Serious)
    This happened hand in hand with the Fog of War bug. with the error “Total Score” is not declared.

  • Death kills, literally (Serious)
    Seemingly, if a worker dies, then it causes a massive number of bugs. Usually unable to select workers, but can also cause force-closing and corruption of save-games.

  • Large silkweed farms (Serious)
    Making a large silkweed farm (about 10x30 in size) can potentially cause a C++ runtime error and crash the game.

The list goes on :slight_smile: Thanks to all for contributing, we will continue adding as much as we can!

Thanks to:
DJ_Jackel, Xandoria, Didis, daisyj201, Kav, Teleros, TenaciousTom, Sweeck, JonathanDB :smile:


[Dup] [BUGS] Alpha 4, Release 0.1.0, Build 127
#2

Found a few but can’t type them out in detail due to having carpel tunnel surgery just before the weekend. Took screenshots and added brief descriptions. Many happen during the change from night to day, but there are others too.

http://steamcommunity.com/id/ViperZeroOne/screenshots/

Also one screenshot shows 2 errors. One is the time change, one is a journal issue. Journal shows complaint about a not eating even though there is visibly plenty of food available, high variety of it too.


#3

Any way you can say how you replicated them? Maybe get someone to type it out for you?
I never encountered the red box during my game, so I’m curious


#4

One hand typing here, not fun, but I’ll try…

Most red boxes occurred at the change from night to day, when the rooster crow happened. Started on change from night 2 to day 3. By that time I had accepted the food donation from the travelers, and started 4 farm plots. Had a stockpile and also had the carpenter, farmer, weaver, trapper, and 2 footmen assigned. I had also went through my first “goblin stealing” event, and whooped it’s little green butt, and also added my first villager (Carpenter). Not sure what caused the error to start though. If I had to guess, probably the carpenter addition.

I found doodad placement through “Place Doodad” to be extremely buggy, and eventually caused the GUI to act up. This also brought up a big red box, and the error message seen in the upper right corner. Doodads placed during the house planning phase, or by selecting them manually in the stockpile, didn’t seem to have any issues.

Windows placed higher than 1 block above ground would not be built due to the temp ladder not reaching the ground, was able to fix by “finishing” the ladder and then removing it manually after the window was in. Finishing the ladder prior to the scaffold removal caused the windows to remain bugged and not be placed even with the extension.

Had a few builders and materials get stuck on the roof of finished buildings, but making a ladder to the roof allowed everything/everybody to be cleared off.

As mentioned, I also had a problem with the journal reports. First, the day was always filled in after the rooster crowed. It didn’t show the start of a new day, but did update which day it was showing. I always had a “no food” complaint, even though my stockpile had everything from pumpkins and berries to corn and meat. Can’t really tell you how to replicate that either, but I did catch it in the screenshot (small red box during daylight) where I show the stockpile/farm in it’s early form. You can see the complaint in the white text on the bottom right, and the food clearly in the stockpile.


#5

Oh, and I can verify the infinite wood bug you posted. My carpenter started to build a comfy bed before the weaver was finished making the cloth, so placed the wood block then paused. After that I had unlimited wood as my stockpile only had a few blocks and I was able to build 3 houses without depleting any.


#6

Unifinished house (ladders to windows are not removed and one window wasn’t installed.


#7

Trapped animal at the top of a tree.


#8

I had the same bug so I try to place the windows at one block in height ahd they managed to place the windows and remove the ladders.
I got also some other bugs as at moment I’m not able to place furniture and the game return me a value e which is a nil value.
An image of the error.

But now the save seems to be less corrupted.


#9

Racoon jerky at the top of a tree.


#10

Baskets of vegetables left on top of berries bushes for 2 days, nobody takes them (they seem so juicy though)


#11

Anyone else having trouble with creating a new game? I started a new game in peaceful mode, and it got stuck about 75% of the way through.

Steps to reproduce:

  1. select “new game”
  2. select “peaceful mode”
  3. choose embark location
  4. loading screen freezes and stays that way

No mods


#12

I’ve got a few more. First, workers not sleeping in available beds. No clear steps to reproduce.

Second, red grid left behind after deleting a planned building.

Steps to reproduce:

  1. Plan a building
  2. Scrap the building plans
  3. Plan a building over the original building spot

And then there is an issue with trying to automatically add walls to a building with multiple rooms. This error appears.

Steps to reproduce:

  1. Place the floor for a house with multiple rooms separated by gaps in the wall (see photo.)
  2. Try to add the walls automatically.

That’s all I’ve got for now but I’m sure there will be more :confused:


#13

Large numbers of errors occur when groups of villagers kill goblins.

If you try and access the defend command while in build mode, you cannot ever access defend again. I think my footman even ignored Zun Deathfist as he robbed me blind.

There is an unknown error that causes my game to crash before I fully load on load or continue after I got to day 8, a friend of mine also is receiving this bug.

You cannot build walls by themselves.

Occasionally I noticed my crafters idling for no reason when it stated they were crafting, and they had materials at the ready.


#14

Run the game for 2min with the R127… my Bugs:

Cannot click Menu buttons (peaceful or normal chose) and only “quick start” is possible.
Carpenter and Weaver does not place their Workbench, so no one is working at all.
Stopped testing at this point, as its pointless that way sry :frowning:


#15

I assume these occurred after traps were placed under trees?


#16

That’s interesting, I don’t think that’s happened to me before, try removing all local content and then re-installing the game? That might work.


#17

Already tried, does not change anything, still not able to use the buttons.

EDIT:
found the issue, already reinstalled the “why so blue” mod which causes the issue


#18

Oh that’s good, at least it works now :slight_smile: Was going to suggest going back to the original build of Alpha 4 if nothing else worked.


#19

Had a rather interesting CTD experience just now…

  1. Ordered some 1-high ladders to connect the 1-high ladders used to place windows with the ground (as said windows weren’t being installed).

  2. When to item placement menu, it bugged out (not displaying properly etc).

  3. CTD with just “i!= end” as the message I think (could click “Ok”). Had no time to hit Print Screen because the game crashed and took the error message with it :stuck_out_tongue: .

No idea if #1 is related, but thought it best to put it in there just in case.

**Edit: **Some more bugs:


On loading a saved game, I got the error on the left; on the right are the details.


The poor fella should probably put his sword away, mmm :smiley: ?


[Ack] Mega clearing/mega building bug
#20

A few more:


Lighting / fog of war bug.



These two go hand-in-hand. As you can see, I kept getting spammed with a score error, at approximately the stage you see in the other picture. Reloading the saved game gave me the same error once, but after opening the town info panel I didn’t get it any more. However, that seems a mighty high score to me - I guess owing to the size of the warehouse I began working on.