Placeable items NOT showing in "Place item" menu

Some items aren’t showing in the “Place Item” menu but I’m able to find them in crates etc.

I was making a lot of stone fencing when I noticed that as I was placing them and waiting for more to be done that I’d find more fence in my storage boxes and leather chests.

I sort of found a way around it by deselecting “defense” from the storage boxes and chests and laying out a stockpile for “defense” only and then manually selecting each individual “stone fence” and placing it.

Before update -549 I started having the same issue with “Oak Saplings”.

Steps to reproduce:
Not exactly sure how to reproduce except that I was placing items while they were being made/put in storage.

Version Number and Mods in use:
Alpha 15 -543


could you upload the save in wich this occures? Then the mods can see what may be happening

1 Like

Wooden Crates are bugged, try using stone chests

Hey there @Deakn, welcome to the Discourse!

@Deakn, uploading a save may indeed be helpful!

@Sukai, wooden crates shouldn’t have any different issues from stone chests or vaults. They are all based on the same storage system.

1 Like

had/have the same problem with different placable item (fences, beds,crates) first thought like sukai that it were the wooden crates but it also happens with Stone chests. You can also “see” them disappear.
Example: you have like 9 beds and want to place them after you placed 1 the rest disappears from the placing menu but is still in it’s container.
For me all the items “reappear” in the placing menu after I save and load the game.
They also “reappear” when they change Location (if they are in a stonechest/woodencrate/etc. and you empty the chest and let your hearthlings place them in a new stonechest/woodencrate/etc.)
I also don’t know of a way for reproducing this bug as it seems to come and go.

@Doc_Brano Here’s a copy of my save -> - best file hosting solution, with no limits, totaly free

@Kagea Yours seem like a light version of mine, cause it doens’t reappear if I move it or save & load. I have to move the bugged item to a stockpile so I can see and click it and then place it by selecting each item individually, sometimes newly created items of same kind show up in the place item menu but it only adds in new ones and not the old ones (FYI new and old are seperated by a save & load in this case).

great for the upload, will check it out soon. Just 1 thing, you do know that you don’t have to upload zip files on a upload site. Just drag the file to the reply screen. It should upload it on this site if its not bigger then the common savefile size i believe.


Opened the file saw the issues. Made a vid of it showing what happens for the devs. No errors or things like that. Saving and reloading only temporarly fixes it untill you run in to the next issue. Also in the vid an issue with shading. 1 side just seems a bit off. Played this savefile in the latest 549 version


@Doc_Brano I didn’t know that, thanks for letting me know :smile:

And thanks for doing the video.

1 Like

Having this issue in build 3092. So far it’s occurred with Comfy Beds, Large Crates, Large Wheat Bundles and Stone Chests. Saved game is attached. (7.5 MB)

1 Like

@WolffLaarcen I’ve downloaded your savefile but I can’t unzip it, it says it’s empty. Maybe there was some problem when uploading it?

That’s odd. Try this one: 1471899581699.7z (9.2 MB)

1 Like

That one seems to work. Thanks!

1 Like

I’ve run into this same issue and while I haven’t had a chance to properly document it, I have played around with it. This is only something I’ve noticed in the latest alpha 18 build on hard mode.

When you place an item on an already completed building, a second placement shadow of the same item appears way below the map. This in effect eats up the item in your menu of placeable objects, although the overall town inventory will show there to be the proper number of undeployed instances.

If you select this shadow and reset it, it will teleport to the corresponding location above ground. Your hearthlings will then attempt to place the item. Once they do, the placed item teleport to the original location way below the map. You can then reset this item and it will once again teleport to the corresponding location on the ground above it. It will now be a normally placed and usable item that can then be moved or undeployed.

This bug only happens with placing an item on an already completed building. If you place it on the ground outside, this does not happen. There is also no issue if you move an already placed item into a building.

No idea what’s causing this, as I had received no storage related error reports that corresponded to any of this.

(Apparently stacking crates is once again buggy)

1 Like

I can confirm that in your save, the comfy beds are visible, except for one that the inventory says it’s undeployed, but it’s nowhere to be found, there’s not in a backpack or the ground, nor in storage.

Thanks for the info, @Gaddiel :smile:

Edit: I got this bug while trying to reproduce another one. However, I was able to see the only item in my stockpile, being able to place it with the button on the unit frame, so it might be a different instance of the bug.

My steps:
1-Start a game and build a tiny cottage.
2-Use the Clear tool in game, dragging a square that encloses the bed inside the cottage (and at least one wall).
3-Make another bed (it will replace the one in the cottage automatically, due to the recent feature).
4-Undeploy the bed.
5-Place the bed again inside the cottage.
6-Undeploy the bed again.
7-Look at the Place item menu, the bed won’t appear there.

Uh-oh, if I tell the hearthlings to remove the building now, it will play the destruction effect in a loop :scream:

Can anyone reproduce it with these steps? I have many mods installed so it might be just me. :sweat:

(It’s probably the Clear tool that shouldn’t be able to remove building parts)…

1 Like

I was playing my first new session yesterday, and was going fine until the end. I had save & reloaded twice since then; maily due to hearthling upgrade/downgrade putting head misplaced. Regardless of that, I had a building complete fully; my first and only.

I put on the doll house view, where you see walls still. Pushed “P” for placing items. I had couple beds listed correctly to be placed. I place 1 bed, and the item disappears from the list. I had to find the bed in stockpile and place through individual item placement icon when you select item that way.

I had 1 tables and 4 chairs after that I tried to place with the “P” window. The table did the same thing as the bed above; which should happen with the table as there is only one. With the chairs however I was only able to place 2 of them, because it would do the same as above. the chairs listed 2 after placing of the first, and then off the list after the second.

I am thinking something is wrong with the placement menu, in that it is transcribing 2=1 when placing an item. However I did make another table, it is set to maintain 1, and that showed up once it was made. I have chairs set to maintain 2.

So effectively it is doubling the count taken from “P” menu, instead of minus 1 when there is more than one. I haven’t checked with odd numbers, but with even numbers this is most certainly the case at least with my session.
Steps to reproduce:

  1. Have a house built, and view in doll house mode.
  2. Have more than one of an individual item to be placed, preferably even number.
  3. Attempt to place through “P” window.

Expected Results:
The count int the “P” window should go down by 1, and not disappear from the list if there is still more in storage.
Actual Results:
Count seem to go down by 2, making it disappear from list, even though I still had 1+ in storage.
Beyond pathing issues, like people gathering items then stopping part way, drop stuff, and pick up again to continue on path; there was the head issue I mentioned. Building built fine, although odd in the way they did it, but it finished; which matters more. Even took down scaffolding.

I had other tasks going on during this obviously. Mainly mining and gathering tasks.

Don’t know what you need so I included the template the house that was used, log file, and the save file just in case.

I couldn’t get any pics unfortunately as I didn’t have overlay and was playing in full screen; which means screen capture doesn’t work as well. I just hope I described it well enough above, as it was a simple bug. Don’t know if I can reproduce it as I haven’t loaded the game up yet, but was something I did run into multiple times through that single session last night.

Best of luck finding the root of the bug. :smiley:
stonehearth.log (1.0 MB) (5.2 MB)
moonbeam house porch f3 (21.3 KB)

Version Number and Mods in use:
A18(The first iteration)

1 Like

Also this was playing RC in the forest; which makes clay a bit more difficult to come by, especially considering how costly it is to buy. Don’t know if that matters, but is what I was playing. :slight_smile:


Confirmed, first bug easy to reproduce with A18. I have build 7 beds, I can place 5, the 2 other beds manualy (deploy item in world individualy).


still exists in develop-3092.


It’s definitely getting worse. I think there’s another report out there that can be merged, all of them have in common that there seems to be a bug with the inventory…


ever since moving to alpha 18, whenever i place items, it places double. if i only have 1 thing, it works fine, but if i make 10+ items (dining tables for example), and place 1, it double counts it. if i remove it afterwards, it only sends 1 back to inventory. Placing the “same” one, double counts again, so i lose 1 extra each time. Inventory screen shows the correct number i have built (if i don’t sell extras), and SOMETIMES i can sell the extras that aren’t available to place.

Steps to reproduce:
.1)Make new game

  1. I have been working through building in mountains, and it doesn’t seem to happen in templates.
  2. dig out fun areas
  3. make foundation inside mountain
  4. place tables and chairs
  5. lose half of what i made (still counts as inventory slots)
  6. when sending back to inventory, only one appears in inventory

Expected Results:

  1. placing a single table or chair, number in inventory to place iterates down by 1.
  2. (after double items are supposedly placed) when clicking on placed item(s), and and selecting return to inventory, should go up by 2 (if two indeed are placed).
    Actual Results:
  3. placing a single table or chair on new finished foundation, number in inventory to place iterates down by 2.
  4. when clicking on placed (double) item(s), sending back to inventory only goes up by 1, effectively making it disappear. Still shows when selling (sometimes)
    Was unable to find another bug report like this one.

Version Number and Mods in use:
no mods
both the first alpha 18 and current (3092) alpha 18.
System Information:
i7 4790k
16gb ram
GeForce GTX 970
windows 10, all drivers and patches up to date.

Built “cave”, made foundation, built tables (9), placed 3 of them (one a couple times to see if it still happens).

Full inventory shows 9 total tables. 3 placed to the side (no others placed anywhere else)

Only able to upload one pic at a time:

Place an item shows 1 item available to place. i made 9, 3 are on ground, one is currently available to place.
I placed a few, took them back, tried again, took it back, tried again. 5 disappeared in this case.

Seller currently shows i can sell up to 6.
I looked to see if elsewhere in inventory but was unable to spot them.
I find that this seems to only happen in cave houses.