Villagers stop working

resolved

#1

Hi guys n galls,

I got a starting town. 22 villagers in wich i maxed it out to.
However… there are multiple buildings in the make, and objects to be placed/replaced.
Then the Hearthlings stop working and standing around. When i check the UI for Idle Hearthlings it tells me there are 0% Idle Hearthlings.

I have no idea wether its a bug or performance issue from my side. Game is running smoothly on the computer.

regards,
Yohane


The amazing builds thread - Community editable thread
#2


#3


#4

Hey there and welcome !
Do your workers completly stop to work or do they work sometimes ?


#5

They work sometimes :wink:

And thank you for your welcome! :smiley:
I tried suspending different parts like the job or hauling but that did not lead to more efficient working


#6

When it happens to me, I make them do a little work as mining a few blocks then I let them idling. Finally, they do most of their tasks.
Don’t hesitate to save-reload your game at the same time :slightly_smiling:
I’ve seen that you’ve activated the speed X3. Don’t know if it impacts, but try to disable it and see the result.


#7

i tried enabling 1x speed aswell but that didnt make result for that part.
Doesnt mining give them more jobs so they will take longer to think?


#8

For me it kinda restarts their tasks that’s why when I see they don’t loot items laying on the ground, I make them diging a little bit. And then they often loot those items.


#9

And a bit will be like 4x4x4?


#10

Yeah even less like 5-6 blocks


#11

k. imma give that a try and reïnform you
Edit:

This is what happened. Mined > Desperate for food > Lunch > Idle


#12

Then I don’t know. It works well for me. Try a last time : mining a few blocks, let them idling, save-load and see the result.
I’m calling @moderators for help ! :bulb:


#13

Oke. thnx for your help\so far!

on startup i get 2 Engine errors now:
1:
release-489 (x64)c++ exception: lua runtime errorstack traceback:

2:
release-489 (x64)…earth/services/server/build/scaffolding_manager.luac:48: attempt to index field ‘fabricator’ (a nil value)stack traceback:
[C]: ?
…earth/services/server/build/scaffolding_manager.luac:48: in function ‘_trace_project_region’
…earth/services/server/build/scaffolding_manager.luac:13: in function <…earth/services/server/build/scaffolding_manager.luac:10>


#14

That’s a building problem that may interfer with your HL but they’re working on it :wink:


#15

Hey there @Yohane1, welcome to the Discourse! First off, your town looks gorgeous, love the ship in the water! (That couldn’t have been easy to build :smile:).

Anyway, first let me get some more information from you. Can you share your system specs? Specifically, Processor, Processor Speed, RAM, GPU, and Operating System.

Also, can you upload this save game to the Discourse? That would be a great way for us to test if it is a save issue or a computer issue. To upload a save game, locate the save in your install directory (default is C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games assuming Steam) and compress it to a zip file. If it is less than 10 MB, you can upload it directly to the Discourse. If larger than 10 MB, please upload it to a online file storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

Finally, as @Powerclank mentioned, the engine log you posted is a known building related error, but thank you for reporting that it is still occurring on the latest release!


#16

@jomaxro :slight_smile: i was hoping one of you was noticing my ship. Yes that was some work. :slight_smile: 3 days speed 1 editing. Then the ages of building for the Hearthlings.

As for System Specs:
MSi GP60 2PE Leopard Laptop
Intel i5-4210H CPU @2.92GHz
8GB RAM
Intel NVidia Geforce 840M
Operating on Windows 10 64x

have i forgotten something?

Ah yea. The save file: Dropbox - 1451483555731.zip

Edit: As this was my last (max) post for the first day. I cannot post untill 19 hours. So id say. Untill next year! Happy New year in advance.
PS: i can edit this message 1000+ times


#17

OK, so my computer is not anywhere close to yours spec wise, it is almost 4 years old (and a laptop). I could barely run the game. Unfortunately, my guess is that you have overwhelmed the AI, to the point that the Hearthlings spend all their time “debating” what to do instead of actually doing it. This is likely a very good save for the devs to look at, though, paging @Albert, @sdee, and @not_owen_wilson


#18

Just wanted to say your town is GORGEOUS. That’s what I’ve been slowly (and poorly LOL) aiming for in my own games. Awesome work! I hope you’re able to play it again soon :slight_smile:


#19

@jomaxro Ive been manually destroying every ladder in the save file. Now they started building on the flags of the Ship.

Edit:
The builders after finish of building the flags are done with their tasks. They dont know again what to do. as far as i know now theres nothing to be done at this moment other then placing some items.

  • My Potter does not start to craft his oven/furnace.

#20

So ive been looking at the Hearthlings for awhile and i noticed them not doing the things i want to do.
So i summon it for u:

  • Workers do their job as far as for building. They dont haul and place items (look for the far end of the village). (No i did not suspend it)
  • Jobs are half done, carpetender is working, blacksmith is thinkin quite long before doing anything, same as the Potter.
  • Weaver does what i ask him to do.
  • Farmers (i got 3 for the 10 fields) all work on 1 field and dont look at the rest, wich makes other food die.
  • Cook is cooking
  • Sheep Herd is doing its job.

keeping you up to date