StoneVox 3D - Community Voxel Modeler for StoneHearth


#101

Don’t rule it out completely. I am seeing what I can do to reduce the requirement as @Azhrak pointed out, the current requirement is a graphics device that supports OpenGL 4.2. Integrated or standalone card makes no difference.

I can’t give any info about how low I can get it yet… but I’d say, wait for the new release of StoneVox coming out in a few days. You never know, it may work. :slight_smile:

According to my sources, if I can get the requirements down below or at OpenGL 4.0 and you have enough RAM available, I believe the HD4000 has no VRAM, StoneVox will run on your current computer. :wink:

Edit

Perhaps I could pull some tricky too, specifically for you and other users who are experiencing problems.


#102

Thank you for your hard work for the community! I can not wait for the next update :smile: I do hope that StoneVox will run on my current computer but take your time!


#103

Hello! I have a small question for you:

I am able to open .qb files, as long as the matrix is fairly small. What I’m trying to do right now is to edit the female worker torso (I was inspired by Norsecraft, and I’m a rennie/aspiring SCAdian, so I have a bunch of info on norse clothing, and maybe an actual physical outfit or two >.>), but I’m having a problem.

When I try to drag the female worker outfit, or the female worker body, into StoneVox, it freezes the program entirely. I am assuming this is because the matrix is too big? Is there a way to make, essentially, the ‘canvas size’ larger, so that larger matrixes can be edited?

EDIT: Well, now I don’t think it’s because of the size - I just opened the sheep, and that’s rather a bit larger than a humanoid torso :confused: I have no idea what I’m doing wrong at this point? Is there something with the bodies that bugs out things? (in the meantime, I’m going to go make goats)

EDIT 2 ELECTRIC BOOGALOO: Aaaaand I’m a moron. I needed to update Java. EVERYTHING IS FINE, NOTHING IS RUINED.


#104

Okay, so. Making that goat, and things are going well! I started with the sheep (of course), and have a head that I like really well so far.

So I started working on the body, buuuuut… the matrixes for the head and the front half of the body overlap by one voxel. It says on the features that moving matrices isn’t currently implemented, right? I think I can work with it anyway. Nothing should explode because I shave off a slice of the body matrix, right?

(if I don’t make it back, tell my wife I love her)(oh wait I’m the wife)


#105

Well… it’s kinda there but also kinda a hidden developer feature too… you can use the arrow keys to move around the currently selected matrix. Keep in mind though that it shouldn’t be a problem, so you could just leave it alone if you’d like :wink:

By the way thanks for checking out the project… looking forward to seeing your work :slight_smile:


#106

Heck of an awesome thing i see here! Will be playing around with this tonight! =)


#107

OoooooOOoooooh! Okay! Man, that helps a ton! I know I’d tried already messing with the arrow keys, but I thought that moved the whole model, not just the visible matrixes.

Oh, while I was messing around with that, though, I did discover a thing? I was moving the face-matrix forward, and it went more forward than the ‘canvas’ size, and sliced off the front of his nose. When I moved him back, the slice remained gone, and I had to re-add the voxels. Wasn’t a huge deal, since that was like 6 voxels, but I thought you might like to know.

EDIT: Oh, also, is there a command to move things up-down?

EDIT 2: Okay, messing with it now, and it seems like it’s moving the whole matrix? i.e. I leave the head only visible, move it one forward, then make the ears visible… and they are in the same relative position to the head that they were before.


#108

@Zariface
Sorry for all the confusion… my bad. It does in fact move the whole matrix… :frowning:

Moving the matrix around as I said at this point is more of developer feature, hence the nose being sliced off. Watch the edges :wink: .

Give me a minute and I’ll throw something together quickly if it will make a difference :slight_smile: .

I’ll set it up so

  • CTRL + Up/Down : moves only selected matrix up and down
  • ALT + (Any Arrow Key) : moves only selected matrix

#109

Okay, so to clarify then:

Arrow key: moves entire model front/back/left/right
CTRL + up/down: moves only selected matrix up/down (NOT all visible, but only one matrix)
ALT + arrow key: moves only selected matrix front/back/left/right

Is that right?


#110

Also, here is my wee little Starter Goat:


#111

Looks Great :slight_smile:
People always amaze me what they can make in StoneVox. I myself view the project as highly unfinished and yet so many people have made such great things with it. That makes me very happy .
Again great work. :slight_smile:

I’ve uploaded a new version of StoneVox v0.0.6… here are the new controls

  • Left Control + Up/Down : moves all matrices up/down
  • Left Control + Alt + Up/Down : moves only the selected matrix up/down
  • Alt + (any arrow key) : moves only the selected matrix (forward, back, left, right)
  • (any arrow key) : moves all matrices (forward, back ,left ,right)

Hope it helps :wink:

As a side note these are early developer features expect at times visual bugs and such from using them. If these occur just export your current model, and then reimport it. This will clear any issues up.

Again good luck with your work… looks great so far.


#112

OK, small feed back time.
I’m not sure if I’m writing corectly but I will try my best.
I downloaded the StoneVox 3D V0.0.6, and the CMD gives me that mensage:

C:\Users\Guilherme Souza\Desktop\StoneVox 3D 0.0.6>java -Djava.library.path=nati
ve\windows\ -jar StoneVox3D-0.0.6.jar
org.lwjgl.LWJGLException: Failed to find ARB pixel format 1 0

        at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
        at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.ja
va:52)
        at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252)

        at org.lwjgl.opengl.Display.createWindow(Display.java:306)
        at org.lwjgl.opengl.Display.create(Display.java:848)
        at org.lwjgl.opengl.Display.create(Display.java:757)
        at stonevox.Program.init(Program.java:144)
        at stonevox.Program.execute(Program.java:111)
        at stonevox.Program.main(Program.java:103)
Exception in thread "main" java.lang.RuntimeException: No OpenGL context found i
n the current thread.
        at org.lwjgl.opengl.GLContext.getCapabilities(GLContext.java:124)
        at org.lwjgl.opengl.GL20.glCreateShader(GL20.java:219)
        at stonevox.data.Shader.Load(Shader.java:34)
        at stonevox.Program.loadContent(Program.java:177)
        at stonevox.Program.execute(Program.java:112)
        at stonevox.Program.main(Program.java:103)

I really don’t know if that is the right place to give this feed back, if its not then Im really sorry.
Keep The good work.
Guilherme Souza


#113

@guiga707 Thanks :slight_smile: and sorry for the late response, I’ve been busy working on the new version of StoneVox.

It’s fine to post here with crash reports :wink: .

This looks like a cause of your graphics card not supporting the amount of sampling SV is doing. You try to could disable AA sampling in your graphics cards settings and see if that makes a difference.

Otherwise I’ll make a version for you with the AA turned off :slight_smile:

There could potentially be other problems too though… we’ll see.

Let me know how you make out with turning off the AA.


#114

@honestabelink well i’m bearer of bad news…
currently i’m using an AIO from “HP”, and this piece of … well you know, uses an integrated chipset from Intel,
I searched on the web a way to turn off AA, but i didn’t found anything for chipsets.
and I really don’t know much on that topic…so, how can we proceed?
Thank you for your hard work.
Guilherme Souza
PS: sorry for my incompetence


#115

Thanks for looking around… no worries I don’t mind helping… :slight_smile:

There are chances that the chipset will not run the current version of StoneVox. But lets try anyway… :wink:

https://drive.google.com/file/d/0BynmPA83eY4PRDcwSDMzR1VFR2c/view?usp=sharing
This is a version of StoneVox with the sampling turned off.

Beyond this if it doesn’t work there may not be much we can do until I get the new release of StoneVox out. Currently the requirements for StoneVox are pretty high, requiring a relatively new graphics card.

A lot of those requirements are not needed though, this is something I am going to be addressing with the new release. If the version I provided above still doesn’t work, try waiting for the next release then seeing how that goes.

Thanks for your time @guiga707 and feedback. Feel free to let me know how the no AA version goes anyway. :wink:


#116

OK @honestabelink I must thank you so much for the support on that problem.
Now for the feedBack you asked, It opened! :heart: :heart: :heart:
but unfortunately something strange happened.
on the following PNG you will see the CMD batch resulted after closing the program:

and now what looked strange for me:


the HUD was working fine, but i couldn’t see anything :cry:
Hope it helps somehow
Guilherme Souza


#117

This is the result of your integrated chipset not support the particular version of OpenGL StoneVox is looking for. This is one of the issue I am addressing in the new version of StoneVox I am working on.

I’ve been working hard to try and get it out the door, but have been held up by a few things. Now, a lot more of the complicated things are done and out of the way… so really it shouldn’t be too long till it’s release.

I would ask for your patience until then.

Overall the next release is a great improvement across a lot of things. Compatibility with hardware, performance, memory footprint, loading times, and also has the addition of some networking features which will allow you to work with others over the internet.

I am really excited about the new version… I hope to get it out as soon as I can.

Thanks again @guiga707, it’s always motivating when I talk to someone who is using StoneVox or at least has an interest in it :slight_smile: .

Oh by the way not sure if it’d be tonight or not but sometime over the next few days I’ll be pushing the new version to Github, along with it’s source. That version will be feature bare in the beginning, but you could test it out to see if it visualizes the .qb’s. Than you’d know if StoneVox will work in the future for you :wink: . I’ll be posting here when I commit the push to Github so you’ll know when it happens if you’d like.

Thanks for your time


#118

I thank you again for your time @honestabelink and im looking forward for the new releases :smile:
PS: don’t worry about my testing time, i’m still learning and im happy to help


#119

@honestabelink I would like to thank you for your hard work on StoneVox even though I can not use it as of no. So thank you!

I hope you have a good day!

~Wolf


#120

when i try to open i get that same error, only works when i reinstal any version off java on the machine