StoneVox 3D - Community Voxel Modeler for StoneHearth


I tried to download StoneVox but, when I ran the java file I got an exception & I download the jre java thing. I really don’t get where I can find a file to run this thing/install this thing.


Is StoneVox currently working? i couldn’t get it to load anything


@Zhaldak @JahWaaah,

There is no installer for StoneVox, in the download you see a file called run.bat. Double-click it to start up StoneVox.

Other than that StoneVox is very functional, but it can be fiddly with different hardware. @JahWaaah a common issue people see is that the UI loads properly but none of the .qb’s are drawn. Hardware compatibility is one of the main things I am addressing in the new version of StoneVox I am working on. If this is the case for you, then I’d just ask for your patience as I finish up the version, it may very likely make everything work.

This guy is a programming guru… his voxel modeler is still rather incomplete as far as fully supporting what SH needs. It however is still very good, and you could use it to make simple models.

Sorry for the frustrations :wink:


I know, I ran it and it said 'Unable to access Jarfile StoneVox3D-0.0.6


sounds like a file permission problem… where are you trying to run StoneVox from, your desktop?

You could try running run.bat as admin. (Right click the file, “Run As Administrator”)


Oop! Thanks it worked!
Edit: I got this… Screenshot by Lightshot Screenshot by Lightshot


Try this version of StoneVox…

It should at least load correctly but might no draw any qb’s. Once again this comes down to hardware support, I’ll have that sorted on the next release of SV.

Thanks for you time, feedback is really appreciated. :slight_smile:


No problem man. It’s great that you made something like this.


Yeah I just unzipped it as normal and used Run.bat since I am familiar with batch files but it attempted to load and failed. What is the hardware it has most issues with? I can post my Rig if that helps? @honestabelink


The more info I have the better I can adjust SV to match everyone’s hardware. :slight_smile:
Feel free to PM me or post here, either would be appreciated.

I don’t really need anything other the graphics card…


Ahh okay. Well my Graphics card is a GTX 570


Yeah the card was borderline whether it would work… :frowning: (even though it is a nice card)

The new version of SV will definitely support it though :slight_smile:

Sometime today I’ll will be releasing a little test version of the new SV… if you’d like you can try that out and see how it goes. It should work just fine with the adjustments I’ve made.

Thanks for your time @JahWaaah


Yeah if that’s cool man. I’ll test it and give you some feedback :slight_smile: @honestabelink



Been messing around with your program (Very nice BTW). key= LxWxD

Eraser - (Idk if you are planning to have multiple eraser options or not) Maybe have it so when you click on the Eraser tab have a Single 1x1x1,2x1x1, 2x2x2 for options? I don’t think anything more then a 2x2x2 if this is just going to be for Stonehearth.
If your just going to leave it a single Voxel remover maybe just click on the Eraser Tab for easy use? No need to click on the tab and then another to re-confirm.

Painting - Might be just me but the single voxel paint icon looked like a wide paint brush? Threw me for a loop for a bit maybe change it to a Pencil like icon?
Just a few suggestions nothing major, other then that Very,very nice work, super easy to use! TYVM for your work and sharing it! :slight_smile:


StoneVox - upcoming release

Hi everyone,

As a lot of you already know I’ve been working on a new version of StoneVox. This new version is written in an entirely different programming language then the previous and also comes along with a few other changes too. :wink:

  • Better Hardware Compatibility
  • Reduced .qb load time greatly
  • Huge improvement in memory footprint
  • Networking/Sharing (think of like building in Minecraft with friends but in StoneVox)
  • And tons of other tech. things… don’t mind the man behind the curtain

Really I am very excited about this new version, it is so much better than the previous lol :slight_smile: , and should hopefully give me the room to implement lots of new features in the future.

The main reason I am here today is to get feedback on if the compatibility changes I’ve made have been enough to get StoneVox running on most peoples computers. I know that there were quite of few of you struggling with getting StoneVox working. This new version has many changes to help in all these areas. :wink:

So I guess without further ado :slight_smile:

a little side note, when you run this version windows firewall will come up as StoneVox includes a bunch of networking code. You can either allow it or click cancel, the networking features are more of a dev feature right now and are not needed when working locally on your computer


  • Right Mouse to orbit camera
  • Middle Mouse pan camera
  • WASD or Arrow keys
  • Ctrl + O : open files ( alternatively you can drag and drop .qb’s right into the programs window)

One big thing to point out is that this is not a finished release. For example none of the UI elements are there yet, among other things too. I will working to finish off whatever I need to, then you will see a full release with all the features you are expecting and maybe some new ones if I have the time. :wink:

super side note, I will push the source code to git later on tonight

Thanks so much for your time


Ok tried and doenst start … is joined the server but blackscreen - tested both ways zip and installer


Well there is no UI or anything… when the program loads you will just get a black screen, that is normal. Did you try loading a .qb?

Does it say it’s crashing, are you running x64?


so retried with java reinstall ^^ i get 2 screens - one with the startinformations and the last entry that he has joined the server and a second screen with nothing only blackscreen no UI etc so i can´t load a qb. - im running win8.1 - x64 (6-cores - 12gb ram) and there are no errormessages.

also waited 5min if the blackscreens does anything :wink:


I am using some fancy tricks to get drag and drop file opening to work. Windows 8 might not like them… :frowning:

Try the alternative way to open up a .qb.

  • Ctrl + O

This will open a new window where you can navigate and select a .qb to open.

Other that that… it sounds like a hardware issue still :frowning:

In the window with the “start information”, type /openglsupport, and press enter. That will give us feedback if there are still compatibility issues. If it mentions “Shader test failed”, then it’s a hardware issue. If you’d like you can PM the log it creates, it will be found on your desktop.

Thanks @Wiese2007 this is the feedback I am looking for :slight_smile:


And by the way Java is no longer a requirement for StoneVox. This new version is written in C# using .NET… I believe by default Windows 8 out of the box comes with the version of .NET StoneVox is looking for :wink:


do you mean the opengl support from nvidia? i have an amdcard hd5700 (its support only to opengl 2.1 ) ^^ i think this could be the problem ^^