Stonehearth doesn't open

I recently downloaded stonehearth on my new computer and it doesn’t open the window. Steam says the games running for about 5 seconds before it goes away again. There is no crash log that I could find. Anyone know whats happening?

Hello :merry:

I fixed a similar error on someone else’s computer today! Let’s see if I get lucky again:

Right click Stonehearth on Steam and go into Properties... then Local Files and then Browse Local Files to get to the game folder. In there you should find a file called user_settings.json. Open it with your favorite text editor (or notepad) and look for a line that says "enable_fullscreen" : false, erase the false and write true, save, close and try running the game again!

Let me know if it helps :slight_smile:

PS: Don’t forget the comma after true

Hey! I went into that file and all it says is “user_id” : followed by numbers and letters. Would this have something to do with the error? I’ve never opened it on this computer and idk if the full screen code you were referring to would be somewhere else for whatever reason. Thanks for your reply!

Perhaps? Try deleting the file and running the game again, should create a new file!

hello mystic
i have the exact same problem here man. i really sucks it says it running but then goes back to the normal state again. if i press play again it says running but again goes to the normal state. i really tryd everrything already.
can i ask what laptop are u using?

i also tryd this and at my laptob it only displays a ID with a weird number

i deleted the file but again a weird file comes up with a weird id number

I’m using a Microsoft surface laptop, don’t know if it would be a computer error as I haven’t tried deleting the files yet but I’ll get back to you as soon as I can

I’m guessing it’s because of the touchscreen aspect. Stonehearth plays funny with some added devices like webcams, touchscreens, etc. Not sure if it’s possible to disable the touchscreen and use it just as a regular display device, but if so, that’s what I’d recommend.

1 Like

oh thats weird because i have laptop without touchcreen and its not a surface laptop just a lenove laptop and i have the same problem

Me too, exact same thing as @jakegrootscholten and @MysticPenguin39, It is a new computer, a Lenovo 82C5 with Win10. No touchscrren, so I don’t think this is it.
I have tried unplugging all USB, Pluggin in a Contoller, starting it as Admin, Compatabily mode for any Version I could get, deactivating my firewall, and uninstalled and reinstalled my game multople times, tried starting with and without steam. So far nothing has worked. i have a Stonehearth log, but all it sais is this:

2020-11-21 15:30:33.567271 | server | 1 | app | Stonehearth Version (x64)
2020-11-21 15:30:33.568259 | server | 1 | core.config | user id is e622c480-93c8-41aa-b03d-d500fa3e8cc1
2020-11-21 15:30:33.568259 | server | 1 | core.config | session id is 0e0c04f0-6def-4de9-9431-541549424085
2020-11-21 15:30:33.568259 | server | 0 | app | Steam present.
2020-11-21 15:30:33.569276 | server | 0 | core.system | Initializing crash reporter

Hope someone finds out why this is, I would love to play again…

Has anyone found a solution to this? From What I have seen i was not the only one who had this problem, but none of the topics perterning this have been updated in about a month. Isn’t there something that can be done?

What were the specs of your old computer
Stonehearth may not work with intel uhd graphics

This was my old Laptop
Don’t know if Links are okay, if not, these are some of the internal bits

|RAM|8 GB|
|operating system|Windows 10 Home|
|Hard Drive 1|HDD , 1 TB , 5400 U/Min.|
|Graphic Card|Intel® UHD-Grafik 620|
|RAM-Size|8 GB|
|Processor|Intel® Core™ i5-8250U Prozessor (bis zu 3,40 GHz mit Intel® Turbo-Boost-Technik 2.0, 6 MB Intel® Cache)|
|Hard Drive 1|HDD , 1 TB , 5400 U/Min.|
|Hard Drive Type 1. Hard Drive|HDD|
|Hard Drive Capacity 1. Hard Drive|1 TB|
|Totation Speed 1. Hard Drive|5400 U/Min.|
|Processor-Modell|Core™ i5|
|Prozessor-Frequenzy with Turbo|3.4 GHz|
|Cache-Memory Type|Intel® Cache|
|Cachesize|6 MB|

As you can see I had UHD Graphics before, so i don’t think that is it

Edit: The Specs were all in german, as is the site, as i am from germany I translated hopefully correctly

Pretty much the same specs on both old and new laptop
No idea why, could be a lenovo issue

But so many other people here have this too. Is it probable that they all have lenovos?