Stonehearth Won't Start on 64 Bits (but Strangely Works When Run on 32 Bits)

Greetings fellow hearthlings!

I just got an awesome new laptop a few months ago and one the first I did was install Stonehearth onto it, especially after hearing about the new recent A.C.E update!

Unfortunately, everytime I click on the green “PLAY” button on Steam to launch the game, it gives me the usual prompt that says: “Preparing to launch Stonehearth”, then it says that Stonehearth is running on my Steam Library window for about 2-5 seconds and the green “PLAY” button reappears, just as if nothing happened. Additionally, Stonehearth shows up on my Task Manager while it is supposedly launching, but then immediately disappears once the green “PLAY” button reappears on my Steam Library window. No error message or reason whatsoever on why Stonehearth won’t launch is displayed.

Strangely enough, Stonehearth launches and runs perfectly fine on my new laptop when I ran the game at 32 bits, which, after hours of digging on how to resolve the problem myself on the Discourse and Steam forums, I was able to do by editing the user_settings.json to force it to run on 32 bits. While I was delighted that my laptop could at least run Stonehearth, I would much prefer to run Stonehearth on 64 bits instead, since I imagine that Stonehearth is rather intensive on the CPU and RAM-usage, particular when knowing that Stonehearth isn’t the most optimized game out there.

EDIT: After logging in a few more hours of playtime, I found that playing Stonehearth on 32 bits has even more issues of its own. After about an hour of playtime, sometimes even within 10 minutes of gameplay, the game will suddenly freeze, forcing me to close the game using the Task Manager. This occurs even when I had started a new game, where the first instance happened when I had just 7 hearthlings. Sometimes the game even crashes to desktop in the middle of a load screen. I have to save constantly to avoid lossing progress, which is very tiresome, on top of having to launch the game up everytime.

(This is the Stonehearth.log that is generated when I attempt to run Stonehearth on 64 bits)

2020-12-30 22:04:49.733769 | server | 1 | app | Stonehearth Version (x64)
2020-12-30 22:04:49.734773 | server | 1 | core.config | user id is f1e9e128-9426-11e5-af25-d050994f7ba8
2020-12-30 22:04:49.734773 | server | 1 | core.config | session id is 323a5d90-ab26-4f16-b542-f276112fb708
2020-12-30 22:04:49.734773 | server | 0 | app | Steam present.
2020-12-30 22:04:49.735299 | server | 0 | core.system | Initializing crash reporter


I do not have a crash.dmp file to upload (I’m a new user so I wouldn’t even be able to), perhaps because Stonehearth isn’t even able to run long enough to generate one, but that’s just my belief on why that is.

If I’m missing other important deliverables that can help you troubleshoot, please let me know!

Versions and Mods:

The most recent version of Stonehearth (Which I believe is v1.1???)

ACE Pre-Release v0.9.5.3b - “The MASSIVE Update!”
Extra Map Options
The Hunter
[ACE Mod] Composting
Dani’s Core Mod

***I uninstalled all these mods when I tried to run Stonehearth at 64 bits, but still, no dice

System Information:

CPU: 10th Gen Intel Core i7-1065G7 @ 1.30 GHz to 1.50 GHz (up to 3.9 GHz) /w 4 Cores & 8 Threads
OS: Windows 10 64-bit, x64-based processor
RAM: 16 GB
External Monitor

Have you attempted basic troubleshooting steps?

I’m aware that my issue is strikingly similar to these two recent topics:
Stonehearth doesn’t open
The game doesn’t start and doesn’t show any error

I tried all the solutions proposed and then some, like running Stoneheath.exe as an administrator, launching the game offline, disabling my anti-virus and/or firewalls, uninstalling any mods, reinstalling Stonehearth (which I did 4 times), reinstalling Steam, forcing Stonehearth to run on windowed mode, updating my drivers, etc., but all have resulting in failure for me.

The thing is, they were satisfied with running Stonehearth at just 32 bits, which is a decent but not ideal solution. I would like to run the game at 64 so I get the smoothest possible experience.


I know for certain that it is still possible to run this game at 64 bits! I used to play Stonehearth on a desktop PC on 64 bits and it worked just fine. I don’t remember exactly when was the last time I played Stonehearth, but I do know for sure that it was around when A.C.E’s Drinking Update was released.

I have +220 hours logged into this game already, and I hope to bring that number up some more during the holiday break!
I wish everyone an early happy new year! And thank you in advance for anyone who helps me!

What if the does not work in 64 bit mode because it was never coded for it

I doubt 64 bit would run smoother than 32 bit, because most problems are caused by unfinished or unrefined coding

Keep in mind, Stonehearth runs on 64 bits by default, so you have to manually change it to run it on 32 bits instead on the game settings (assuming the game will launch successfully the first time, which it didn’t in my case for my new laptop, so I had to browse the local game files myself and edit the user_settings.json file to force the game to run on 32 bits). It wouldn’t make any sense for the developers to run the game on 64 bits by default if it was never programmed to support it. Like I said in my initial post, I was able to play Stonehearth on 64 bits on my desktop PC and log over 200 hours of gameplay, so it must certainly be possible.

Generally, running a game at 64 bits is better than 32 bits because it allows the game to use more memory from your computer, so this should logically mean a smoother in-game experience. Your statement could still be true in some cases though.

Thank you so much for your input!

how do i run it in 32 bits