[Res] Game crashing on startup (wrong enable 64bit option)

Hi everyone, I’m having a problem with my game…

So, I was playing today on my laptop because I wasn’t home and the game worked fine and dandy. I got home, went to the desktop and tried to launch Stonehearth but this time, the game crashes on startup.

Like, it opens as if it were launching but stays on a white screen and the message saying it stopped working comes up.

Here are my specs:

Intel i7-4790
NVidia GeForce GTX 960
Windows 8.1

Which version are you running? Is it on steam or the stand alone game?

I’m running the latest stable version and it is on steam

So there is a Stonehearth.log file in your steam game folder (for me my stonehearth game is located in C:\Program Files (x86)\Steam\SteamApps\common\Stonehearth) You might have a different drive or exact folder location depending on where you installed steam.
If you could upload your file to a website like http://pastebin.com/ (or just replay with the raw text here).
I just opened my copy of Stonehearth and closed it so I will compare what the two look like.
I’m not a mod or anything but ill try to help if I can :smiley:

1 Like

Okay, here it goes. This is from about 2 minutes ago since I tried to reboot my pc to see if it worked or not Stonehearth.log - Pastebin.com

And thanks for your help! Really appreciate it :smile:

Hmm TBH im not to sure. If you look at my log Stonehearth.log For user Gir - Pastebin.com we both have the
"browser | Doing a buffered navigation…" part but then yours end.
The next line for me, " simulation.remote_client | started buffering client updates. (seq:12 ack:0)" looks to be getting data from the local server that the game sets up (interesting way that they have made it).

I would say download it from humble bundle (since they should be the same build right now) and try running that one. If need be you can right click it and start it up in compatibility mode.

IF that still doesn’t work then you would probably have to just hook up your laptop to your main monitor set up and play it off of there (if you can do that). Hopefully one of the dev’s knows what the problem is and will reply. Best of luck to you :smiley:

Yes, I thought that would be a problem. Mine just abruptly ends there and that’s it. I will try with the humble bundle download and update this post when I do.

Thanks for the help! If it doesn’t work, I’ll wait for a reply from the devs :smile:

1 Like

Also I would change this topic from the support to support/performance since they talk about failed startup’s in there


Will do, and as I type this, I have an update. So, installing from Humble Bundle made no difference. Although, the log is shorter and abruptly ends aswell. Oh well, I’ll just boot up my laptop and play from there until I can play on my desktop. Thanks for the help! :smile:

firstly, welcome to the discourse :smile:

secondly, are all your drivers up to date? as @Solus says, dont trust the “auto” updates, go to your drivers website and update them there as sometimes the “auto” updates dont work and such.

and another question, do you have Service Pack 1 installed on your computer?

1 Like

Thank you! :smile:

Yes my drivers are up to date. I went to check on the website earlier and the latest is the one for GTA V which is the one I got from the nvidia control panel.

I don’t see anywhere that I have Service Pack 1… Where would I check that? It might just be a case of not having it.

in the “system” part of control pannel on your computer it should say whether or not you have SP1 if not it just wont be there, though im not 1005 certain i believe Stonehearth may require SP1 to run…

but hey, im not a dev i dont know what runs the game :stuck_out_tongue:

Yeah, that’s what I thought. Doesn’t say anything apart from Windows 8.1. I’ll try to install it, see if it works and I’ll update :slight_smile: Thanks for helping!

if you dont mind, could you check if your laptop has SP1 installed? this would either confirm or deny my thoughts about having to have SP1 to run stonehearth.

8.1 is Windows 8 Service Pack 1. They decided to take off the Service pack part in the new version.


Hey @BlackRaven this is Gir (I can’t post for 22 hours since I posted too much O.O) But just search up windows update and it will take you to a screen (if your in the metro view) where you can see all the updates for your computer. Also @8BitCrab im not sure if there is a SP1 for 8.1 because windows 8’s “service pack” was the upgrade to 8.1 Though BlackRaven may be missing some important updates on his desktop

1 Like

well i dont know to much about Microsoft stuff, good to know that 8.1 includes SP1 :smile:

Don’t mean to highjack this thread but I can’t seem to post in the other thread without getting auto flagged >:( This is what I posted the first time @8BitCrab "Hey this is Gir (Dan Janes) I can’t do anything with it for 22 hours since I “preformed to many of the same action” (or something like that) so I can’t reply, send messages, or make new topics ) I can buy and sell any item. This only happens when I buy all of the same item. Maybe a index out of bounds error. But I would have thought that they they would have stored the items as int numbers. Then when they tried to store more than a certain amount of items in the same block it would give an error. But I don’t know much about C++ or Lua. Just java "

And the second post:
“Ya i was wondering how it got flagged a second after me posting… I hope @Gir Will be able to get full member status so I don’t have post like this”

1 Like

yep i knew what you posted, i clicked the “show post” button :wink:

something im starting to wonder about is, where are the mods? @SteveAdamo @Relyss and whoever else is a mod seem to have just disappeared from the discourse :confused:

@BlackRaven Try this “Change the screen resolution in the user_settings.json file (located inside the Stonehearth folder) to match your screen resolution”