[Res] 64 bit not working on 64 bit machine

Ever since I got the game, I have not been able to play Stonehearth on x64 despite my laptop being x64. I’ve tried deleting local content and reinstalling, that doesn’t work. No new games/patches seem to fix it either.

What basically happens, is that if I choose to play the game on x64, I can get through to the loading screen that usually has the tips and/or the picture in the background. Once the bar fills up it CTDs.

I’d really like to be able to play in x64 because it says it supports larger towns, and currently, my save is getting pretty large… and pretty laggy and unruly. Does anyone know a workaround/fix, or if there even is one?

1 Like

Others have suggested to do Windows Update and install the latest updates.

My computer has not notified me of needing to be updated or requiring an update, unless it’s something that doesn’t tell you about itself first.

It might be one of this programs interferring:

Since there’s another report out there that also has the same problem. Only crashes on 64bit, 32 bit runs fine. And devs looked at the crash report and it was a Lavasoft library, but they know of more libraries that can be conflictive with the game.

You can PM your user_id from your user_settings file to @Albert or to another dev, and they can see which one could be, if they find your crash.

May I ask what user_id you are referring to? Is there one for Stonehearth/Steam or what? :confused: Also where could I find it?

Sorry for the delay, @MyCoal417 . Real life is tiring

It’s in your Stonehearth folder, typically located on a path similar to this one: C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\user_settings.json

You can open it with any text editor. The first value in that file is usually the “user_id” which looks like a string of alphanumeric characters, with some hyphens.

1 Like

Any chance you’re running Lavasoft Ad-Aware? We had another guy with similar symptoms that were resolved when he uninstalled Ad-Aware (which has been verified to crash Stonehearth).


Holy crap I’m sorry for no replies or the showing/sending of the user_id. I most completely forgot about Stonehearth with Company of Heroes 2. I do not have Lavasoft, although it sounds familiar. Are there any other programs that could cause this?

Asides from the ones listed, which I have none of… unless Norton Security Suite is counted as similar to Norton 360. Because Trend Micro expired on me, I had to fall back to the basics. :stuck_out_tongue:

i would say they’re close enough alike.

but i guess @Albert is the one who should decide that.

Yes. I believe Norton Security Suite is the next generation that includes Norton 360 functionality.


That sucks. Norton’s all I got, and I’m sure I won’t be able to buy/pay for anything. I’m only getting Norton off of my mother’s Comcast or Xfinity account or something. Just updated to Windows 10, maybe something’ll work…?

  1. You might be able to tell Norton not to mess with Stonehearth.
  2. Microsoft Security Essentials is free and works really well as antivirus. Pretty much everyone I know has dropped 3rd party antivirus for this in the past few years.
  3. We (meaning us the developers) might be able solve this problem by running Chrome in sandboxed mode. We won’t be able to try this until Chromium embedded compiles on Visual Studio 2015 though. They (Google et al) are apparently working on this, but I have no idea how long it will take.

Okay, thanks! I’ll mess around and see what I can find. Good luck.

Update: It works! 64-bit works! I’m not sure if I even did anything to solve it or if it happened with Windows 10, or gradually, but Norton and Stonehearth had no problems.

1 Like

Yay! We’re glad it worked :smile:

I’ll tag this as resolved but leave it open in case you have problems again with it.

Thanks for the follow up!

1 Like

Well, I didn’t know it was possible, but I love the game even more now because of 64 bit. I can handle bugs, glitches, and game-breaking problems, but I was plagued with an issue where after an undefined period of time, saving would not work. That lead to me saving every five minutes, at least, and sometimes it still wasn’t enough to beat it. I would also have random CTD’s that usually accompanied the save bug and that sometimes caused me to get… very upset.

And it’s gone! [Insert South Park Meme here]

The only thing now is a horrible lagging during nighttime (I tried turning down lights and shadows, maybe I should do that some more?) and an occasional lag during the day.


the most likely cause is if you have lots of lanterns, or other light sources, they will tend to cause tons of lag at night, due to all the particle effects, shadows, etc…

[quote=“MyCoal417, post:16, topic:15417”]
(I tried turning down lights and shadows, maybe I should do that some more?)
[/quote]and that is the fix i was about to suggest, turning the amount of lights and shadows down during the night will help with the lag, due to the above mentioned things becoming less present.

Yeah, I’ve tried, and it doesn’t really help. I can live with it though, as it’s not present so much during the daytime. But it seems like it’s starting to creep into day, and LUA/Pathfinder is taking over, although I’m not seeing as many bugs or glitches as I’ve heard of around this point.

1 Like

hmm… how many hearthlings do you have? and how many in-game days have passed?

Oh boy, I’m on to about 22 hearthlings and it’s day one or two of the second month. Longest/biggest game I’ve had, I’m not about to give it up anytime soon though!

Especially the seed. If I do give it up, I’ll just make it on the same seed. It’s so cool - a pretty long lake next to some hills that forms long walls on two sides, only in the hills there’s about a 20-30 voxel wide valley leading to the other side. It’s awesome.