Steam A8 to A9 (dev 2283) Conversion Issue / Crash On Save

Title: Steam A8 to A9 (dev 2283) Conversion Issue / Crash On Save

Summary: I used Steam to update my game to the Alpha 9 develop-2283 (x64) version after downloading the original Alpha 8 from the original link sent to me in email when I purchased the game. After that, no new games would save and the game would hard-freeze on attempting to save game before exit. I tested this three times. Only killing it with task manager would exit and the saved game was lost. Later I went in as recommended by another gamer and deleted the entire Stonehearth folder from Steamapps and started from scratch. Upgraded to the A9 and played test run - Saved successfully multiple times, no freezing / no crashes.

Steps to reproduce:

  1. Download A8 version from email download link (external from Steam)
  2. Add game to Steam via Steam Key & then select optional beta download of A9 dev-2283
  3. Create new game - attempt to save and exit newly created game at any point.

Expected Results: Game should save normally under A9 save.

Actual Results: Game will freeze and lock up as soon as you hit the Save Game button and perma-freeze/crash.

Notes: I was then able to FIX this problem by completely removing Stonehearth from my Steam folder and starting over with a clean install directly from Steam, not using the original download I had started with. Downloaded Alpha 8, then upgraded that to Alpha 9, created game and was able to save the game, no freezing / no crash. There’s something wrong between the two versions on external vs. Steam.

Special thanks to @micheal_handy76_mh for suggesting I erase the game entirely and start over with Steam install - that worked!

Versions and Mods: Stonehearth 0.1.0 (develop 2283) x64 build / No Mods used.

System Information: Windows 7 Pro - 64bit / Intel i7 CPU / 6 GB RAM / NVIDIA GeForce GTX 650 Ti Boost

1 Like

Yep, been deleting the folder every update, learned that one several updates ago, was posted here somewhere

1 Like

It’s hard to distinguish this on Steam though because you download the Alpha 8 and then convert that to Alpha 9 just fine if you only use Steam to do so. If you do this from the two different download locations that’s when you run into trouble or at least I did. I’m pretty techie-comfortable with game installs and it didn’t occur to me that the build in Steam for A9 wasn’t compatible for upgrading like a ‘patch’ (much smaller file size) so yeah, obvious lesson learned is don’t try to keep Alpha 8 in there.

Oddly though, I downloaded 8 first on Steam this time around after deleting the old one and then ‘upgraded’ to 9 and this time it has no problems. That’s why I think the build from external and Steam must be different.

1 Like

if i recall i does say on the download page that you can either download the steam version, which will always be more stable or you can download manually and update it yourself, please be aware that this verision is more unstable than the steam build and you will have to manually update or something along those line :slight_smile:

Yeah I got that but I did it the other way around. I had the A8 version not from Steam, it’s the version I downloaded when I bought the game last week. Then I went and added my Steam Key and ran it that way (it worked)… Then I tried to download the new A9 from Steam on top of that and that’s when I got into trouble. I should have wiped all and started fresh with only Steam. :smile:

yeh :P… also, remember to flush everything on updating through steam (its sad that we don’t get to keep our old saves)

Just be careful if you have any build saves, which can be brought into the next update, make sure you move those over. I always make extra copy and save it to a folder on desktop.

Just so you know, anytime you buy something outside of steam, but gives you a key before downloading it, iF the game is a steam game or on steam. Always just directly go to steam and enter any key you get from sites to just to DL it and install from steam. Humble Bundle is known for this.

1 Like

hey there @Vexed … i’m changing this to a General Discussion, as the general rule of thumb (for now … and really throughout the entire Alpha stage) is that save games are not to be considered compatible between builds…

however, once we hit the Beta stage, we are more likely to see compatibility come into play… :+1:

I think you may have misunderstood the nature of the bug. It was not a saved game. It was a fresh, new game on a brand new install of Alpha 9. The freeze / crash happens when you attempt to save (NEW game).

Please re-read original because what the problem is - is a compatibility between the external client and the Steam client versions. I know I’m not going to be the only player to do this during the life-span of the game’s development into Steam release so it would be best if they knew it was an issue now before the angry bees on Steam hit it.

1 Like

apologies if I misunderstood! but I confess, i’m still confused…

if you are simply reporting that the save game process is failing on the most recent steam client (you lose me on the reference to previous builds), then this is indeed a valid bug report (but one that can be merged with existing “save game issues” that are very common)…

1 Like

i THINK i might know your problem a bit better now, and this is where steam gets confusing, and… cheecky…

ok, im saying something about myself here … i am/used to be/still am a pirate (but 100% bought this game, if any dev needs confirmation of this, then i do not mind)

what steam is allowed to do with their games and any game which has a steam key, is search your computer to see if you have another version of the game… if you do, then it doesn’t like you much and can do various things from making the versions incompatible/crash and in extream circumstances ban your steam account

Sources:

Banned for pirating a steam game from an unmentionable site… the game i downloaded first of all played fine, a few days later, it kept crashing to desktop… about half a month later, my account was suspended and had to create a new one (i don’t know if its the same issue here, as i am sure Radiant would have notified steam that they have 2 versions???)

Sorry, I’m probably over-complicating my explanation - I tend to do that! I’ll try to break it down like I did in the steps to reproduce in my original post:

1 - I bought the game from the humble bundle method like anyone not connected on Steam would do, installed it - Alpha 8 - game ran fine.

2 - Installed my Steam Key and decided to run the game (Alpha 8) via Steam - game ran fine.

3 - Decided to use Steam’s hidden beta opt-in option (see attached screenshot) to access the new unfinished Alpha 9 / Downloaded via Steam.

4 - Steam did not wipe out previous A8 - it just downloaded files for A9 on top of A8. You can’t actually use this method without having already downloaded the game I think.

5 - Started a new game, did not load any previous old saves from A8. Game started and played fine but when I attempted to Save, it immediately hard froze my PC (with a lot of beeping errors) and I had to use task manager to kill it.

6 - To fix, I had to completely remove the entire Stonehearth folder from Steam and start from scratch but here’s where it gets weird.

7 - Once again, it forced me to download Alpha 8, which I did. Then again I went to the Betas tab in Properties and selected to get the latest build - minimally tested.

8 - Again I started a new game (there were no saved games to load anyways since it was a fresh install).

9 - Game plays fine and saves fine. No freezing when I try to save game.

So what’s the key difference in the two scenarios? The only thing different in the first scenario where I had repeated crashing while trying to save was that I was using the original humble bundle downloaded Alpha 8 with the Steam client Alpha 9 opt-in over top of it.

It actually does work to just upgrade from Alpha 8 to Alpha 9 entirely within Steam without deleting your previous build of the game but only if you used Steam to download the original Alpha 8 and not Humble Bundle. Steam players will expect new versions to overwrite old ones and I realize the minimally tested versions are unstable and in a different category from most early access games and also Stonehearth isn’t even released on Steam yet.

The thing I am trying to communicate to the Devs is that there seems to be some version compatibility issues between the Humble Bundle Alpha 8 and the Steam Alpha 8 and they may either want to make sure the two versions match or that Steam isn’t somehow changing code in there to foul it up (and they might be doing that).

I actually had a very similar situation happen with StarMade game. I downloaded it from the dev’s website and then when he released it on Steam and I got a Steam Key, I had issues playing the game from Steam, it wouldn’t launch…there was a compatibility issue. Players won’t realize that and be frustrated out the wazoo.

Hope this helps clear up the confusion and someone checks this out before the game goes into Early Access on Steam because like I said, the general gamer populace on Steam are some angry beavers and much less polite about bug finding and crashes because of Steam version foul ups. :stuck_out_tongue: (though once it’s on Steam this issue should not happen except for those of us who had non-steam versions to start with)…

Edit: Adding a small screenshot of the hidden (most Steam players don’t know it’s there!) “Select the beta you would like to opt into” selection in Properties for Steam’s Stonehearth version so you can see where I’m talking about getting the version Alpha 8 to become Alpha 9 via Steam.

Have to admit, I’m a bit confused too. The two versions of the game (Steam and Humble Bundle) are not connected in any way (that’s the point of the DRM-free version you get from HB). Differences in game save versions aside, it’s two completely separate versions and installs of the game in entirely different locations on your computer.

Go to Steam, right click on Stonehearth and select Delete Local Content. This uninstalls the game.

Then right click Stonehearth and go to properties > Betas > and select latest - build from the drop down. You don’t have to have the earlier version installed first.

This works, I just did it to check again. When changing back and forth from one alpha version to another, it’s best to uninstall first just to make sure you have a clean install.

ahhhh, very well then… sorry, I completely missed this (most obvious, now) point! :blush:

you raise a good point, and I’m just not sure about the current stance on compatibility between the two clients… given their basic differences, perhaps it’s just not possible?

actually, now that I actually understand the point you’re trying to raise, I have to wonder if this has been brought up before… will take a closer look as soon as I’m at a PC… thanks!

yes you can… you just needed to copy and past the key into steam and download it that way, you did not need to download any of the zip files on the donlowd link scrren :slight_smile:

Bingo. I know y’all are confused but that actually is the problem. For many of us, a game is a game, and we may not understand the difference between downloading the game from Humble Bundle vs. downloading it from Steam being two different things at all and that the two aren’t compatible unless you delete one entirely before downloading from Steam. There needs to be some sort of warning when you download from Steam to remove previous client manually.

While I do understand it goes to different places on my computer when downloaded, I’m telling you there’s something in there that causes a hard lock crash no matter what if you do it that way and I’m not going to be the first or last player to do that I can guarantee. Players buy in early and then want their Steam key so they can play it via Steam and get updates that way. You didn’t have to tell me all the steps to get the beta updates or repeat the process to download from A8 to A9 as if you read my entire previous reply I already demonstrated that. THAT is not the problem. That works!

I believe this has something to do with save files as after really examining what was ‘different’ the first time, the only thing I can say is the save files were still there from my A8 previous load (the Humble Bundle one) even though I did not choose them or load an older saved game…they were still there and there was a red warning on them that they were incompatible/mismatched versions. I started a new game and that is the game that continually froze.

When I deleted the entire folder from both locations and started from scratch with nothing, I did download A8 from Steam and then A9 from the beta option tab as I put in the screenshot. This probably isn’t advisable but it does work and does save. Lots of players are going to do it that way since that’s the normal expectation for a game on Steam (I didn’t realize I should have deleted A8 first)

But anyways, I’ve tried really hard to explain this as best as I can, so if it still makes no sense, don’t know what to tell you. It will cause problems for some players who choose to buy the game externally and then switch over to Steam versions if they don’t do it properly (like I did) so I thought I’d try and head that off so the Devs could put a warning in there somewhere for Steam users who previously downloaded the Humble Bundle. Players who buy the game directly from Steam once it’s released there won’t have this issue as they will only be downloading the Steam version from the git go so I don’t think the ‘angry beavers’ I talked about will be as bad that route.

Yes I understand it’s always a good idea to wipe out old builds before installing new ones. I get it. I’m telling you not everyone will get it and there’s something incompatible if you don’t delete the Humbe Bundle A8 before going into Steam to play A9. That’s all it was, an overcomplicated issue. I’ll stop ranting about it now. :stuck_out_tongue:

ok first of all sorry for my confusion, second of all thanks for trying to explaine… as i am no dev or official games tester, i am still slightly confused (althouhg i do understand that they are seperate files…

Have you made 2 short cuts on your desk top? maybe rename then (so that the steam version is called something like Steam-hearth and the other stonehearth?

also have you actually checked the save location of both downloads to check if they are not saving to the same location? sorry for my dumbness here

It’s ok, I probably come across snippy with long replies. I need to learn brevity and bland typing (I’m a hot-headed AI) :wink:

I’ve actually fixed the whole thing by wiping everything out and starting fresh so I don’t have this problem anymore. I’m just adamantly sticking to the argument because it was a serious game-crashing issue and has only to do with loading the game one way and then trying to go over to Steam and upload that untested A9 version. That’s a pretty narrow test case, and edge case if you will (my company’s name!). Not many are going to repeat the process ridiculously like I did but I suspect others might at least as the game transitions from external to Steam fully. This was supposed to be a heads up type thing, not necessarily a true “bug” report - but rather, “hey be careful how you download this if you try and go from Humble Bundle to Steam as it can really jack your PC up!”

1 Like

To have experienced such a bug, you must have downloaded the game in a folder, and then later Steam pointed again to that same folder (if not, you shouldn’t have been able to see the old savegames or files). Perhaps you did it on purpose, perhaps not.

It’s weird because if you download first from humble bundle, you’re not keeping the game inside your Steam folder, you’d probably make another one on your PC to save the game there. (Steam players would probably use the key right away, as it’s stated above that you don’t need to download the Humble Bundle version first). Although I don’t remember if Steam asks you (at some point) where do you have/want to have the game’s folder??