[Con] Saved game disappeared

ok so, heres a bug.

  1. play a game
  2. save, then over right that save (times 10 or so)
  3. keep playing, try to save that file again
  4. BOOM disappeared.
  5. RAGE

exiting the game and restarting doesnt work. it will only show 2 options at the main menu, quick start and play, no option to continue or load a save.

anyone run into this ? or how to fix it ?
i played for about 4 or so hours and i would hate to lose my dam save

(alpha 7) although, its been happening since awhile back
windows 8.1


hmm… have you confirmed the actual save game file is missing from the saves folder?

the save is infact inside the folder still, its just that the game doesnt see the save file anymore it looks like it

This happens to me a lot. The only file generated in the save folder is client_state.bin all others are missing.

I have just encountered this as well, it is only creating the client_state.bin file on save. All I see in the stonehearth.log at the time I save is:

2014-Dec-19 16:10:01.441295 | client | 0 | client | starting save.
2014-Dec-19 16:10:01.585302 | client | 0 | client | saved.

And yet it only generated the one file. Not much help there.

The only thing interesting I can say is this is happening after running the game for over an hour with a lot of construction going on in my game. Will tinker around and see if there is an easier way to reproduce this.


I can successfully save then five minutes later failure. I’ve tried when mining huge areas and I’ve tried when everything is quiet. It doesn’t seem to matter. It appears to be completely random to me. I’ll post fresh logs after some more play.

I think I just made an interesting find. Whenever this bug occurs, I can load up a completely unrelated save and the bug persists and will not complete the save.

This might not sound significant, but it means the problem is probably related to the instance of the client/server, not the scenario currently being played. This could also explain whey it happens so randomly, as BlockHeadTimo stated.

Hope this helps.


I have saved the log files generated each time I have recently experience the failed save issue. Five times in the last 1.5 hours and once in the wee hours this morning. I hope these may help the developer in tracking down the issue.

Thanks again for the great game and the fantastic support!

Failed save followed by crash to desktop
Failed save followed by crash to desktop
Failed save followed by crash to desktop
Failed save - no crash
Failed save - no crash

1 Like

its sad to see that so many people are having this issue, to play for so long and build so many things and then not being able to play that save is super frustrating

Can confirm this bug, it has happened to me a few times now.

I’ve collected some more logs and zipped up a bunch of saved game files (or the attempt to save.)

At this point I find myself not able to play more than 3 minutes before a crash to desktop or saving the game fails. Rage quiting and screaming at my computer have become the norm and not acceptable! I’m leaving these files with you so maybe you can figure out what’s happening.

In the meantime I’m completely wiping out the Steam files and downloading anew. A fresh new install! A fresh start! I’ll keep you posted on progress.

Thanks again! I’m liking the game but becoming very frustrated with these little hiccups. I just have to keep telling myself It’s alpha… It’s alpha… It’s alpha… you’re helping quash the bugs. You’re helping. Helping is good. :smile:

15 saved games - only two successful
Failed save followed by crash to desktop
Failed save followed by crash to desktop
Failed save – resulting in much swearing and rage quit


I personally have clocked saves, it seems almost exactly every 9 minutes of gameplay for me causes one of these crashes.

I too like everyone here have experienced this issue, And the more you play the higher chance you have of it happening. A work around is to create multiple saves. Nothing causes it, And for me 90% of the time it won’t even give error messages it pretty much just deletes the file, it won’t allow me to make a new save file.If you try clicking on another save file it will also delete that until you reload the game.


I can confirm this Also, just recently I had a small town going. A huge mine and was starting to build Houses for all 17 of my villagers. And making walls around village. I had 22 saves at that point, and it wouldn’t let me save anymore, it was deleting saves. so I cleaned up saves and it started to let me save again for a bit till my 6th save then it just deleted all of them. and couldn’t save anymore. I thought it was the game itself struggling with so much going on, but guess not. So, yeah to the point I can confirm this bug. Love the game though and will keep playing even with this bug, I will look for a work around in the mean time, like maybe cleaning the folder out here and there and see if that works.

Okay found a work around. It works for me at this point. It’s a lil trouble, but worth it. When you save games. go to save folder and make copies and put in a separate fold off to side. when the game starts deleting and not allowing saves. just delete all saves in that save folder. basically starting the game over. Now move all your copied saves u made into the save folder. and you have your saves back. I know its a lil pain but it’s the best i can find. it works for me.

1 Like

well lets hope they get a real fix for this soon, maybe in the next update ? @sdee

Confirmed it on build 180 and 183 that the save that goes missing is still occuring. For me, it usually happens around day 20. Rage! xD

Before seeing this post, I tried that too, but got really lazy of doing that over and over again. Maybe a copy of saves every 3 days might work, but I’d probably get tired of doing that, too. ;/

just happend to me as well. i can’t make a new save file anymore im about 30-31 crossing into day 1 again and it wont make a new save anymore, trying to overwrite removes any old save.

The cause appears to be that the server side crashes but doesn’t notify the client. When the save is executed the client saves it’s state but is unable to notify the server to save it’s state as well due to the crash. I’ve seen this a number of times myself and typically make a habit of just always saving as a new save each time instead of overwriting, just in case.