Corrupted Save Files

3 times now I’ve gone to save after playing for a couple hours and nothing happens. It doesn’t show any saved files and won’t let me create a new one. I’ve tried to overwrite current file (even though none were showing) and it acts like it did. But when you start the game up it starts a new game as all the save files are gone. or their pointers are. If you then try to save the same thing happens you can’t. Going to the save files and deleting the last one doesn’t help. Normal Steam uninstall reinstall doesn’t help. After I uninstall I have to go to the local files and delete them all. Then I can reinstall via Steam.
So not just 1 file is getting corrupted. All of them are. win8.1 pro x64, nvidia 750ti running beta drivers , no mods, hero motherboard intel i7 4471 quad. 16 gigs ram.DEAKON-PC.txt (98.4 KB)

so you can save, you simply cant load previous saves… correct?

can you attach your most recent save here? I haven’t even checked for the file extensions, to see if they are allowed here…

I think have a variant of your problem too, except mine is worse.

After a world corruption, I couldn’t save or load any previous save files. I really want to save my games, especially if this Alpha is really unstable and is the biggest update for Stonehearth yet.

No that’s the problem. It wouldn’t let me save. I am already on a fresh install again. If/when it happens again I’ll dump the save folder to where you can get to it. And add a screen shot to clarify it.

1 Like

@SteveAdamo I couldn’t get a screen shot because my system froze up this time. I cheated and dropped the stonehearth folder onto google drive. that way you can pick through logs saved files whatever.

1 Like

I think your problem is similar to what happened to me and @Geoffers747 helped me out. When I tried to save nothing would appear, and I couldnt load any save (because there were none!) so I had to delete all the files in the “saved games” folder (you will lose every save, it’s a pitty) and then you will be able to save again, you don’t need to uninstall the whole game.

Edit: Wasn’t @EpicDwarf who helped me out, it was @Geoffers747, sorry lord.



thanks @TRJ@deakon, can you give that a go and let us know if it works for you?

Thanks @TRJ! I’ll try it out and report the conclusion.

So, wait, I found the saved games folder, do I delete every folder in it?

You only have to delete the most recent ones till you find the save that’s corrupted. You can copy the folder elsewhere so you have backups before you delete!

Thanks I’ll try that the next time I kill it

I didn’t want to correct you earlier because I’m not that narcissistic, but if you make that mistake again I will imprison you for eternity. You don’t want that. You don’t want that at all my friend.

1 Like

So, I deleted the last 10 save files.

Well, that didn’t work.

I deleted half of the save files.

That didn’t work.

I deleted all the save files.

That worked. :smiley:


Oh lord, I’m just a humble settler, I dont wan’t to be target of your wrath. Be lenient lord.

1 Like

nice! when in doubt, employ the Alien Methodology: nuke it from orbit, just to be sure! :smile:

1 Like

So, recently I’ve had a problem with saving and loading Stonehearth games. For some reason, all of my saves were deleted (which is fine, they weren’t too important), but I can’t seem to create any new saves (I’m on the current alpha snapshot). Is this related to the situations above, and what is the method to restoring the save feature? I’m not sure how to view Stonehearth local files outside of the game to check them.

I uninstalled and reinstalled Stonehearth on Steam, but so far, it seems to still have the same issue.

This is a common problem that I have experienced myself.

To fix it you must access Stonehearth’s local files. Then, you must locate the folder named “saved games”. You can find this exact file by searching for it in Microsoft Windows’s built in search function. After that, you have to delete every file in that folder. Each file in the folder is a savefile of your games. After that, Stonehearth should work properly.

Thanks–right as you posted this, I found the saved games folder through Steam. Working like a charm now.

Thanks for all your help!

i opened my save file but only a blank screen showed the game was still running, i could hear my peeps working and stuff but couldn’t see crap. i tried a bunch of buttons but nothing worked.