223 not leaving any save .bin files behind when 'save new' fails

Used to be you’d be left with two .bin files in the tmp_save directory when your ‘save new’ failed, but now (last few times I tried), you’re left with nothing. So, it seems that after hours of playing, you have no chance to save your progress buy using the two .bin files with an existing .json and screenshot files.

Could you post a stonehearth.log file where your save failed, please? Thanks!

Thought about this last night. At work now, so I’ll post as soon as I get home.

@Ponder, here’s my log file: stonehearth.txt (120.4 KB)


That is just weird! I’m looking at these lines in particular, about 30 minutes into your play session.

2015-Mar-16 20:02:48.757120 | client | 0 | client.core | starting save.
2015-Mar-16 20:02:48.829124 | client | 0 | client.core | saved.
2015-Mar-16 20:02:48.875126 | server | 0 | simulation.core | Starting save.
2015-Mar-16 20:02:53.364383 | server | 0 | simulation.core | Saved.
2015-Mar-16 20:02:53.366383 | server | 1 | lua.memory | not using low memory allocator
2015-Mar-16 20:02:53.389385 | client | 1 | client.core | moving C:/Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games\tmp_save to “C:/Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games\1426550568433”

It looks like the save worked! Is there a 1426550568433 directory your saved_games folder? Did you try to save after this?

@Ponder, Yeah, it saved initially, but then failed two times afterwards. Here’s a fresh log file from a fresh install (previous install deleted). New game started from scratch.

stonehearth.txt (21.4 KB)

…with this line just as the save-new failed (and nothing in the tmp_save directory: 2015-Mar-17 20:57:17.540863 | client | 1 | rpc | critical error in http reactor: bad allocation

The only ‘numbered’ directory I have was from the last save a half hour earlier (2015-Mar-17 20:18).

‘Save-New’ just sits there and doesn’t generate a new snapshot (how we know the save failed). I then go check the directories out and then see there are no current save files at all, anywhere. (use to at least drop two .bin files in the tmp directory)