The game crashing instantly when opening game

Every time that I open stoneheath it instantly crashes and I don’t know why can someone plz help me :cry:

2 Likes

Hi @Lord_Doomsday welcome to the discourse.

I’m sorry you’re having this problem, can you please specify your computers specs and any other applicable information so our illustrious forum members can assist you.

Thanks

3 Likes

are you playing the humble bundle or steam version of the game? and as @TurtleSquish said what are your system specs, also are you attempting to run the 64-bit or 32-bit version?

1 Like

I have the humble bundle I’m gonna check later if I have the 64 or 32 bit

1 Like

Update your graphics drivers from the vendor website. Also, try updating your intel drivers, if appropriate!

1 Like

What’s the difference of the 32 and 64 bit version?

the 32-bit version runs smoother on 32-bit machines and 64-bit version runs smooth on 64-bit machines, generally a 32-bit machine wont run a 64-bit game smoothly and vice versa.

check your computer specs and it should say whether you have a 32-bit or 64-bit machine.

I have a 64 bit operating system but how can I check what operating system does the game has?

1 Like

go into your stonehearth folder, open up the user_settings.json somewhere in there it should say

“enable_64_bit” : true

if it says “false” intead of “true” then 64-bit isnt enabled, change it to true and then you will be running the 64-bit version :smile:

this is what i got 2015-May-16 13:36:39.762093 | server | 1 | app | Stonehearth Version 0.1.0.256 (x64)
2015-May-16 13:36:39.778098 | server | 1 | core.config | user id is 84ca921e-dbc5-11e4-b909-0c84dcf561ec
2015-May-16 13:36:39.778098 | server | 1 | core.config | session id is 1beb5cc2-fbf2-11e4-b947-0c84dcf561ec
2015-May-16 13:36:39.789721 | server | 1 | core.timer | QPC count: 855712709289, frequency: 2435874
2015-May-16 13:36:39.789721 | server | 1 | core.timer | QPC count: 855712709438, frequency: 2435874
2015-May-16 13:36:39.789721 | server | 1 | core.timer | QPC count: 855712709625, frequency: 2435874
2015-May-16 13:36:39.789721 | server | 1 | core.timer | QPC count: 855712709758, frequency: 2435874
2015-May-16 13:36:39.789721 | server | 0 | core.system | Initializing crash reporter
2015-May-16 13:36:40.350986 | server | 0 | lua.code | lua jit disabled in 64-bit builds. set force_lua_jit to override
2015-May-16 13:36:40.395884 | server | 0 | lua.data | lua jit is disabled
2015-May-16 13:36:43.444371 | server | 1 | resources | Modules are verified pristine.
2015-May-16 13:36:43.501039 | server | 1 | app | Running Stonehearth server on port 33739
2015-May-16 13:36:45.228634 | client | 1 | horde.general | Initializing GL2 backend using OpenGL driver ‘4.0.0 - Build 10.18.10.3958’ by ‘Intel’ on 'Intel® HD Graphics 4000’
2015-May-16 13:36:45.540857 | server | 1 | lua.code | could not find path for lua script “lualibs/unclasslib.lua”.
2015-May-16 13:36:45.684705 | server | 1 | lua.code | could not find path for lua script “modules/common.lua”.
2015-May-16 13:36:45.684705 | server | 1 | lua.code | could not find path for lua script “modules/timer.lua”.
2015-May-16 13:36:45.782681 | server | 1 | lua.code | could not find path for lua script “stonehearth/stonehearth/lib/loot_table/loot_table.lua”.
2015-May-16 13:36:45.812869 | server | 0 | mod stonehearth | greedy task scheduling enabled
2015-May-16 13:36:45.825878 | server | 1 | lua.code | could not find path for lua script “stonehearth/radiant/modules/filtered_trace.lua”.
2015-May-16 13:36:45.858724 | server | 1 | lua.code | could not find path for lua script “stonehearth/stonehearth/lib/entity_forms/entity_forms_lib.lua”.
2015-May-16 13:36:46.851780 | server | 2 | network | server allocating new send buffer (total: 0)
2015-May-16 13:36:46.940177 | server | 2 | network | server allocating new send buffer (total: 0)
2015-May-16 13:36:46.990623 | server | 2 | network | server allocating new send buffer (total: 0)
2015-May-16 13:36:47.042801 | server | 2 | network | server allocating new send buffer (total: 0)
2015-May-16 13:36:47.093902 | server | 2 | network | server allocating new send buffer (total: 0)
2015-May-16 13:36:47.144989 | server | 2 | network | server allocating new send buffer (total: 0)
2015-May-16 13:36:47.195532 | server | 2 | network | server allocating new send buffer (total: 0)
2015-May-16 13:36:47.246885 | server | 2 | network | server allocating new send buffer (total: 0)
2015-May-16 13:36:47.297710 | server | 2 | network | server allocating new send buffer (total: 0)
2015-May-16 13:36:47.348849 | server | 1 | simulation.remote_client | started buffering client updates. (seq:10 ack:0)
2015-May-16 13:36:48.620733 | client | 1 | browser | cef started.
2015-May-16 13:36:48.894208 | client | 2 | browser | Navigate called without an existing browser!
2015-May-16 13:36:49.322947 | client | 1 | lua.code | could not find path for lua script “lualibs/unclasslib.lua”.
2015-May-16 13:36:49.326947 | client | 1 | lua.code | could not find path for lua script “modules/common.lua”.
2015-May-16 13:36:49.327949 | client | 1 | lua.code | could not find path for lua script “modules/timer.lua”.
2015-May-16 13:36:49.329949 | thread8080 | 2 | browser | Doing a buffered navigation…
2015-May-16 13:36:49.389329 | client | 2 | network | client allocating new send buffer (total: 0)
2015-May-16 13:36:49.526737 | client | 1 | client.core | user feedback is off

Could be wrong usually am, But as @sdee Said, Is your graphics drive updated? Along side other updates? Any tiny updates could help.

Hope this helped!

2 Likes

After I went here I contacted the developers and asked them how should I fix it they said the same thing my graphics drive is updated my friends are telling me to give up but it’s just that I paid 2 times for this game and it’s just sooo awesome that’s why I haven’t given up

you paid twice?!?!?!?!

Yeah the first time I paid it I couln’t find the game in my computer so I had to pay twice

oh dear! i feel bad for you :fearful:

it seems like you should have been able to contact the Humble Bundle staff to help out… :confused:

but hey, if you love the game so much your willing to pay twice thats cool :smile:

Another frequently asked question here that can cause play issues, do you have Service Pack 1 installed? It’s been known to have issues without that installed.

1 Like

But that’s why I made this chat because it’s instantly crashing

Service pack 1 ehh haven’t heard of it

1 Like

what are your computer specs? and what version of windows do you have?

I coun’t contact the humble bundle staff I contacted the game creators